summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-02-21 11:37:10 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-02-21 11:37:10 +0000
commit4376a28973cb4588da643d01b9b45e935d5187e7 (patch)
tree82893c8f1572309218fa141681498eab38c1f632 /media-tv/livestation
parentBump for #306065, thanks to Priit Laes for the test fixes (diff)
downloadgentoo-2-4376a28973cb4588da643d01b9b45e935d5187e7.tar.gz
gentoo-2-4376a28973cb4588da643d01b9b45e935d5187e7.tar.bz2
gentoo-2-4376a28973cb4588da643d01b9b45e935d5187e7.zip
Version bump wrt #305151, thanks to "hitachi" for reporting.
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'media-tv/livestation')
-rw-r--r--media-tv/livestation/ChangeLog8
-rw-r--r--media-tv/livestation/livestation-3.1.0.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/media-tv/livestation/ChangeLog b/media-tv/livestation/ChangeLog
index 30603a57188c..28b3a50a6d5d 100644
--- a/media-tv/livestation/ChangeLog
+++ b/media-tv/livestation/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-tv/livestation
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/livestation/ChangeLog,v 1.7 2010/01/01 15:19:11 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/livestation/ChangeLog,v 1.8 2010/02/21 11:37:10 ssuominen Exp $
+
+*livestation-3.1.0 (21 Feb 2010)
+
+ 21 Feb 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +livestation-3.1.0.ebuild:
+ Version bump wrt #305151, thanks to "hitachi" for reporting.
01 Jan 2010; Samuli Suominen <ssuominen@gentoo.org>
livestation-3.0.0.ebuild:
diff --git a/media-tv/livestation/livestation-3.1.0.ebuild b/media-tv/livestation/livestation-3.1.0.ebuild
new file mode 100644
index 000000000000..374c76f7724f
--- /dev/null
+++ b/media-tv/livestation/livestation-3.1.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/livestation/livestation-3.1.0.ebuild,v 1.1 2010/02/21 11:37:10 ssuominen Exp $
+
+inherit eutils
+
+DESCRIPTION="Watch live, interactive TV and radio on the Livestation player"
+HOMEPAGE="http://www.livestation.com"
+SRC_URI="http://updates.${PN}.com/releases/${P/l/L}.run"
+
+LICENSE="GPL-3 LGPL-3 Livestation-EULA"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+EMUL_VER=20091231
+
+RDEPEND="amd64? ( >=app-emulation/emul-linux-x86-baselibs-${EMUL_VER}
+ >=app-emulation/emul-linux-x86-xlibs-${EMUL_VER}
+ >=app-emulation/emul-linux-x86-qtlibs-${EMUL_VER} )"
+DEPEND=""
+
+MY_PN=${PN/l/L}
+
+QA_TEXTRELS="opt/${MY_PN}/lib/*"
+QA_DT_HASH="opt/${MY_PN}/${MY_PN}.bin opt/${MY_PN}/lib/.* opt/${MY_PN}/plugins/imageformats/.*"
+QA_PRESTRIPPED="opt/${MY_PN}/${MY_PN}.bin opt/${MY_PN}/lib/.* opt/${MY_PN}/plugins/imageformats/.*"
+
+RESTRICT="mirror"
+PROPERTIES="interactive"
+
+S=${WORKDIR}/i386
+
+pkg_setup() {
+ check_license Livestation-EULA
+}
+
+src_unpack() {
+ unpack_makeself
+}
+
+src_install() {
+ local dest=/opt/${MY_PN}
+
+ dodir ${dest}
+ cp -dpR *.{bin,conf} plugins "${D}"/${dest} || die
+ rm -f lib/{libcrypto.so.0.9.8,libssl.so.0.9.8,libXtst.so.6,libQt*} || die
+ exeinto ${dest}/lib
+ doexe lib/* || die
+ dosym plugins/imageformats ${dest}/imageformats || die
+ dodoc README
+
+ newicon "${FILESDIR}"/${PN}_icon.svg ${PN}.svg
+ make_wrapper ${PN} ./${MY_PN}.bin ${dest} ${dest}/lib
+ make_desktop_entry ${PN} ${MY_PN} ${PN}
+}