summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2009-07-18 16:14:05 +0000
committerSteve Arnold <nerdboy@gentoo.org>2009-07-18 16:14:05 +0000
commitf02834d6e44bc335821171f0fab5138fe72f7516 (patch)
treeb90ae560e4a1c8aab0ec8b4e9e0756f416c5b7c1 /media-sound
parentRepoman warngs (diff)
downloadgentoo-2-f02834d6e44bc335821171f0fab5138fe72f7516.tar.gz
gentoo-2-f02834d6e44bc335821171f0fab5138fe72f7516.tar.bz2
gentoo-2-f02834d6e44bc335821171f0fab5138fe72f7516.zip
Updated to current upstream release with support for newer kernels.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/line6usb/ChangeLog11
-rw-r--r--media-sound/line6usb/line6usb-0.7.3.ebuild7
-rw-r--r--media-sound/line6usb/line6usb-0.8.1.ebuild102
3 files changed, 115 insertions, 5 deletions
diff --git a/media-sound/line6usb/ChangeLog b/media-sound/line6usb/ChangeLog
index 0d3fabc0e9d8..d78a7b11d1fd 100644
--- a/media-sound/line6usb/ChangeLog
+++ b/media-sound/line6usb/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/line6usb
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/line6usb/ChangeLog,v 1.2 2008/10/18 06:16:23 nerdboy Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/line6usb/ChangeLog,v 1.3 2009/07/18 16:14:05 nerdboy Exp $
+
+*line6usb-0.8.1 (18 Jul 2009)
+
+ 18 Jul 2009; Steve Arnold <nerdboy@gentoo.org> line6usb-0.7.3.ebuild,
+ +line6usb-0.8.1.ebuild:
+ Updated to current upstream release with support for newer kernels
+ (see bug # 278164).
18 Oct 2008; Steve Arnold <nerdboy@gentoo.org> line6usb-0.7.3.ebuild:
Updated Makefile by replacing uname-based paths with ebuild vars; fixes
diff --git a/media-sound/line6usb/line6usb-0.7.3.ebuild b/media-sound/line6usb/line6usb-0.7.3.ebuild
index be3608464cda..7c68054ad887 100644
--- a/media-sound/line6usb/line6usb-0.7.3.ebuild
+++ b/media-sound/line6usb/line6usb-0.7.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/line6usb/line6usb-0.7.3.ebuild,v 1.3 2008/10/18 06:16:23 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/line6usb/line6usb-0.7.3.ebuild,v 1.4 2009/07/18 16:14:05 nerdboy Exp $
inherit linux-mod eutils multilib linux-info
@@ -22,9 +22,10 @@ ERROR_PODXTPRO="${P} requires the podxtpro driver to be removed first."
RDEPEND="virtual/modutils
dev-lang/perl"
+
DEPEND="${RDEPEND}
virtual/alsa
- virtual/linux-sources
+ <virtual/linux-sources-2.6.25
sys-apps/debianutils"
pkg_setup() {
diff --git a/media-sound/line6usb/line6usb-0.8.1.ebuild b/media-sound/line6usb/line6usb-0.8.1.ebuild
new file mode 100644
index 000000000000..9c363bf094b0
--- /dev/null
+++ b/media-sound/line6usb/line6usb-0.8.1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/line6usb/line6usb-0.8.1.ebuild,v 1.1 2009/07/18 16:14:05 nerdboy Exp $
+
+inherit linux-mod eutils multilib linux-info
+
+DESCRIPTION="Experimental USB driver for Line6 PODs and the Variax workbench."
+HOMEPAGE="http://www.tanzband-scream.at/line6/"
+SRC_URI="http://www.tanzband-scream.at/line6/download/${P}.tar.bz2
+ doc? ( http://www.tanzband-scream.at/line6/driverdocs.pdf )"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+# needs testing/keywording with 2.6 kernels on ~ppc/ppc64 (should work)
+IUSE="doc"
+
+CONFIG_CHECK="USB SOUND"
+MODULE_NAMES="line6usb(usb:${S}:${S})"
+ERROR_PODXTPRO="${P} requires the podxtpro driver to be removed first."
+
+RDEPEND="virtual/modutils
+ dev-lang/perl"
+DEPEND="${RDEPEND}
+ virtual/alsa
+ >=virtual/linux-sources-2.6.25
+ sys-apps/debianutils"
+
+pkg_setup() {
+ ABI="${KERNEL_ABI}"
+ linux-mod_pkg_setup
+ BUILD_PARAMS="LINUX_DIR=${KV_DIR} OUTPUT_DIR=${KV_OUT_DIR}"
+ check_upgrade
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ convert_to_m Makefile
+
+ sed -i \
+ -e "s:/lib/modules/\$(shell uname -r)/build:${KERNEL_DIR}:g" \
+ -e "s:\$(shell uname -r):${KV_FULL}:g" \
+ -e "s:\$(shell pwd):${S}:g" \
+ Makefile || die "sed failed!"
+}
+
+src_compile() {
+ # linux-mod_src_compile doesn't work here
+ set_arch_to_kernel
+ cd "${S}"
+ emake KERNEL_LOCATION="${KERNEL_DIR}" || die "emake failed."
+}
+
+src_install() {
+ DESTDIR="${D}" make install-only || die "make install failed"
+
+ # remove some cruft
+ rm "${D}"usr/bin/remove_old_podxtpro_driver.sh
+
+ dodoc INSTALL
+ if use doc; then
+ insinto /usr/share/doc/${P}
+ doins "${DISTDIR}"/driverdocs.pdf
+ fi
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ elog
+ elog "This is an experimental driver. Not responsible for runaway dogs,"
+ elog "hair-loss, or sterility. You have been warned..."
+ elog
+}
+
+check_upgrade() {
+ local old="podxtpro.${KV_OBJ}"
+ local new="line6usb.${KV_OBJ}"
+ if [[ -e \
+ "/lib/modules/${KV_FULL}/kernel/sound/usb/${old}" ]]; then
+ eerror "The previous version of the driver called podxtpro"
+ eerror "exists on your system."
+ eerror
+ eerror "Please completely remove the old driver before trying"
+ eerror "to install ${P}."
+ eerror
+ die "upgrade not possible with existing driver"
+ elif [[ -e \
+ "/lib/modules/${KV_FULL}/kernel/sound/usb/${new}" ]]; then
+ ewarn
+ ewarn "Collisions are expected here, if you removed the ebuild"
+ ewarn "(because kernel modules are protected by default). Use"
+ ewarn "FEATURES=-collision-protect emerge ... for this package,"
+ ewarn "or remove the old kernel module (${new}) manually first"
+ ewarn "from /lib/modules/${KV_FULL}/kernel/sound/usb/"
+ ewarn
+ has collision-protect "${FEATURES}" &&
+ die 'incompatible with FEATURES=collision-protect'
+ fi
+}