summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2008-05-03 11:23:15 +0000
committerCédric Krier <cedk@gentoo.org>2008-05-03 11:23:15 +0000
commitea873fec650a52557a3916bc65ef09547dfccd1c (patch)
tree0f57b6f9204cfd3898180a5d6615b2b9db3f1fb7 /media-sound
parentAdd patch for gcc-4.3, bug #219809 (diff)
downloadgentoo-2-ea873fec650a52557a3916bc65ef09547dfccd1c.tar.gz
gentoo-2-ea873fec650a52557a3916bc65ef09547dfccd1c.tar.bz2
gentoo-2-ea873fec650a52557a3916bc65ef09547dfccd1c.zip
Remove old
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/chuck/ChangeLog6
-rw-r--r--media-sound/chuck/chuck-1.2.0.7.ebuild72
-rw-r--r--media-sound/chuck/chuck-1.2.1.0.ebuild72
3 files changed, 5 insertions, 145 deletions
diff --git a/media-sound/chuck/ChangeLog b/media-sound/chuck/ChangeLog
index bf5808577300..07da0fd2a739 100644
--- a/media-sound/chuck/ChangeLog
+++ b/media-sound/chuck/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/chuck
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/chuck/ChangeLog,v 1.7 2008/05/03 11:22:02 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/chuck/ChangeLog,v 1.8 2008/05/03 11:23:15 cedk Exp $
+
+ 03 May 2008; Cédric Krier <cedk@gentoo.org> -chuck-1.2.0.7.ebuild,
+ -chuck-1.2.1.0.ebuild:
+ Remove old
03 May 2008; Cédric Krier <cedk@gentoo.org>
+files/chuck-1.2.1.1-gcc43.patch, chuck-1.2.1.1.ebuild:
diff --git a/media-sound/chuck/chuck-1.2.0.7.ebuild b/media-sound/chuck/chuck-1.2.0.7.ebuild
deleted file mode 100644
index e32b46079c40..000000000000
--- a/media-sound/chuck/chuck-1.2.0.7.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/chuck/chuck-1.2.0.7.ebuild,v 1.2 2007/03/18 13:20:38 opfer Exp $
-
-inherit toolchain-funcs flag-o-matic
-
-DESCRIPTION="Strongly-timed, Concurrent, and On-the-fly
-Audio Programming Language"
-HOMEPAGE="http://chuck.cs.princeton.edu/release/"
-SRC_URI="http://chuck.cs.princeton.edu/release/files/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86"
-IUSE="oss jack alsa examples"
-
-RDEPEND="jack? ( media-sound/jack-audio-connection-kit )
- alsa? ( >=media-libs/alsa-lib-0.9 )
- media-libs/libsndfile"
-DEPEND="${RDEPEND}
- sys-devel/bison
- sys-devel/flex"
-
-pkg_setup() {
- local cnt=0
- use jack && cnt="$((${cnt} + 1))"
- use alsa && cnt="$((${cnt} + 1))"
- use oss && cnt="$((${cnt} + 1))"
- if [[ "${cnt}" -eq 0 ]] ; then
- eerror "One of the following USE flags is needed: jack, alsa or oss"
- die "Please set one audio engine type"
- elif [[ "${cnt}" -ne 1 ]] ; then
- ewarn "You have set ${P} to use multiple audio engine."
- fi
-}
-
-src_compile() {
- local backend
- if use jack ; then
- backend="jack"
- elif use alsa ; then
- backend="alsa"
- elif use oss ; then
- backend="oss"
- fi
- einfo "Compiling against ${backend}"
-
- # when compile with athlon or athlon-xp flags
- # chuck crashes on removing a shred with a double free or corruption
- # it happens in Chuck_VM_Stack::shutdown() on the line
- # SAFE_DELETE_ARRAY( stack );
- replace-cpu-flags athlon athlon-xp i686
-
- cd "${S}/src"
- emake -f "makefile.${backend}" CC=$(tc-getCC) CXX=$(tc-getCXX) || die "emake failed"
-}
-
-src_install() {
- dobin src/chuck
-
- dodoc AUTHORS DEVELOPER PROGRAMMER QUICKSTART README THANKS TODO VERSIONS
- docinto doc
- dodoc doc/*
- if use examples; then
- insinto /usr/share/doc/${P}/examples
- doins `find examples -type f`
- for dir in `find examples/* -type d`; do
- insinto /usr/share/doc/${P}/$dir
- doins $dir/*
- done
- fi
-}
diff --git a/media-sound/chuck/chuck-1.2.1.0.ebuild b/media-sound/chuck/chuck-1.2.1.0.ebuild
deleted file mode 100644
index 51d0716fd6d2..000000000000
--- a/media-sound/chuck/chuck-1.2.1.0.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/chuck/chuck-1.2.1.0.ebuild,v 1.1 2007/08/23 22:01:34 cedk Exp $
-
-inherit toolchain-funcs flag-o-matic
-
-DESCRIPTION="Strongly-timed, Concurrent, and On-the-fly
-Audio Programming Language"
-HOMEPAGE="http://chuck.cs.princeton.edu/release/"
-SRC_URI="http://chuck.cs.princeton.edu/release/files/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="oss jack alsa examples"
-
-RDEPEND="jack? ( media-sound/jack-audio-connection-kit )
- alsa? ( >=media-libs/alsa-lib-0.9 )
- media-libs/libsndfile"
-DEPEND="${RDEPEND}
- sys-devel/bison
- sys-devel/flex"
-
-pkg_setup() {
- local cnt=0
- use jack && cnt="$((${cnt} + 1))"
- use alsa && cnt="$((${cnt} + 1))"
- use oss && cnt="$((${cnt} + 1))"
- if [[ "${cnt}" -eq 0 ]] ; then
- eerror "One of the following USE flags is needed: jack, alsa or oss"
- die "Please set one audio engine type"
- elif [[ "${cnt}" -ne 1 ]] ; then
- ewarn "You have set ${P} to use multiple audio engine."
- fi
-}
-
-src_compile() {
- local backend
- if use jack ; then
- backend="jack"
- elif use alsa ; then
- backend="alsa"
- elif use oss ; then
- backend="oss"
- fi
- einfo "Compiling against ${backend}"
-
- # when compile with athlon or athlon-xp flags
- # chuck crashes on removing a shred with a double free or corruption
- # it happens in Chuck_VM_Stack::shutdown() on the line
- # SAFE_DELETE_ARRAY( stack );
- replace-cpu-flags athlon athlon-xp i686
-
- cd "${S}/src"
- emake -f "makefile.${backend}" CC=$(tc-getCC) CXX=$(tc-getCXX) || die "emake failed"
-}
-
-src_install() {
- dobin src/chuck
-
- dodoc AUTHORS DEVELOPER PROGRAMMER QUICKSTART README THANKS TODO VERSIONS
- docinto doc
- dodoc doc/*
- if use examples; then
- insinto /usr/share/doc/${P}/examples
- doins `find examples -type f`
- for dir in `find examples/* -type d`; do
- insinto /usr/share/doc/${P}/$dir
- doins $dir/*
- done
- fi
-}