summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-02-05 17:17:59 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-02-05 17:17:59 +0000
commite575bc46283686c93d6e6de767db289dcaf86048 (patch)
tree7beeca8ec82f759928fe8fc8a5bcb5e5c2ee1d82 /media-sound
parentMake use of the new support in kde eclass to set the translations and documen... (diff)
downloadgentoo-2-e575bc46283686c93d6e6de767db289dcaf86048.tar.gz
gentoo-2-e575bc46283686c93d6e6de767db289dcaf86048.tar.bz2
gentoo-2-e575bc46283686c93d6e6de767db289dcaf86048.zip
Move the $LINGUAS handling to kde eclass.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/amarok/ChangeLog5
-rw-r--r--media-sound/amarok/amarok-1.3.8.ebuild22
2 files changed, 10 insertions, 17 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index fbf58fea8d51..f33824af0d54 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/amarok
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.101 2006/01/31 10:38:29 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.102 2006/02/05 17:17:59 flameeyes Exp $
+
+ 05 Feb 2006; Diego Pettenò <flameeyes@gentoo.org> amarok-1.3.8.ebuild:
+ Move the $LINGUAS handling to kde eclass.
31 Jan 2006; Diego Pettenò <flameeyes@gentoo.org> amarok-1.3.8.ebuild:
Make kioslaves an optional dependency on kde useflag, and add a notice about
diff --git a/media-sound/amarok/amarok-1.3.8.ebuild b/media-sound/amarok/amarok-1.3.8.ebuild
index d9def4ca20de..b2e68f547e30 100644
--- a/media-sound/amarok/amarok-1.3.8.ebuild
+++ b/media-sound/amarok/amarok-1.3.8.ebuild
@@ -1,6 +1,11 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-1.3.8.ebuild,v 1.3 2006/01/31 10:38:29 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-1.3.8.ebuild,v 1.4 2006/02/05 17:17:59 flameeyes Exp $
+
+LANGS="az be bg br ca cs cy da de el en_GB eo es et fi fr ga gl he hi hr hu id is it ja ko ku lo lt nb nds nl nn pa pl pt pt_BR ro ru se sl sq sr sr@Latn ss sv ta tg th tr uk uz zh_CN zh_TW"
+LANGS_DOC="da de et fr it nl pt pt_BR ru sv"
+
+USE_KEG_PACKAGING=1
inherit kde eutils flag-o-matic
@@ -66,21 +71,6 @@ pkg_setup() {
append-flags -fno-inline
}
-src_unpack() {
- kde_src_unpack
-
- LANGS="az be bg br ca cs cy da de el en_GB eo es et fi fr ga gl he hi hr hu id is it ja ko ku lo lt nb nds nl nn pa pl pt pt_BR ro ru se sl sq sr sr@Latn ss sv ta tg th tr uk uz zh_CN zh_TW"
- LANGS_DOC="da de et fr it nl pt pt_BR ru sv"
-
- MAKE_PO=$(echo $(echo "${LINGUAS} ${LANGS}" | fmt -w 1 | sort | uniq -d))
- MAKE_DOC=$(echo $(echo "${LINGUAS} ${LANGS_DOC}" | fmt -w 1 | sort | uniq -d))
-
- sed -i -r -e "s:^SUBDIRS =.*:SUBDIRS = ${MAKE_PO}:" ${S}/po/Makefile.am || die "sed for locale failed"
- sed -i -r -e "s:^SUBDIRS =.*:SUBDIRS = \. ${MAKE_DOC} ${PN}:" ${S}/doc/Makefile.am || die "sed for locale failed"
-
- rm -f ${S}/configure
-}
-
src_compile() {
# amarok does not respect kde coding standards, and makes a lot of
# assuptions regarding its installation directory. For this reason,