summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-07-10 11:24:43 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-07-10 11:24:43 +0000
commite485be3f50a4ff7ee7d7cc77a0459edd7130bcd8 (patch)
tree7e6d5b872d494b80b5deae45f692a7d6262e5d4f /media-sound
parentFix firefox[xulrunner] check to apply only to 3.0. 3.5 doesn't have it option... (diff)
downloadgentoo-2-e485be3f50a4ff7ee7d7cc77a0459edd7130bcd8.tar.gz
gentoo-2-e485be3f50a4ff7ee7d7cc77a0459edd7130bcd8.tar.bz2
gentoo-2-e485be3f50a4ff7ee7d7cc77a0459edd7130bcd8.zip
Revision bump to drop usage of obsolete libmp4v2 from mpeg4ip package.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/easytag/ChangeLog8
-rw-r--r--media-sound/easytag/easytag-2.1.6-r2.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/media-sound/easytag/ChangeLog b/media-sound/easytag/ChangeLog
index 00ad676dbf2d..1f3828e75d09 100644
--- a/media-sound/easytag/ChangeLog
+++ b/media-sound/easytag/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/easytag
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/easytag/ChangeLog,v 1.129 2009/06/25 18:02:46 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/easytag/ChangeLog,v 1.130 2009/07/10 11:24:43 ssuominen Exp $
+
+*easytag-2.1.6-r2 (10 Jul 2009)
+
+ 10 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +easytag-2.1.6-r2.ebuild:
+ Revision bump to drop usage of obsolete libmp4v2 from mpeg4ip package.
25 Jun 2009; Raúl Porcel <armin76@gentoo.org> easytag-2.1.6-r1.ebuild:
sparc stable wrt #272966
diff --git a/media-sound/easytag/easytag-2.1.6-r2.ebuild b/media-sound/easytag/easytag-2.1.6-r2.ebuild
new file mode 100644
index 000000000000..7a02211f5000
--- /dev/null
+++ b/media-sound/easytag/easytag-2.1.6-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/easytag/easytag-2.1.6-r2.ebuild,v 1.1 2009/07/10 11:24:43 ssuominen Exp $
+
+EAPI=2
+inherit eutils fdo-mime
+
+DESCRIPTION="GTK+ utility for editing MP2, MP3, MP4, FLAC, Ogg and other media tags"
+HOMEPAGE="http://easytag.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="flac mp3 speex vorbis wavpack"
+
+RDEPEND=">=x11-libs/gtk+-2.12:2
+ mp3? ( >=media-libs/id3lib-3.8.3-r7
+ media-libs/libid3tag )
+ flac? ( media-libs/flac
+ media-libs/libvorbis )
+ vorbis? ( media-libs/libvorbis )
+ wavpack? ( media-sound/wavpack )
+ speex? ( media-libs/speex
+ media-libs/libvorbis )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-desktop_entry.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable mp3) \
+ $(use_enable mp3 id3v23) \
+ $(use_enable vorbis ogg) \
+ $(use_enable flac) \
+ --disable-mp4 \
+ $(use_enable wavpack) \
+ $(use_enable speex)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog README THANKS TODO USERS-GUIDE
+}
+
+pkg_postinst() { fdo-mime_desktop_database_update; }
+pkg_postrm() { fdo-mime_desktop_database_update; }