summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-02-08 19:37:27 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-02-08 19:37:27 +0000
commite38ec417c7a3265f8de5b4661ffe0393e5814638 (patch)
treeae913cc3da71ea004543336fcadfc4d63631835a /media-sound
parentRemoved old revision of meteor. (diff)
downloadgentoo-2-e38ec417c7a3265f8de5b4661ffe0393e5814638.tar.gz
gentoo-2-e38ec417c7a3265f8de5b4661ffe0393e5814638.tar.bz2
gentoo-2-e38ec417c7a3265f8de5b4661ffe0393e5814638.zip
Patch out the call to update-modules script that was installed with sys-apps/module-init-tools and is not present with sys-apps/kmod.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/alsa-utils/ChangeLog11
-rw-r--r--media-sound/alsa-utils/alsa-utils-1.0.26-r2.ebuild79
-rw-r--r--media-sound/alsa-utils/files/alsa-utils-1.0.26-kmod.patch19
3 files changed, 107 insertions, 2 deletions
diff --git a/media-sound/alsa-utils/ChangeLog b/media-sound/alsa-utils/ChangeLog
index ed281b59e9a6..7b33a4b27646 100644
--- a/media-sound/alsa-utils/ChangeLog
+++ b/media-sound/alsa-utils/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/alsa-utils
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.329 2012/12/11 16:31:40 axs Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.330 2013/02/08 19:37:27 ssuominen Exp $
+
+*alsa-utils-1.0.26-r2 (08 Feb 2013)
+
+ 08 Feb 2013; Samuli Suominen <ssuominen@gentoo.org>
+ +alsa-utils-1.0.26-r2.ebuild, +files/alsa-utils-1.0.26-kmod.patch:
+ Patch out the call to update-modules script that was installed with
+ sys-apps/module-init-tools and is not present with sys-apps/kmod.
11 Dec 2012; Ian Stakenvicius <axs@gentoo.org> alsa-utils-1.0.26.ebuild,
alsa-utils-1.0.26-r1.ebuild:
diff --git a/media-sound/alsa-utils/alsa-utils-1.0.26-r2.ebuild b/media-sound/alsa-utils/alsa-utils-1.0.26-r2.ebuild
new file mode 100644
index 000000000000..aed5afbd77ed
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-1.0.26-r2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-1.0.26-r2.ebuild,v 1.1 2013/02/08 19:37:27 ssuominen Exp $
+
+EAPI=5
+inherit eutils systemd udev toolchain-funcs
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/utils/${P}.tar.bz2
+ !minimal? ( mirror://alsaproject/driver/alsa-driver-1.0.25.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="doc +libsamplerate minimal +ncurses nls selinux"
+
+COMMON_DEPEND=">=media-libs/alsa-lib-${PV}
+ libsamplerate? ( media-libs/libsamplerate )
+ ncurses? ( >=sys-libs/ncurses-5.7-r7 )
+ selinux? ( sec-policy/selinux-alsa )"
+RDEPEND="${COMMON_DEPEND}
+ !minimal? (
+ dev-util/dialog
+ sys-apps/pciutils
+ )"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ doc? ( app-text/xmlto )"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.0.23-modprobe.d.patch \
+ "${FILESDIR}"/${PN}-1.0.25-separate-usr-var-fs.patch \
+ "${FILESDIR}"/${PN}-1.0.26-kmod.patch
+}
+
+src_configure() {
+ local myconf
+ use doc || myconf='--disable-xmlto'
+
+ econf \
+ $(use_enable libsamplerate alsaloop) \
+ $(use_enable nls) \
+ $(use_enable ncurses alsamixer) \
+ $(use_enable !minimal alsaconf) \
+ "$(systemd_with_unitdir)" \
+ --with-udev-rules-dir="$(get_udevdir)"/rules.d \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc ChangeLog README TODO seq/*/README.*
+
+ use minimal || newbin "${WORKDIR}"/alsa-driver-*/utils/alsa-info.sh alsa-info
+
+ newinitd "${FILESDIR}"/alsasound.initd-r5 alsasound
+ newconfd "${FILESDIR}"/alsasound.confd-r4 alsasound
+
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}"/alsa-modules.conf-rc alsa.conf
+
+ keepdir /var/lib/alsa
+}
+
+pkg_postinst() {
+ echo
+ elog "To take advantage of the init script, and automate the process of"
+ elog "saving and restoring sound-card mixer levels you should"
+ elog "add alsasound to the boot runlevel. You can do this as"
+ elog "root like so:"
+ elog " # rc-update add alsasound boot"
+ echo
+ ewarn "The ALSA core should be built into the kernel or loaded through other"
+ ewarn "means. There is no longer any modular auto(un)loading in alsa-utils."
+ echo
+}
diff --git a/media-sound/alsa-utils/files/alsa-utils-1.0.26-kmod.patch b/media-sound/alsa-utils/files/alsa-utils-1.0.26-kmod.patch
new file mode 100644
index 000000000000..991002a71c9e
--- /dev/null
+++ b/media-sound/alsa-utils/files/alsa-utils-1.0.26-kmod.patch
@@ -0,0 +1,19 @@
+update-modules is a script from $FILESDIR of sys-apps/module-init-tools and it should
+be a no-op thesedays.
+
+# cd /usr/portage/sys-apps/module-init-tools/files
+# ./update-modules-3.5 --verbose
+
+* We have just /etc/modprobe.d; Nothing to do!
+
+--- alsaconf/alsaconf.in
++++ alsaconf/alsaconf.in
+@@ -924,7 +924,7 @@
+ farewell
+ clear
+ case "$distribution" in
+- gentoo | debian)
++ debian)
+ xecho "Running update-modules..."
+ update-modules
+ ;;