summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Horelick <jdhore@gentoo.org>2012-06-17 18:22:07 +0000
committerJeff Horelick <jdhore@gentoo.org>2012-06-17 18:22:07 +0000
commitdc2385624ebaa307ea2afc64772c9714e5097ac3 (patch)
tree82a3e4f43e3d5c7e02ecd9f50a72c99ff2f65337 /media-sound
parentalpha/ia64/m68k/s390/sh/sparc stable wrt #416333 (diff)
downloadgentoo-2-dc2385624ebaa307ea2afc64772c9714e5097ac3.tar.gz
gentoo-2-dc2385624ebaa307ea2afc64772c9714e5097ac3.tar.bz2
gentoo-2-dc2385624ebaa307ea2afc64772c9714e5097ac3.zip
Version bump to 3.3_alpha1 (with no keywords). This version is using gtk+:3.
(Portage version: 2.2.0_alpha110/cvs/Linux i686)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/audacious/ChangeLog7
-rw-r--r--media-sound/audacious/audacious-3.3_alpha1.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/media-sound/audacious/ChangeLog b/media-sound/audacious/ChangeLog
index 63766842dad7..bc39108c1bb8 100644
--- a/media-sound/audacious/ChangeLog
+++ b/media-sound/audacious/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/audacious
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.270 2012/06/10 18:40:59 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.271 2012/06/17 18:22:07 jdhore Exp $
+
+*audacious-3.3_alpha1 (17 Jun 2012)
+
+ 17 Jun 2012; Jeff Horelick <jdhore@gentoo.org> +audacious-3.3_alpha1.ebuild:
+ Version bump to 3.3_alpha1 (with no keywords). This version is using gtk+:3.
10 Jun 2012; Jeff Horelick <jdhore@gentoo.org> audacious-3.2.3.ebuild:
Drop gtk3 support for now as it is currently a bit broken.
diff --git a/media-sound/audacious/audacious-3.3_alpha1.ebuild b/media-sound/audacious/audacious-3.3_alpha1.ebuild
new file mode 100644
index 000000000000..f9a65c5149d6
--- /dev/null
+++ b/media-sound/audacious/audacious-3.3_alpha1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-3.3_alpha1.ebuild,v 1.1 2012/06/17 18:22:07 jdhore Exp $
+
+EAPI=4
+inherit eutils
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://distfiles.audacious-media-player.org/${MY_P}.tar.bz2
+ mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+
+IUSE="chardet nls session"
+
+RDEPEND=">=dev-libs/dbus-glib-0.60
+ >=dev-libs/glib-2.16
+ dev-libs/libxml2
+ >=x11-libs/cairo-1.2.6
+ >=x11-libs/pango-1.8.0
+ x11-libs/gtk+:3
+ session? ( x11-libs/libSM )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ chardet? ( >=app-i18n/libguess-1.1 )
+ nls? ( dev-util/intltool )"
+
+PDEPEND=">=media-plugins/audacious-plugins-3.3_alpha1"
+
+src_prepare() {
+ epatch "$FILESDIR"/${P}-fix-mutex.patch
+}
+
+src_configure() {
+ # D-Bus is a mandatory dependency, remote control,
+ # session management and some plugins depend on this.
+ # Building without D-Bus is *unsupported* and a USE-flag
+ # will not be added due to the bug reports that will result.
+ # Bugs #197894, #199069, #207330, #208606
+ econf \
+ --enable-dbus \
+ $(use_enable chardet) \
+ $(use_enable nls) \
+ $(use_enable session sm)
+}
+
+src_install() {
+ default
+ dodoc AUTHORS README
+
+ # Gentoo_ice skin installation; bug #109772
+ insinto /usr/share/audacious/Skins/gentoo_ice
+ doins "${WORKDIR}"/gentoo_ice/*
+ docinto gentoo_ice
+ dodoc "${WORKDIR}"/README
+}