summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2003-08-14 04:28:40 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2003-08-14 04:28:40 +0000
commitdae86d0fb9c84ab3b77f0fc99b6072a2aa4967f4 (patch)
tree57214484941a4203d75427c461cac88bb2b0cee3 /media-sound
parentVersion bump. (diff)
downloadgentoo-2-dae86d0fb9c84ab3b77f0fc99b6072a2aa4967f4.tar.gz
gentoo-2-dae86d0fb9c84ab3b77f0fc99b6072a2aa4967f4.tar.bz2
gentoo-2-dae86d0fb9c84ab3b77f0fc99b6072a2aa4967f4.zip
Version bump.
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/mpd/ChangeLog7
-rw-r--r--media-sound/mpd/Manifest4
-rw-r--r--media-sound/mpd/files/digest-mpd-0.8.41
-rw-r--r--media-sound/mpd/mpd-0.8.4.ebuild44
4 files changed, 53 insertions, 3 deletions
diff --git a/media-sound/mpd/ChangeLog b/media-sound/mpd/ChangeLog
index 86e7f73dfc98..9aae69797f19 100644
--- a/media-sound/mpd/ChangeLog
+++ b/media-sound/mpd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/mpd
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/ChangeLog,v 1.2 2003/07/31 15:44:19 tigger Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/ChangeLog,v 1.3 2003/08/14 04:28:36 g2boojum Exp $
+
+*mpd-0.8.4 (13 Aug 2003)
+
+ 13 Aug 2003; Nick Hadaway <raker@gentoo.org> mpd-0.8.4.ebuild:
+ Version bump. Closes bug #26548
*mpd-0.8.2 (31 Jul 2003)
diff --git a/media-sound/mpd/Manifest b/media-sound/mpd/Manifest
index af1fd392d25f..9e35fd599139 100644
--- a/media-sound/mpd/Manifest
+++ b/media-sound/mpd/Manifest
@@ -1,6 +1,6 @@
-MD5 24efbb6aa450130a48c0d489924d6dcb mpd-0.8.4.ebuild 1141
+MD5 5911894c4e998fb70b063c8fffa1304d mpd-0.8.4.ebuild 1108
MD5 58f887042db750a9d8e72e410c7092c4 mpd-0.8.1.ebuild 1140
-MD5 2b28299d951f1fd15416fd2d198fd6a8 ChangeLog 558
+MD5 b3594ee0cc0d290c4f9eaae414b77aa0 ChangeLog 687
MD5 24efbb6aa450130a48c0d489924d6dcb mpd-0.8.2.ebuild 1141
MD5 584e630a8aba4c01febb8248c9f3247b files/digest-mpd-0.8.1 61
MD5 3ba62c82a1d52363a5cf5862b0ff5d7e files/digest-mpd-0.8.2 61
diff --git a/media-sound/mpd/files/digest-mpd-0.8.4 b/media-sound/mpd/files/digest-mpd-0.8.4
new file mode 100644
index 000000000000..f150bad24855
--- /dev/null
+++ b/media-sound/mpd/files/digest-mpd-0.8.4
@@ -0,0 +1 @@
+MD5 be4866a6cd25753a0b41a5cc9735647d mpd-0.8.4.tar.gz 719303
diff --git a/media-sound/mpd/mpd-0.8.4.ebuild b/media-sound/mpd/mpd-0.8.4.ebuild
new file mode 100644
index 000000000000..82ae6326f0bf
--- /dev/null
+++ b/media-sound/mpd/mpd-0.8.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/mpd-0.8.4.ebuild,v 1.1 2003/08/14 04:28:36 g2boojum Exp $
+
+IUSE="oggvorbis mad"
+
+DESCRIPTION="Music Player Daemon (mpd)"
+SRC_URI="http://mercury.chem.pitt.edu/~shank/${P}.tar.gz"
+HOMEPAGE="http://musicpd.sourceforge.net/"
+
+KEYWORDS="~x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="oggvorbis? ( media-libs/libvorbis )
+ mad? ( media-sound/mad )
+ >=media-libs/flac-1.1.0
+ media-libs/libao
+ sys-libs/zlib"
+
+src_compile() {
+ local myconf
+ myconf="--with-gnu-ld"
+
+ use oggvorbis \
+ || myconf="${myconf} --disable-ogg --disable-oggtest \
+ --disable-vorbistest"
+ use mad || myconf="${myconf} --enable-mpd-mad --enable-mpd-id3tag"
+
+ econf ${myconf} || die "could not configure"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin mpd
+
+ dodoc mpdconf.example COMMANDS ChangeLog INSTALL README TODO UPGRADING
+}
+
+pkg_postinst() {
+ einfo "libao has issues with the ALSA drivers, please refer to the FAQ"
+ einfo "http://musicpd.sourceforge.net/faq.php"
+}