summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-05-27 04:56:05 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-05-27 04:56:05 +0000
commitd3bc610cf890a29beedcfddec5f72cbd6fb57be2 (patch)
tree315da1c23a93c2ae74e2e42b1530e925247ff4bd /media-sound
parent*portage-2.2.0_alpha37 (27 May 2011) (diff)
downloadgentoo-2-d3bc610cf890a29beedcfddec5f72cbd6fb57be2.tar.gz
gentoo-2-d3bc610cf890a29beedcfddec5f72cbd6fb57be2.tar.bz2
gentoo-2-d3bc610cf890a29beedcfddec5f72cbd6fb57be2.zip
version bump
(Portage version: 2.2.0_alpha36/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/ripperx/ChangeLog8
-rw-r--r--media-sound/ripperx/files/ripperx-2.7.3-ldflags.patch13
-rw-r--r--media-sound/ripperx/files/ripperx-2.7.3-pkgconfig.patch12
-rw-r--r--media-sound/ripperx/ripperx-2.7.3.ebuild46
4 files changed, 78 insertions, 1 deletions
diff --git a/media-sound/ripperx/ChangeLog b/media-sound/ripperx/ChangeLog
index bf368d52937a..79aff485b732 100644
--- a/media-sound/ripperx/ChangeLog
+++ b/media-sound/ripperx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/ripperx
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ripperx/ChangeLog,v 1.37 2011/03/29 12:40:43 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ripperx/ChangeLog,v 1.38 2011/05/27 04:56:04 aballier Exp $
+
+*ripperx-2.7.3 (27 May 2011)
+
+ 27 May 2011; Alexis Ballier <aballier@gentoo.org> +ripperx-2.7.3.ebuild,
+ +files/ripperx-2.7.3-ldflags.patch, +files/ripperx-2.7.3-pkgconfig.patch:
+ version bump
29 Mar 2011; Christoph Mende <angelos@gentoo.org> ripperx-2.7.2.ebuild:
Fix gtk+ slot deps
diff --git a/media-sound/ripperx/files/ripperx-2.7.3-ldflags.patch b/media-sound/ripperx/files/ripperx-2.7.3-ldflags.patch
new file mode 100644
index 000000000000..a0a7561e3bf8
--- /dev/null
+++ b/media-sound/ripperx/files/ripperx-2.7.3-ldflags.patch
@@ -0,0 +1,13 @@
+Index: ripperX-2.7.3/plugins/Makefile.in
+===================================================================
+--- ripperX-2.7.3.orig/plugins/Makefile.in
++++ ripperX-2.7.3/plugins/Makefile.in
+@@ -658,7 +658,7 @@ uninstall-am: uninstall-binPROGRAMS
+ all: ripperX_plugin_tester $(PLUGINS)
+
+ .c.o:
+- $(CC) $(CFLAGS) $(LDFLAGS) -c $< -o $@
++ $(CC) $(CFLAGS) -c $< -o $@
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/media-sound/ripperx/files/ripperx-2.7.3-pkgconfig.patch b/media-sound/ripperx/files/ripperx-2.7.3-pkgconfig.patch
new file mode 100644
index 000000000000..5b7ddaa397b7
--- /dev/null
+++ b/media-sound/ripperx/files/ripperx-2.7.3-pkgconfig.patch
@@ -0,0 +1,12 @@
+Index: ripperX-2.7.3/ripperX.pc.in
+===================================================================
+--- ripperX-2.7.3.orig/ripperX.pc.in
++++ ripperX-2.7.3/ripperX.pc.in
+@@ -1,6 +1,7 @@
+ prefix=@prefix@
+ exec_prefix=@exec_prefix@
+ libdir=@libdir@
++includedir=@includedir@
+
+ pkglibdir=${libdir}/@PACKAGE@
+ pkgincludedir=${includedir}/@PACKAGE@
diff --git a/media-sound/ripperx/ripperx-2.7.3.ebuild b/media-sound/ripperx/ripperx-2.7.3.ebuild
new file mode 100644
index 000000000000..36fa98a25b83
--- /dev/null
+++ b/media-sound/ripperx/ripperx-2.7.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ripperx/ripperx-2.7.3.ebuild,v 1.1 2011/05/27 04:56:05 aballier Exp $
+
+EAPI=2
+inherit eutils
+
+MY_P=${P/x/X}
+MY_PN=${PN/x/X}
+
+DESCRIPTION="a GTK program to rip CD audio tracks and encode them to the Ogg, MP3, or FLAC formats."
+HOMEPAGE="http://sourceforge.net/projects/ripperx"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND="x11-libs/gtk+:2
+ media-sound/lame
+ media-sound/cdparanoia
+ media-libs/id3lib"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ldflags.patch \
+ "${FILESDIR}"/${P}-pkgconfig.patch
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc BUGS CHANGES FAQ README* TODO
+ doicon src/xpms/${MY_PN}-icon.xpm
+ make_desktop_entry ${MY_PN} ${MY_PN} ${MY_PN}-icon
+}