summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-12-19 09:33:13 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-12-19 09:33:13 +0000
commitcfe8b842c9a572bb3d1fc00d19e9d8016a84f600 (patch)
tree9a6051417ddb9835eb82fcf93dfdc37b40c2a028 /media-sound
parentAdded ~ppc64 (diff)
downloadgentoo-2-cfe8b842c9a572bb3d1fc00d19e9d8016a84f600.tar.gz
gentoo-2-cfe8b842c9a572bb3d1fc00d19e9d8016a84f600.tar.bz2
gentoo-2-cfe8b842c9a572bb3d1fc00d19e9d8016a84f600.zip
Add debug useflag as per bug #115993.
(Portage version: 2.1_pre1)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/alsa-driver/ChangeLog6
-rw-r--r--media-sound/alsa-driver/alsa-driver-1.0.10-r1.ebuild9
2 files changed, 10 insertions, 5 deletions
diff --git a/media-sound/alsa-driver/ChangeLog b/media-sound/alsa-driver/ChangeLog
index 8e0aeb8e17d5..b990e0668d2d 100644
--- a/media-sound/alsa-driver/ChangeLog
+++ b/media-sound/alsa-driver/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/alsa-driver
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.174 2005/12/15 22:19:25 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.175 2005/12/19 09:33:13 flameeyes Exp $
+
+ 19 Dec 2005; Diego Pettenò <flameeyes@gentoo.org>
+ alsa-driver-1.0.10-r1.ebuild:
+ Add debug useflag as per bug #115993.
*alsa-driver-1.0.10-r1 (15 Dec 2005)
diff --git a/media-sound/alsa-driver/alsa-driver-1.0.10-r1.ebuild b/media-sound/alsa-driver/alsa-driver-1.0.10-r1.ebuild
index 03a2f76ede2c..059c0251615f 100644
--- a/media-sound/alsa-driver/alsa-driver-1.0.10-r1.ebuild
+++ b/media-sound/alsa-driver/alsa-driver-1.0.10-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.10-r1.ebuild,v 1.1 2005/12/15 22:19:25 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.10-r1.ebuild,v 1.2 2005/12/19 09:33:13 flameeyes Exp $
inherit linux-mod flag-o-matic eutils
@@ -15,7 +15,7 @@ LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~x86"
-IUSE="oss doc"
+IUSE="oss doc debug"
RDEPEND="virtual/modutils
~media-sound/alsa-headers-${PV}"
@@ -60,8 +60,8 @@ pkg_setup() {
linux-mod_pkg_setup
if [[ ${PROFILE_ARCH} == "sparc64" ]] ; then
- CBUILD=${CBUILD-${CHOST}}
- CHOST="sparc64-unknown-linux-gnu"
+ export CBUILD=${CBUILD-${CHOST}}
+ export CHOST="sparc64-unknown-linux-gnu"
fi
}
@@ -83,6 +83,7 @@ src_compile() {
append-flags "-I${KV_DIR}/arch/$(tc-arch-kernel)/include"
econf $(use_with oss) \
+ $(use_with debug debug full) \
--with-kernel="${KV_DIR}" \
--with-build="${KV_OUT_DIR}" \
--with-isapnp=yes \