summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-02-09 04:38:46 +0000
committerTim Harder <radhermit@gentoo.org>2013-02-09 04:38:46 +0000
commitcc182f9f17d2395239ccd0003898d37bbaf6ba82 (patch)
treec3122ee44fc8a6b8e8549dc7b05e5070c4f7f87f /media-sound
parentUpdate HOMEPAGE to use sourceware.org #455152 by wbrana. (diff)
downloadgentoo-2-cc182f9f17d2395239ccd0003898d37bbaf6ba82.tar.gz
gentoo-2-cc182f9f17d2395239ccd0003898d37bbaf6ba82.tar.bz2
gentoo-2-cc182f9f17d2395239ccd0003898d37bbaf6ba82.zip
Version bump.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/lilypond/ChangeLog7
-rw-r--r--media-sound/lilypond/lilypond-2.17.12.ebuild104
2 files changed, 110 insertions, 1 deletions
diff --git a/media-sound/lilypond/ChangeLog b/media-sound/lilypond/ChangeLog
index cba2c518865f..caf1666c8b83 100644
--- a/media-sound/lilypond/ChangeLog
+++ b/media-sound/lilypond/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/lilypond
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/ChangeLog,v 1.142 2013/01/29 19:20:14 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/ChangeLog,v 1.143 2013/02/09 04:38:46 radhermit Exp $
+
+*lilypond-2.17.12 (09 Feb 2013)
+
+ 09 Feb 2013; Tim Harder <radhermit@gentoo.org> +lilypond-2.17.12.ebuild:
+ Version bump.
29 Jan 2013; Tim Harder <radhermit@gentoo.org> -lilypond-2.17.8.ebuild,
-lilypond-2.17.9.ebuild:
diff --git a/media-sound/lilypond/lilypond-2.17.12.ebuild b/media-sound/lilypond/lilypond-2.17.12.ebuild
new file mode 100644
index 000000000000..26c1da712f5f
--- /dev/null
+++ b/media-sound/lilypond/lilypond-2.17.12.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/lilypond-2.17.12.ebuild,v 1.1 2013/02/09 04:38:46 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit elisp-common autotools eutils python-single-r1
+
+DESCRIPTION="GNU Music Typesetter"
+SRC_URI="http://download.linuxaudio.org/lilypond/sources/v${PV:0:4}/${P}.tar.gz"
+HOMEPAGE="http://lilypond.org/"
+
+SLOT="0"
+LICENSE="GPL-3 FDL-1.3"
+KEYWORDS="~amd64 ~hppa ~x86"
+LANGS=" ca cs da de el eo es fi fr it ja nl ru sv tr uk vi zh_TW"
+IUSE="debug emacs profile vim-syntax ${LANGS// / linguas_}"
+
+RDEPEND=">=app-text/ghostscript-gpl-8.15
+ >=dev-scheme/guile-1.8.2[deprecated,regex]
+ media-fonts/urw-fonts
+ media-libs/fontconfig
+ media-libs/freetype:2
+ >=x11-libs/pango-1.12.3
+ emacs? ( virtual/emacs )
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ app-text/t1utils
+ dev-lang/perl
+ dev-texlive/texlive-metapost
+ virtual/pkgconfig
+ media-gfx/fontforge
+ >=sys-apps/texinfo-4.11
+ >=sys-devel/bison-2.0
+ sys-devel/flex
+ sys-devel/gettext
+ sys-devel/make"
+
+# Correct output data for tests isn't bundled with releases
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.17.2-tex-docs.patch
+
+ if ! use vim-syntax ; then
+ sed -i -e "s/vim//" GNUmakefile.in || die
+ fi
+
+ sed -i -e "s/OPTIMIZE -g/OPTIMIZE/" aclocal.m4 || die
+
+ for lang in ${LANGS}; do
+ use linguas_${lang} || rm po/${lang}.po || die
+ done
+
+ eautoreconf
+}
+
+src_configure() {
+ # documentation generation currently not supported since it requires a newer
+ # version of texi2html than is currently in the tree
+
+ econf \
+ --with-ncsb-dir=/usr/share/fonts/urw-fonts \
+ --disable-documentation \
+ --disable-optimising \
+ --disable-pipe \
+ $(use_enable debug debugging) \
+ $(use_enable profile profiling)
+}
+
+src_compile() {
+ default
+
+ if use emacs ; then
+ elisp-compile elisp/lilypond-{font-lock,indent,mode,what-beat}.el \
+ || die "elisp-compile failed"
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${D}" vimdir=/usr/share/vim/vimfiles install
+
+ # remove elisp files since they are in the wrong directory
+ rm -r "${ED}"/usr/share/emacs || die
+
+ if use emacs ; then
+ elisp-install ${PN} elisp/*.{el,elc} elisp/out/*.el \
+ || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el
+ fi
+
+ python_fix_shebang "${ED}"
+
+ dodoc AUTHORS.txt HACKING NEWS.txt README.txt
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}