summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2012-05-09 04:20:27 +0000
committerBen de Groot <yngwin@gentoo.org>2012-05-09 04:20:27 +0000
commitc729395382abd1b9f5163898c1b9b8f8cc8ddb60 (patch)
tree998443f617e6bc12bb81dee9979ab4baf297d395 /media-sound
parentUnrestrict python 3, bug 407925 by W. Trevor King. (diff)
downloadgentoo-2-c729395382abd1b9f5163898c1b9b8f8cc8ddb60.tar.gz
gentoo-2-c729395382abd1b9f5163898c1b9b8f8cc8ddb60.tar.bz2
gentoo-2-c729395382abd1b9f5163898c1b9b8f8cc8ddb60.zip
Apply patch by kensington which fixes bug #415049 (install failure when none of the provided linguas are selected)
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/qsynth/ChangeLog6
-rw-r--r--media-sound/qsynth/qsynth-0.3.6.ebuild22
2 files changed, 16 insertions, 12 deletions
diff --git a/media-sound/qsynth/ChangeLog b/media-sound/qsynth/ChangeLog
index f62f5b974290..d4eb1b86709c 100644
--- a/media-sound/qsynth/ChangeLog
+++ b/media-sound/qsynth/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/qsynth
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qsynth/ChangeLog,v 1.55 2012/05/07 10:39:04 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qsynth/ChangeLog,v 1.56 2012/05/09 04:20:27 yngwin Exp $
+
+ 09 May 2012; Ben de Groot <yngwin@gentoo.org> qsynth-0.3.6.ebuild:
+ Apply patch by kensington which fixes bug #415049 (install failure when none
+ of the provided linguas are selected)
07 May 2012; Ben de Groot <yngwin@gentoo.org> -qsynth-0.3.2.ebuild,
-qsynth-0.3.4.ebuild, -qsynth-0.3.5.ebuild, qsynth-0.3.6.ebuild:
diff --git a/media-sound/qsynth/qsynth-0.3.6.ebuild b/media-sound/qsynth/qsynth-0.3.6.ebuild
index 36059ae0143f..dab914b1ae69 100644
--- a/media-sound/qsynth/qsynth-0.3.6.ebuild
+++ b/media-sound/qsynth/qsynth-0.3.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qsynth/qsynth-0.3.6.ebuild,v 1.6 2012/05/07 10:39:04 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qsynth/qsynth-0.3.6.ebuild,v 1.7 2012/05/09 04:20:27 yngwin Exp $
EAPI=4
LANGS="cs de es ru"
@@ -10,8 +10,8 @@ inherit qt4-r2 eutils flag-o-matic
DESCRIPTION="A Qt application to control FluidSynth"
HOMEPAGE="http://qsynth.sourceforge.net/"
SRC_URI="mirror://sourceforge/qsynth/${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT="0"
IUSE="debug jack alsa pulseaudio"
KEYWORDS="amd64 ppc x86"
@@ -26,15 +26,7 @@ RDEPEND="${DEPEND}"
DOCS="AUTHORS ChangeLog README TODO TRANSLATORS"
src_prepare() {
- local lang use_langs
- for lang in ${LANGS} ; do
- if use linguas_${lang} ; then
- use_langs="${use_langs} src/translations/${PN}_${lang}.qm"
- fi
- done
-
- sed -e "s|\$(translations_targets)|${use_langs}|" -i Makefile.in \
- || die "sed translations failed"
+ sed -e '/@install/,/share\/locale$/d' -i Makefile.in || die "sed translations failed"
sed -e 's/@make/@\$(MAKE)/' -i Makefile.in || die "sed Makefile failed"
@@ -63,6 +55,14 @@ src_compile() {
src_install () {
qt4-r2_src_install
+ insinto /usr/share/locale
+ local lang
+ for lang in ${LANGS} ; do
+ if use linguas_${lang} ; then
+ doins "src/translations/${PN}_${lang}.qm"
+ fi
+ done
+
# The desktop file is invalid, and we also change the command
# depending on useflags
rm -rf "${D}/usr/share/applications/qsynth.desktop"