summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-09-30 12:04:18 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-09-30 12:04:18 +0000
commitc15dc5eb0191234e839ea499c1cef4a25ce353aa (patch)
tree19ce791306217ac1c5bc8aa8715bbe170acb9ef5 /media-sound
parentVersion bump, addresses bug #335731 (diff)
downloadgentoo-2-c15dc5eb0191234e839ea499c1cef4a25ce353aa.tar.gz
gentoo-2-c15dc5eb0191234e839ea499c1cef4a25ce353aa.tar.bz2
gentoo-2-c15dc5eb0191234e839ea499c1cef4a25ce353aa.zip
Make sure dev-db/sqlite is built with USE="fts3".
(Portage version: 2.2_rc88/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/clementine/ChangeLog6
-rw-r--r--media-sound/clementine/clementine-0.5.1.ebuild98
-rw-r--r--media-sound/clementine/clementine-0.5.3.ebuild3
3 files changed, 7 insertions, 100 deletions
diff --git a/media-sound/clementine/ChangeLog b/media-sound/clementine/ChangeLog
index 6225634c5a21..a3b11460f316 100644
--- a/media-sound/clementine/ChangeLog
+++ b/media-sound/clementine/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/clementine
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/clementine/ChangeLog,v 1.16 2010/09/30 10:19:07 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/clementine/ChangeLog,v 1.17 2010/09/30 12:04:18 ssuominen Exp $
+
+ 30 Sep 2010; Samuli Suominen <ssuominen@gentoo.org>
+ clementine-0.5.3.ebuild:
+ Make sure dev-db/sqlite is built with USE="fts3" by Nikoli.
*clementine-0.5.3 (30 Sep 2010)
diff --git a/media-sound/clementine/clementine-0.5.1.ebuild b/media-sound/clementine/clementine-0.5.1.ebuild
deleted file mode 100644
index aada776bc4af..000000000000
--- a/media-sound/clementine/clementine-0.5.1.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/clementine/clementine-0.5.1.ebuild,v 1.1 2010/09/21 15:36:28 ssuominen Exp $
-
-EAPI=2
-
-LANGS=" ar bg ca cs da de el en_CA en_GB es fi fr gl hu it kk lt nb nl oc pl pt_BR pt ro ru sk sl sr sv tr uk zh_CN zh_TW"
-
-inherit cmake-utils gnome2-utils
-
-DESCRIPTION="A modern music player and library organizer based on Amarok 1.4 and Qt4"
-HOMEPAGE="http://code.google.com/p/clementine-player/"
-SRC_URI="http://clementine-player.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="iphone ipod mtp projectm wiimote"
-IUSE+="${LANGS// / linguas_}"
-
-COMMON_DEPEND="
- x11-libs/qt-gui:4[dbus]
- x11-libs/qt-opengl:4
- x11-libs/qt-sql:4[sqlite]
- >=media-libs/taglib-1.6
- media-libs/liblastfm
- >=dev-libs/glib-2.10:2
- dev-libs/libxml2
- >=media-libs/gstreamer-0.10
- >=media-libs/gst-plugins-base-0.10
- ipod? (
- >=media-libs/libgpod-0.7.92
- iphone? (
- app-pda/libplist
- >=app-pda/libimobiledevice-1.0
- app-pda/usbmuxd
- )
- )
- mtp? ( media-libs/libmtp )
- projectm? ( media-libs/glew )
-"
-# now only presets are used, libprojectm is internal
-# http://code.google.com/p/clementine-player/source/browse/#svn/trunk/3rdparty/libprojectm/patches
-# r1966 "Compile with a static sqlite by default, since Qt 4.7 doesn't seem to expose the symbols we need to use FTS"
-RDEPEND="${COMMON_DEPEND}
- projectm? ( >=media-libs/libprojectm-1.2.0 )
- >=media-plugins/gst-plugins-meta-0.10
- >=media-plugins/gst-plugins-gio-0.10
- >=media-plugins/gst-plugins-soup-0.10
-"
-DEPEND="${COMMON_DEPEND}
- >=dev-libs/boost-1.39
- dev-util/pkgconfig
- sys-devel/gettext
- x11-libs/qt-test:4
-"
-DOCS="Changelog TODO"
-
-PATCHES=( "${FILESDIR}"/${P}-automagic.patch )
-
-src_configure() {
- # linguas
- local langs x
- for x in ${LANGS}; do
- use linguas_${x} && langs+=" ${x}"
- done
-
- # Upstream supports only gstreamer engine, other engines are unstable and lacking features.
- local mycmakeargs=(
- -DLINGUAS="${langs}"
- "-DBUNDLE_PROJECTM_PRESETS=OFF"
- $(cmake-utils_use ipod ENABLE_LIBGPOD)
- $(cmake-utils_use iphone ENABLE_IMOBILEDEVICE)
- $(cmake-utils_use mtp ENABLE_LIBMTP)
- "-DENABLE_GIO=ON"
- $(cmake-utils_use wiimote ENABLE_WIIMOTEDEV)
- $(cmake-utils_use projectm ENABLE_VISUALISATIONS)
- "-DSTATIC_SQLITE=OFF"
- "-DENGINE_GSTREAMER_ENABLED=ON"
- "-DENGINE_QT_PHONON_ENABLED=OFF"
- "-DENGINE_LIBVLC_ENABLED=OFF"
- "-DENGINE_LIBXINE_ENABLED=OFF"
- )
-
- cmake-utils_src_configure
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}
diff --git a/media-sound/clementine/clementine-0.5.3.ebuild b/media-sound/clementine/clementine-0.5.3.ebuild
index f2604f93c9f8..5cf76cde0af5 100644
--- a/media-sound/clementine/clementine-0.5.3.ebuild
+++ b/media-sound/clementine/clementine-0.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/clementine/clementine-0.5.3.ebuild,v 1.1 2010/09/30 10:19:07 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/clementine/clementine-0.5.3.ebuild,v 1.2 2010/09/30 12:04:18 ssuominen Exp $
EAPI=2
@@ -22,6 +22,7 @@ COMMON_DEPEND="
x11-libs/qt-gui:4[dbus]
x11-libs/qt-opengl:4
x11-libs/qt-sql:4[sqlite]
+ dev-db/sqlite[fts3]
>=media-libs/taglib-1.6
media-libs/liblastfm
>=dev-libs/glib-2.10:2