summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-11-25 16:59:48 +0000
committerJohannes Huber <johu@gentoo.org>2013-11-25 16:59:48 +0000
commitbecd369143be13b7126069071d71c675ea86fba2 (patch)
treed8b97b897079030acc112264015fd306e26407c5 /media-sound
parentremoving brcompat, again (diff)
downloadgentoo-2-becd369143be13b7126069071d71c675ea86fba2.tar.gz
gentoo-2-becd369143be13b7126069071d71c675ea86fba2.tar.bz2
gentoo-2-becd369143be13b7126069071d71c675ea86fba2.zip
Add upstream patch which fixes build when LINGUAS is empty, bug #492460.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/kid3/ChangeLog6
-rw-r--r--media-sound/kid3/files/kid3-3.0.1-empty-linguas.patch36
-rw-r--r--media-sound/kid3/kid3-3.0.1.ebuild3
3 files changed, 43 insertions, 2 deletions
diff --git a/media-sound/kid3/ChangeLog b/media-sound/kid3/ChangeLog
index 25a2f742b105..c4223f5ecb1b 100644
--- a/media-sound/kid3/ChangeLog
+++ b/media-sound/kid3/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/kid3
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/ChangeLog,v 1.77 2013/11/24 17:36:37 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/ChangeLog,v 1.78 2013/11/25 16:59:47 johu Exp $
+
+ 25 Nov 2013; Johannes Huber <johu@gentoo.org>
+ +files/kid3-3.0.1-empty-linguas.patch, kid3-3.0.1.ebuild:
+ Add upstream patch which fixes build when LINGUAS is empty, bug #492460.
*kid3-3.0.1 (24 Nov 2013)
diff --git a/media-sound/kid3/files/kid3-3.0.1-empty-linguas.patch b/media-sound/kid3/files/kid3-3.0.1-empty-linguas.patch
new file mode 100644
index 000000000000..ad9c1097f1d3
--- /dev/null
+++ b/media-sound/kid3/files/kid3-3.0.1-empty-linguas.patch
@@ -0,0 +1,36 @@
+commit 94f91f422fbbaaa4af7e46cdaf8fb55c5f675b93
+Author: Urs Fleisch <ufleisch@users.sourceforge.net>
+Date: Mon Nov 25 07:55:53 2013 +0100
+
+ Enable building with all translations disabled, [bugs:#84].
+
+ In Gentoo, it is possible to disable linguas by renaming them from
+ .po to .po.old. If all po files are disabled this way, cmake failed.
+
+diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
+index f036ea6..6cd9fdb 100644
+--- a/po/CMakeLists.txt
++++ b/po/CMakeLists.txt
+@@ -22,13 +22,15 @@ if (APPLE OR WIN32)
+ endforeach (_currentPoFile)
+ endif (APPLE OR WIN32)
+
+-add_custom_command(
+- OUTPUT ${_tsFiles}
+- COMMAND ${PERL_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/po2ts.pl
+- ${QT_LUPDATE_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}
+- ${CMAKE_CURRENT_SOURCE_DIR}/../src
+- DEPENDS ${_poFiles}
+-)
++if (_tsFiles)
++ add_custom_command(
++ OUTPUT ${_tsFiles}
++ COMMAND ${PERL_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/po2ts.pl
++ ${QT_LUPDATE_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}
++ ${CMAKE_CURRENT_SOURCE_DIR}/../src
++ DEPENDS ${_poFiles}
++ )
++endif (_tsFiles)
+ if (APPLE OR WIN32)
+ qt4_add_translation(_qmFiles ${_tsFiles} ${_qtTsFiles})
+ add_custom_target(translations "ALL" DEPENDS ${_qmFiles})
diff --git a/media-sound/kid3/kid3-3.0.1.ebuild b/media-sound/kid3/kid3-3.0.1.ebuild
index f382e7be01e9..8c4e178e0559 100644
--- a/media-sound/kid3/kid3-3.0.1.ebuild
+++ b/media-sound/kid3/kid3-3.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/kid3-3.0.1.ebuild,v 1.1 2013/11/24 17:36:37 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/kid3-3.0.1.ebuild,v 1.2 2013/11/25 16:59:47 johu Exp $
EAPI=5
@@ -46,6 +46,7 @@ DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}/${P}-qt5-automagic.patch"
"${FILESDIR}/${P}-rpath.patch"
+ "${FILESDIR}/${P}-empty-linguas.patch"
)
src_configure() {