summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Schuerch <nativemad@gentoo.org>2013-11-05 09:12:19 +0000
committerAndreas Schuerch <nativemad@gentoo.org>2013-11-05 09:12:19 +0000
commitbd7c1130b6736c0671d7978264f3eb2fce351c9e (patch)
tree72470d2f2a0bda2d168a40521f64515929f91c68 /media-sound
parentadded new version, updated old to use new eclasses (diff)
downloadgentoo-2-bd7c1130b6736c0671d7978264f3eb2fce351c9e.tar.gz
gentoo-2-bd7c1130b6736c0671d7978264f3eb2fce351c9e.tar.bz2
gentoo-2-bd7c1130b6736c0671d7978264f3eb2fce351c9e.zip
Moved the versioned build to the github zip instead of using git directly. See bug 484674.
(Portage version: 2.2.1/cvs/Linux i686, signed Manifest commit with key C1DE54B2)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/ardour/ChangeLog7
-rw-r--r--media-sound/ardour/ardour-3.5.14.ebuild17
-rw-r--r--media-sound/ardour/ardour-9999.ebuild17
3 files changed, 32 insertions, 9 deletions
diff --git a/media-sound/ardour/ChangeLog b/media-sound/ardour/ChangeLog
index 0206acf8b66d..f4ed70e7315e 100644
--- a/media-sound/ardour/ChangeLog
+++ b/media-sound/ardour/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/ardour
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ChangeLog,v 1.121 2013/10/28 18:50:02 nativemad Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ChangeLog,v 1.122 2013/11/05 09:12:19 nativemad Exp $
+
+ 05 Nov 2013; Andreas Schuerch <nativemad@gentoo.org> ardour-3.5.14.ebuild,
+ ardour-9999.ebuild:
+ Moved the versioned build to the github zip instead of using git directly.
+ See bug 484674
*ardour-3.5.14 (28 Oct 2013)
diff --git a/media-sound/ardour/ardour-3.5.14.ebuild b/media-sound/ardour/ardour-3.5.14.ebuild
index 39a1514ee2a7..30ec2650e852 100644
--- a/media-sound/ardour/ardour-3.5.14.ebuild
+++ b/media-sound/ardour/ardour-3.5.14.ebuild
@@ -1,19 +1,20 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ardour-3.5.14.ebuild,v 1.1 2013/10/28 18:50:02 nativemad Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ardour-3.5.14.ebuild,v 1.2 2013/11/05 09:12:19 nativemad Exp $
EAPI=4
inherit eutils git-2 toolchain-funcs flag-o-matic waf-utils
DESCRIPTION="Digital Audio Workstation"
HOMEPAGE="http://ardour.org/"
-EGIT_REPO_URI="http://git.ardour.org/ardour/ardour.git"
if [ ${PV} = 9999 ]; then
KEYWORDS=""
+ EGIT_REPO_URI="http://git.ardour.org/ardour/ardour.git"
+
else
- EGIT_COMMIT="${PV}"
KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/Ardour/ardour/archive/${PV}.zip -> ${P}.zip"
fi
LICENSE="GPL-2"
@@ -65,10 +66,18 @@ DEPEND="${RDEPEND}
doc? ( app-doc/doxygen[dot] )"
src_unpack() {
- git-2_src_unpack
+ if [ ${PV} = 9999 ]; then
+ git-2_src_unpack
+ else
+ unpack ${A}
+ fi
}
src_prepare(){
+ if ! [ ${PV} = 9999 ]; then
+ sed -e '/cmd = "git describe --tags/,/utf-8/{s:cmd = \"git describe --tags HEAD\":rev = \"'${PV}'\":p;d}' -i "${S}"/wscript
+ sed -e 's/'os.path.exists\(\'.git'/'os.path.exists\(\'wscript/'' -i "${S}"/wscript
+ fi
epatch "${FILESDIR}"/${PN}-3.5-syslibs.patch
sed 's/python/python2/' -i waf
}
diff --git a/media-sound/ardour/ardour-9999.ebuild b/media-sound/ardour/ardour-9999.ebuild
index 43ba284ba7e5..01a83f5b7e85 100644
--- a/media-sound/ardour/ardour-9999.ebuild
+++ b/media-sound/ardour/ardour-9999.ebuild
@@ -1,19 +1,20 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ardour-9999.ebuild,v 1.2 2013/10/28 18:50:02 nativemad Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ardour-9999.ebuild,v 1.3 2013/11/05 09:12:19 nativemad Exp $
EAPI=4
inherit eutils git-2 toolchain-funcs flag-o-matic waf-utils
DESCRIPTION="Digital Audio Workstation"
HOMEPAGE="http://ardour.org/"
-EGIT_REPO_URI="git://git.ardour.org/ardour/ardour.git"
if [ ${PV} = 9999 ]; then
KEYWORDS=""
+ EGIT_REPO_URI="http://git.ardour.org/ardour/ardour.git"
+
else
- EGIT_COMMIT="${PV}"
KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/Ardour/ardour/archive/${PV}.zip -> ${P}.zip"
fi
LICENSE="GPL-2"
@@ -65,10 +66,18 @@ DEPEND="${RDEPEND}
doc? ( app-doc/doxygen[dot] )"
src_unpack() {
- git-2_src_unpack
+ if [ ${PV} = 9999 ]; then
+ git-2_src_unpack
+ else
+ unpack ${A}
+ fi
}
src_prepare(){
+ if ! [ ${PV} = 9999 ]; then
+ sed -e '/cmd = "git describe --tags/,/utf-8/{s:cmd = \"git describe --tags HEAD\":rev = \"'${PV}'\":p;d}' -i "${S}"/wscript
+ sed -e 's/'os.path.exists\(\'.git'/'os.path.exists\(\'wscript/'' -i "${S}"/wscript
+ fi
epatch "${FILESDIR}"/${PN}-3.5-syslibs.patch
sed 's/python/python2/' -i waf
}