summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-11-23 23:41:16 +0000
committerTim Harder <radhermit@gentoo.org>2012-11-23 23:41:16 +0000
commitb86fc9b372b52d89ee111b665f25ff56b99a7440 (patch)
treeea84d9be167dc0a0ed1ce75f5c56fb2e8f8af49e /media-sound
parentUpdates; drop 3.5.7 and update to 3.4.19/3.6.7. Use git pull from linux-mips... (diff)
downloadgentoo-2-b86fc9b372b52d89ee111b665f25ff56b99a7440.tar.gz
gentoo-2-b86fc9b372b52d89ee111b665f25ff56b99a7440.tar.bz2
gentoo-2-b86fc9b372b52d89ee111b665f25ff56b99a7440.zip
Version bump.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/abcmidi/ChangeLog7
-rw-r--r--media-sound/abcmidi/abcmidi-2012.11.23.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/media-sound/abcmidi/ChangeLog b/media-sound/abcmidi/ChangeLog
index 1408cb0e2802..c37985232713 100644
--- a/media-sound/abcmidi/ChangeLog
+++ b/media-sound/abcmidi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/abcmidi
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/abcmidi/ChangeLog,v 1.23 2012/08/21 16:22:53 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/abcmidi/ChangeLog,v 1.24 2012/11/23 23:41:16 radhermit Exp $
+
+*abcmidi-2012.11.23 (23 Nov 2012)
+
+ 23 Nov 2012; Tim Harder <radhermit@gentoo.org> +abcmidi-2012.11.23.ebuild:
+ Version bump.
*abcmidi-2012.08.08 (21 Aug 2012)
diff --git a/media-sound/abcmidi/abcmidi-2012.11.23.ebuild b/media-sound/abcmidi/abcmidi-2012.11.23.ebuild
new file mode 100644
index 000000000000..9c4a48f0ab82
--- /dev/null
+++ b/media-sound/abcmidi/abcmidi-2012.11.23.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/abcmidi/abcmidi-2012.11.23.ebuild,v 1.1 2012/11/23 23:41:16 radhermit Exp $
+
+EAPI="5"
+
+inherit eutils versionator autotools
+
+MY_P="abcMIDI-$(replace_all_version_separators '-')"
+DESCRIPTION="Programs for processing ABC music notation files"
+HOMEPAGE="http://abc.sourceforge.net/abcMIDI/"
+SRC_URI="http://ifdo.pugmarks.com/~seymour/runabc/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2011.10.19-install.patch
+ rm configure makefile || die
+ sed -i -e "s:-O2::" configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc doc/{AUTHORS,CHANGES,abcguide.txt,abcmatch.txt,history.txt,readme.txt,yapshelp.txt}
+
+ if use examples ; then
+ docinto examples
+ dodoc samples/*.abc
+ fi
+}