summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-11-06 23:17:02 +0000
committerMike Frysinger <vapier@gentoo.org>2012-11-06 23:17:02 +0000
commitb4f417d1ae2ff45d060773807a4c75dd0f9cfc60 (patch)
tree089ef5438d84b09cb17fdf6749bef99c16f45b1e /media-sound
parentAppend GPL-2 in all ebuilds to cover the initscript license, bug 425870 (diff)
downloadgentoo-2-b4f417d1ae2ff45d060773807a4c75dd0f9cfc60.tar.gz
gentoo-2-b4f417d1ae2ff45d060773807a4c75dd0f9cfc60.tar.bz2
gentoo-2-b4f417d1ae2ff45d060773807a4c75dd0f9cfc60.zip
Add USE="ncurses libsamplerate" to control utils that use the respective libs, and expand USE=minimal to control alsa-info (which uses dialog) #441982.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/alsa-utils/ChangeLog9
-rw-r--r--media-sound/alsa-utils/alsa-utils-1.0.26-r1.ebuild81
-rw-r--r--media-sound/alsa-utils/metadata.xml5
3 files changed, 94 insertions, 1 deletions
diff --git a/media-sound/alsa-utils/ChangeLog b/media-sound/alsa-utils/ChangeLog
index f65e0a6a3fad..3dc03afb6c41 100644
--- a/media-sound/alsa-utils/ChangeLog
+++ b/media-sound/alsa-utils/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/alsa-utils
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.327 2012/09/09 09:13:26 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.328 2012/11/06 23:17:02 vapier Exp $
+
+*alsa-utils-1.0.26-r1 (06 Nov 2012)
+
+ 06 Nov 2012; Mike Frysinger <vapier@gentoo.org> +alsa-utils-1.0.26-r1.ebuild,
+ metadata.xml:
+ Add USE="ncurses libsamplerate" to control utils that use the respective libs,
+ and expand USE=minimal to control alsa-info (which uses dialog) #441982.
09 Sep 2012; Samuli Suominen <ssuominen@gentoo.org>
-alsa-utils-1.0.23-r1.ebuild, -files/alsa-utils-1.0.23-alsactl-output.patch,
diff --git a/media-sound/alsa-utils/alsa-utils-1.0.26-r1.ebuild b/media-sound/alsa-utils/alsa-utils-1.0.26-r1.ebuild
new file mode 100644
index 000000000000..b286b517222e
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-1.0.26-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-1.0.26-r1.ebuild,v 1.1 2012/11/06 23:17:02 vapier Exp $
+
+EAPI=4
+inherit eutils systemd toolchain-funcs
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/utils/${P}.tar.bz2
+ !minimal? ( mirror://alsaproject/driver/alsa-driver-1.0.25.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="doc +libsamplerate minimal +ncurses nls selinux"
+
+COMMON_DEPEND=">=media-libs/alsa-lib-${PV}
+ libsamplerate? ( media-libs/libsamplerate )
+ ncurses? ( >=sys-libs/ncurses-5.7-r7 )
+ selinux? ( sec-policy/selinux-alsa )"
+RDEPEND="${COMMON_DEPEND}
+ !minimal? (
+ dev-util/dialog
+ sys-apps/pciutils
+ )"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ doc? ( app-text/xmlto )"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.0.23-modprobe.d.patch \
+ "${FILESDIR}"/${PN}-1.0.25-separate-usr-var-fs.patch
+}
+
+src_configure() {
+ local myconf
+ use doc || myconf='--disable-xmlto'
+
+ local udevdir=/lib/udev
+ has_version sys-fs/udev && udevdir="$($(tc-getPKG_CONFIG) --variable=udevdir udev)"
+
+ econf \
+ $(use_enable libsamplerate alsaloop) \
+ $(use_enable nls) \
+ $(use_enable ncurses alsamixer) \
+ $(use_enable !minimal alsaconf) \
+ "$(systemd_with_unitdir)" \
+ --with-udev-rules-dir="${udevdir}"/rules.d \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc ChangeLog README TODO seq/*/README.*
+
+ use minimal || newbin "${WORKDIR}"/alsa-driver-*/utils/alsa-info.sh alsa-info
+
+ newinitd "${FILESDIR}"/alsasound.initd-r5 alsasound
+ newconfd "${FILESDIR}"/alsasound.confd-r4 alsasound
+
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}"/alsa-modules.conf-rc alsa.conf
+
+ keepdir /var/lib/alsa
+}
+
+pkg_postinst() {
+ echo
+ elog "To take advantage of the init script, and automate the process of"
+ elog "saving and restoring sound-card mixer levels you should"
+ elog "add alsasound to the boot runlevel. You can do this as"
+ elog "root like so:"
+ elog " # rc-update add alsasound boot"
+ echo
+ ewarn "The ALSA core should be built into the kernel or loaded through other"
+ ewarn "means. There is no longer any modular auto(un)loading in alsa-utils."
+ echo
+}
diff --git a/media-sound/alsa-utils/metadata.xml b/media-sound/alsa-utils/metadata.xml
index 4ce038f08186..daf88adbff29 100644
--- a/media-sound/alsa-utils/metadata.xml
+++ b/media-sound/alsa-utils/metadata.xml
@@ -5,4 +5,9 @@
<maintainer>
<email>alsa-bugs@gentoo.org</email>
</maintainer>
+ <use>
+ <flag name='libsamplerate'>install utils that use libsamplerate (e.g. alsaloop)</flag>
+ <flag name='minimal'>omit utils that rely on extra packages (e.g. alsaconf and alsa-info)</flag>
+ <flag name='ncurses'>install utils that use ncurses (e.g. alsamixer)</flag>
+ </use>
</pkgmetadata>