summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2008-09-01 18:18:41 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2008-09-01 18:18:41 +0000
commitac1ea484fdb0aebfcaa19e5a6b09220a7f6ea0b9 (patch)
tree0d736d7cec15a10b6e049de6d75a6d671d9fcff4 /media-sound
parentRemove old ebuilds. (diff)
downloadgentoo-2-ac1ea484fdb0aebfcaa19e5a6b09220a7f6ea0b9.tar.gz
gentoo-2-ac1ea484fdb0aebfcaa19e5a6b09220a7f6ea0b9.tar.bz2
gentoo-2-ac1ea484fdb0aebfcaa19e5a6b09220a7f6ea0b9.zip
Add back 1.0.14 as it's the only stable on sh.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo i686)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/alsa-utils/ChangeLog6
-rw-r--r--media-sound/alsa-utils/alsa-utils-1.0.14.ebuild86
2 files changed, 91 insertions, 1 deletions
diff --git a/media-sound/alsa-utils/ChangeLog b/media-sound/alsa-utils/ChangeLog
index 4a61d096ab5b..2774fbe787c9 100644
--- a/media-sound/alsa-utils/ChangeLog
+++ b/media-sound/alsa-utils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/alsa-utils
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.243 2008/09/01 18:06:39 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.244 2008/09/01 18:18:41 betelgeuse Exp $
+
+ 01 Sep 2008; Petteri Räty <betelgeuse@gentoo.org>
+ +alsa-utils-1.0.14.ebuild:
+ Add back 1.0.14 as it's the only stable on sh.
01 Sep 2008; Petteri Räty <betelgeuse@gentoo.org>
-alsa-utils-1.0.14_rc2-r3.ebuild, -alsa-utils-1.0.14.ebuild,
diff --git a/media-sound/alsa-utils/alsa-utils-1.0.14.ebuild b/media-sound/alsa-utils/alsa-utils-1.0.14.ebuild
new file mode 100644
index 000000000000..ee1c716f75d1
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-1.0.14.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-1.0.14.ebuild,v 1.10 2008/09/01 18:18:41 betelgeuse Exp $
+
+WANT_AUTOMAKE="latest"
+WANT_AUTOCONF="latest"
+
+inherit eutils autotools
+
+MY_P="${P/_rc/rc}"
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/utils/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~sh"
+IUSE="nls midi"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ dev-util/dialog
+ >=media-libs/alsa-lib-1.0.14_rc1"
+RDEPEND="${DEPEND}
+ virtual/modutils
+ sys-apps/pciutils"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if use midi && ! built_with_use --missing true media-libs/alsa-lib midi; then
+ eerror ""
+ eerror "To be able to build alsa-utils with midi support you need"
+ eerror "to have built media-libs/alsa-lib with midi USE flag."
+ die "Missing midi USE flag on media-libs/alsa-lib"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-1.0.11_rc2-nls.patch"
+ epatch "${FILESDIR}/${PN}-1.0.11_rc5-alsaconf-redirect.patch"
+ epatch "${FILESDIR}/${P}-seq.patch"
+
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable midi sequencer) \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ local ALSA_UTILS_DOCS="ChangeLog README TODO
+ seq/aconnect/README.aconnect
+ seq/aseqnet/README.aseqnet"
+
+ emake DESTDIR="${D}" install || die "Installation Failed"
+
+ dodoc ${ALSA_UTILS_DOCS}
+ newdoc alsamixer/README README.alsamixer
+
+ newinitd "${FILESDIR}/alsasound.initd" alsasound
+ newconfd "${FILESDIR}/alsasound.confd" alsasound
+ insinto /etc/modules.d
+ newins "${FILESDIR}/alsa-modules.conf-rc" alsa
+
+ keepdir /var/lib/alsa
+}
+
+pkg_postinst() {
+ echo
+ elog "To take advantage of the init script, and automate the process of"
+ elog "loading and unloading the ALSA sound drivers as well as"
+ elog "storing and restoring sound-card mixer levels you should"
+ elog "add alsasound to the boot runlevel. You can do this as"
+ elog "root like so:"
+ elog " # rc-update add alsasound boot"
+ echo
+}