summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-06-12 01:01:43 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-06-12 01:01:43 +0000
commit9e33eac25ff6ceed6987d605f51a88d423fb2032 (patch)
tree1b3a3be8e755440c9f97cb101222e1c81407a071 /media-sound
parent[package.mask] Masked media-sound/amarok-2.3.1-r1 for some quick tests of the... (diff)
downloadgentoo-2-9e33eac25ff6ceed6987d605f51a88d423fb2032.tar.gz
gentoo-2-9e33eac25ff6ceed6987d605f51a88d423fb2032.tar.bz2
gentoo-2-9e33eac25ff6ceed6987d605f51a88d423fb2032.zip
[media-sound/amarok-2.3.1-r1] Merged amarok and amarok-utils. Applied patch to drop the accessibility requirement - should fix bug 319803.
Reviewed mysql deps to allow for mariadb - fixes bug 320807. Applied minimal-toc cflag to avoid issues on ppc64 - should fix bug 280552. Testing for this masked version is welcomed. (Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/amarok/ChangeLog13
-rw-r--r--media-sound/amarok/amarok-2.3.1-r1.ebuild153
-rw-r--r--media-sound/amarok/files/amarok-fix-accessibility-dep.patch13
-rw-r--r--media-sound/amarok/metadata.xml2
4 files changed, 180 insertions, 1 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index 1624f9fb3523..16af8279d466 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for media-sound/amarok
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.374 2010/06/09 12:42:57 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.375 2010/06/12 01:01:42 jmbsvicetto Exp $
+
+*amarok-2.3.1-r1 (12 Jun 2010)
+
+ 12 Jun 2010; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +amarok-2.3.1-r1.ebuild, +files/amarok-fix-accessibility-dep.patch,
+ metadata.xml:
+ [media-sound/amarok-2.3.1-r1] Merged amarok and amarok-utils. Applied
+ patch to drop the accessibility requirement - should fix bug 319803.
+ Reviewed mysql deps to allow for mariadb - fixes bug 320807. Applied
+ minimal-toc cflag to avoid issues on ppc64 - should fix bug 280552.
+ Testing for this masked version is welcomed.
09 Jun 2010; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
amarok-2.3.1.ebuild:
diff --git a/media-sound/amarok/amarok-2.3.1-r1.ebuild b/media-sound/amarok/amarok-2.3.1-r1.ebuild
new file mode 100644
index 000000000000..44fd2b1ec5c2
--- /dev/null
+++ b/media-sound/amarok/amarok-2.3.1-r1.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-2.3.1-r1.ebuild,v 1.1 2010/06/12 01:01:42 jmbsvicetto Exp $
+
+EAPI="2"
+
+# Translations are only in the tarballs, not the git repo
+if [[ ${PV} != *9999* ]]; then
+ KDE_LINGUAS="bg ca cs da de en_GB es et eu fi fr it ja km nb nds nl
+ pa pl pt pt_BR ru sl sr sr@latin sv th tr uk wa zh_TW"
+else
+ EGIT_REPO_URI="git://gitorious.org/${PN}/${PN}.git"
+ GIT_ECLASS="git"
+fi
+OPENGL_REQUIRED="optional"
+KDE_REQUIRED="never"
+inherit flag-o-matic kde4-base ${GIT_ECLASS}
+
+DESCRIPTION="Advanced audio player based on KDE framework."
+HOMEPAGE="http://amarok.kde.org/"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+else
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.bz2"
+fi
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="4"
+IUSE="cdda daap debug embedded ipod lastfm mp3tunes mtp +player semantic-desktop +utils"
+
+# ipod requires gdk enabled and also gtk compiled in libgpod
+# Some UI dialogs require qt-gui built with the accessibility use flag
+DEPEND="
+ !<=media-sound/amarok-utils-2.3.1
+ >=media-libs/taglib-1.6.1[asf,mp4]
+ >=media-libs/taglib-extras-1.0.1
+ player? (
+ app-crypt/qca:2
+ >=app-misc/strigi-0.5.7[dbus,qt4]
+ || ( >=dev-db/mysql-5.0.76 =virtual/mysql-5.1 )
+ >=kde-base/kdelibs-${KDE_MINIMAL}[opengl?,semantic-desktop?]
+ sys-libs/zlib
+ x11-libs/qt-script
+ >=x11-libs/qtscriptgenerator-0.1.0
+ cdda? (
+ >=kde-base/libkcddb-${KDE_MINIMAL}
+ >=kde-base/libkcompactdisc-${KDE_MINIMAL}
+ >=kde-base/kdemultimedia-kioslaves-${KDE_MINIMAL}
+ )
+ embedded? ( <dev-db/mysql-5.1[embedded,-minimal] )
+ ipod? ( >=media-libs/libgpod-0.7.0[gtk] )
+ lastfm? ( >=media-libs/liblastfm-0.3.0 )
+ mp3tunes? (
+ dev-libs/glib:2
+ dev-libs/libxml2
+ dev-libs/openssl
+ net-libs/loudmouth
+ net-misc/curl
+ x11-libs/qt-core[glib]
+ )
+ mtp? ( >=media-libs/libmtp-0.3.0 )
+ )
+ !player? ( !utils? ( media-sound/amarok[player] ) )
+"
+RDEPEND="${DEPEND}
+ >=kde-base/phonon-kde-${KDE_MINIMAL}
+ player? (
+ semantic-desktop? ( >=kde-base/nepomuk-${KDE_MINIMAL} )
+ )
+"
+
+# Tests require gmock - http://code.google.com/p/gmock/
+# It's not in the tree yet
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/${PN}-fix-accessibility-dep.patch" )
+
+# required for live ebuild, to skip git_src_prepare, to add
+# the minimal-toc cflag for ppc64 and to fix po issues on utils
+src_prepare() {
+ use ppc64 && append-flags -mminimal-toc
+
+ if ! use player; then
+
+ # Disable po processing
+ sed -e "s:include(MacroOptionalAddSubdirectory)::" \
+ -i "${S}/CMakeLists.txt" \
+ || die "Removing include of MacroOptionalAddSubdirectory failed."
+ sed -e "s:macro_optional_add_subdirectory( po )::" \
+ -i "${S}/CMakeLists.txt" \
+ || die "Removing include of MacroOptionalAddSubdirectory failed."
+ fi
+
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ if use player; then
+ mycmakeargs=(
+ -DWITH_PLAYER=ON
+ -DWITH_Libgcrypt=OFF
+ $(cmake-utils_use embedded WITH_MYSQL_EMBEDDED)
+ $(cmake-utils_use_with ipod)
+ $(cmake-utils_use_with ipod Gdk)
+ $(cmake-utils_use_with lastfm LibLastFm)
+ $(cmake-utils_use_with mtp)
+ $(cmake-utils_use_with mp3tunes MP3Tunes)
+ )
+ else
+ mycmakeargs=(
+ -DWITH_PLAYER=OFF
+ )
+ fi
+
+ mycmakeargs+=(
+ $(cmake-utils_use_with utilities UTILITIES)
+ )
+ # $(cmake-utils_use_with semantic-desktop Nepomuk)
+ # $(cmake-utils_use_with semantic-desktop Soprano)
+
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if use player; then
+
+ if use daap; then
+ echo
+ elog "You have installed amarok with daap support."
+ elog "You may be interested in installing www-servers/mongrel as well."
+ echo
+ fi
+
+ if ! use embedded; then
+ echo
+ elog "You've disabled the amarok support for embedded mysql DBs."
+ elog "You'll have to configure amarok to use an external db server."
+ echo
+ elog "Please read http://amaroklive.com/wiki/MySQL_Server for details on how"
+ elog "to configure the external db and migrate your data from the embedded database."
+ echo
+
+ if has_version "dev-db/mysql[minimal]"; then
+ elog "You built mysql with the minimal use flag, so it doesn't include the server."
+ elog "You won't be able to use the local mysql installation to store your amarok collection."
+ echo
+ fi
+ fi
+ fi
+}
diff --git a/media-sound/amarok/files/amarok-fix-accessibility-dep.patch b/media-sound/amarok/files/amarok-fix-accessibility-dep.patch
new file mode 100644
index 000000000000..d86abe920497
--- /dev/null
+++ b/media-sound/amarok/files/amarok-fix-accessibility-dep.patch
@@ -0,0 +1,13 @@
+diff -urN amarok-2.3.1/src/core-impl/collections/audiocd/FormatSelectionDialog.ui amarok-2.3.1-new/src/core-impl/collections/audiocd/FormatSelectionDialog.ui
+--- amarok-2.3.1/src/core-impl/collections/audiocd/FormatSelectionDialog.ui 2010-05-27 18:37:21.000000000 +0000
++++ amarok-2.3.1-new/src/core-impl/collections/audiocd/FormatSelectionDialog.ui 2010-06-11 18:23:00.157305026 +0000
+@@ -13,9 +13,6 @@
+ <property name="windowTitle">
+ <string>Amarok</string>
+ </property>
+- <property name="accessibleName">
+- <string/>
+- </property>
+ <layout class="QGridLayout" name="gridLayout_2">
+ <item row="0" column="0" colspan="2">
+ <widget class="QGroupBox" name="groupBox">
diff --git a/media-sound/amarok/metadata.xml b/media-sound/amarok/metadata.xml
index 69cf7b8fd01e..935d3e8454f0 100644
--- a/media-sound/amarok/metadata.xml
+++ b/media-sound/amarok/metadata.xml
@@ -20,5 +20,7 @@
</flag>
<flag name="lastfm">Enable Last.fm streaming services support through <pkg>media-libs/liblastfm</pkg></flag>
<flag name="mp3tunes">Enable mp3tunes integration</flag>
+ <flag name="player">Build the player</flag>
+ <flag name="utils">Build the utils - old <pkg>media-sound/amarok-utils</pkg></flag>
</use>
</pkgmetadata>