summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-07-25 09:08:37 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-07-25 09:08:37 +0000
commit99912e0f6469eea1f5fd2446af8e57f37bf9cfd9 (patch)
treef3f07ef1278e657fe20033d161cb875133870560 /media-sound
parentold (diff)
downloadgentoo-2-99912e0f6469eea1f5fd2446af8e57f37bf9cfd9.tar.gz
gentoo-2-99912e0f6469eea1f5fd2446af8e57f37bf9cfd9.tar.bz2
gentoo-2-99912e0f6469eea1f5fd2446af8e57f37bf9cfd9.zip
version bump
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/zynaddsubfx/ChangeLog7
-rw-r--r--media-sound/zynaddsubfx/zynaddsubfx-2.4.3.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/media-sound/zynaddsubfx/ChangeLog b/media-sound/zynaddsubfx/ChangeLog
index 5cb6b1a652f2..5d6cac81c6d6 100644
--- a/media-sound/zynaddsubfx/ChangeLog
+++ b/media-sound/zynaddsubfx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/zynaddsubfx
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/zynaddsubfx/ChangeLog,v 1.41 2012/05/05 08:55:58 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/zynaddsubfx/ChangeLog,v 1.42 2012/07/25 09:08:37 aballier Exp $
+
+*zynaddsubfx-2.4.3 (25 Jul 2012)
+
+ 25 Jul 2012; Alexis Ballier <aballier@gentoo.org> +zynaddsubfx-2.4.3.ebuild:
+ version bump
05 May 2012; Michał Górny <mgorny@gentoo.org> zynaddsubfx-2.4.1.ebuild,
zynaddsubfx-2.4.2.ebuild:
diff --git a/media-sound/zynaddsubfx/zynaddsubfx-2.4.3.ebuild b/media-sound/zynaddsubfx/zynaddsubfx-2.4.3.ebuild
new file mode 100644
index 000000000000..2e3885c94981
--- /dev/null
+++ b/media-sound/zynaddsubfx/zynaddsubfx-2.4.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/zynaddsubfx/zynaddsubfx-2.4.3.ebuild,v 1.1 2012/07/25 09:08:37 aballier Exp $
+
+EAPI=4
+inherit eutils cmake-utils
+
+MY_P=ZynAddSubFX-${PV}
+
+DESCRIPTION="ZynAddSubFX is an opensource software synthesizer."
+HOMEPAGE="http://zynaddsubfx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/zynaddsubfx/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa +fltk jack lash"
+
+RDEPEND=">=dev-libs/mini-xml-2.2.1
+ sci-libs/fftw:3.0
+ alsa? ( media-libs/alsa-lib )
+ fltk? ( >=x11-libs/fltk-1.3:1 )
+ jack? ( media-sound/jack-audio-connection-kit )
+ lash? ( media-sound/lash )"
+# portaudio? ( media-libs/portaudio )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+# Upstream uses the following preferences: alsa > jack > portaudio
+# At least one of them must be enabled
+# We do not support portaudio, so if alsa is disabled force jack.
+REQUIRED_USE="!alsa? ( jack )"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.4.1-docs.patch
+)
+
+DOCS="ChangeLog FAQ.txt HISTORY.txt README.txt ZynAddSubFX.lsm bugs.txt"
+
+src_configure() {
+ use lash || sed -i -e 's/lash-1.0/lash_disabled/' "${S}"/src/CMakeLists.txt
+ mycmakeargs=(
+ `use fltk && echo "-DGuiModule=fltk" || echo "-DGuiModule=off"`
+ `use alsa && echo "-DOutputModule=alsa" || echo "-DOutputModule=jack"`
+ `use alsa && echo "-DAlsaMidiOutput=TRUE" || echo "-DAlsaMidiOutput=FALSE"`
+ `use jack && echo "-DJackOutput=TRUE" || echo "-DJackOutput=FALSE"`
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ insinto /usr/share/${PN}
+ doins -r "${S}"/instruments/*
+}