summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-06-26 01:28:00 +0000
committerIan Delaney <idella4@gentoo.org>2014-06-26 01:28:00 +0000
commit98d1334730202a7a7a5607b6614f5e5fff8ee0a6 (patch)
treed92a302997220e76891c01cbdd928d857b7350f0 /media-sound
parentInitial commit (diff)
downloadgentoo-2-98d1334730202a7a7a5607b6614f5e5fff8ee0a6.tar.gz
gentoo-2-98d1334730202a7a7a5607b6614f5e5fff8ee0a6.tar.bz2
gentoo-2-98d1334730202a7a7a5607b6614f5e5fff8ee0a6.zip
tidy deps, remove rogue pip dep in setup.py, fixes Bug #514976
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/lyvi/ChangeLog5
-rw-r--r--media-sound/lyvi/lyvi-2.0.0.ebuild11
2 files changed, 12 insertions, 4 deletions
diff --git a/media-sound/lyvi/ChangeLog b/media-sound/lyvi/ChangeLog
index 1e875d577aae..b8871a338df2 100644
--- a/media-sound/lyvi/ChangeLog
+++ b/media-sound/lyvi/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/lyvi
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lyvi/ChangeLog,v 1.2 2014/06/25 12:45:33 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lyvi/ChangeLog,v 1.3 2014/06/26 01:28:00 idella4 Exp $
+
+ 26 Jun 2014; Ian Delaney <idella4@gentoo.org> lyvi-2.0.0.ebuild:
+ tidy deps, remove rogue pip dep in setup.py, fixes Bug #514976
25 Jun 2014; Jeroen Roovers <jer@gentoo.org> metadata.xml:
Fix e-mail address.
diff --git a/media-sound/lyvi/lyvi-2.0.0.ebuild b/media-sound/lyvi/lyvi-2.0.0.ebuild
index 461622e0c7e7..37a93445f3b0 100644
--- a/media-sound/lyvi/lyvi-2.0.0.ebuild
+++ b/media-sound/lyvi/lyvi-2.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lyvi/lyvi-2.0.0.ebuild,v 1.1 2014/06/22 13:13:31 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lyvi/lyvi-2.0.0.ebuild,v 1.2 2014/06/26 01:28:00 idella4 Exp $
EAPI="5"
PYTHON_COMPAT=( python3_3 )
@@ -24,5 +24,10 @@ RDEPEND="dev-python/pillow[${PYTHON_USEDEP}]
dev-python/dbus-python[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]
)"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # Remove pip dependency
+ sed -e '/require/d' --in-place setup.py || die
+ distutils-r1_python_prepare_all
+}