summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2009-02-13 23:07:23 +0000
committerCarsten Lohrke <carlo@gentoo.org>2009-02-13 23:07:23 +0000
commit95766c4ba8eb87ce571f4e21adeb2ac1d6791277 (patch)
tree6a7d2e80019f496405b6f3e1170ca3100754e95d /media-sound
parentAdding a warning message when raster use flag is enabled (diff)
downloadgentoo-2-95766c4ba8eb87ce571f4e21adeb2ac1d6791277.tar.gz
gentoo-2-95766c4ba8eb87ce571f4e21adeb2ac1d6791277.tar.bz2
gentoo-2-95766c4ba8eb87ce571f4e21adeb2ac1d6791277.zip
Get rid of invalid aRts dependency.
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/noteedit/ChangeLog9
-rw-r--r--media-sound/noteedit/noteedit-2.8.1-r2.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/media-sound/noteedit/ChangeLog b/media-sound/noteedit/ChangeLog
index 17ecae9bbdf3..e4592949675d 100644
--- a/media-sound/noteedit/ChangeLog
+++ b/media-sound/noteedit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/noteedit
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/noteedit/ChangeLog,v 1.34 2008/06/25 17:24:22 aballier Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/noteedit/ChangeLog,v 1.35 2009/02/13 23:07:23 carlo Exp $
+
+*noteedit-2.8.1-r2 (13 Feb 2009)
+
+ 13 Feb 2009; Carsten Lohrke <carlo@gentoo.org> +noteedit-2.8.1-r2.ebuild:
+ Get rid of invalid aRts dependency.
25 Jun 2008; Alexis Ballier <aballier@gentoo.org>
+files/noteedit-2.8.1+gcc-4.3.1.patch, noteedit-2.8.1-r1.ebuild:
diff --git a/media-sound/noteedit/noteedit-2.8.1-r2.ebuild b/media-sound/noteedit/noteedit-2.8.1-r2.ebuild
new file mode 100644
index 000000000000..e3e0ab9b9f75
--- /dev/null
+++ b/media-sound/noteedit/noteedit-2.8.1-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/noteedit/noteedit-2.8.1-r2.ebuild,v 1.1 2009/02/13 23:07:23 carlo Exp $
+
+ARTS_REQUIRED="never"
+
+EAPI="1"
+
+IUSE="kmid tse3"
+
+LANGS_DOC="de"
+
+USE_KEG_PACKAGING="yes"
+
+inherit kde eutils
+
+DESCRIPTION="Musical score editor."
+HOMEPAGE="http://noteedit.berlios.de/"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="kmid? ( || ( kde-base/kmid:3.5 kde-base/kdemultimedia:3.5 ) )
+ tse3? ( >=media-libs/tse3-0.3.1 )"
+RDEPEND="${DEPEND}"
+need-kde 3.5
+
+PATCHES=( "${FILESDIR}/${P}-desktop-file.patch" "${FILESDIR}/${P}+gcc-4.3.patch" "${FILESDIR}/${P}+gcc-4.3.1.patch" )
+
+src_compile() {
+ use tse3 || use kmid || myconf="--without-libs"
+ use kmid && myconf="${myconf} --with-libkmid-include=$KDEDIR/include
+ --with-libkmid-libs=$KDEDIR/$(get_libdir)"
+ myconf="$(use_with tse3 libtse3) \
+ $(use_with kmid libkmid) ${myconf}"
+
+ rm -f "${S}/configure"
+ kde_src_compile
+}
+
+src_install() {
+ kde_src_install
+ dodoc FAQ FAQ.de
+ docinto examples
+ dodoc noteedit/examples/*
+}