summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-10-19 20:48:43 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-10-19 20:48:43 +0000
commit951c8988a787b860354ead601e6237fcac342dc9 (patch)
treefe694a0442aca98a4341353c9d04a7a9b9d79436 /media-sound
parentVersion bump (diff)
downloadgentoo-2-951c8988a787b860354ead601e6237fcac342dc9.tar.gz
gentoo-2-951c8988a787b860354ead601e6237fcac342dc9.tar.bz2
gentoo-2-951c8988a787b860354ead601e6237fcac342dc9.zip
Version bump (Bug #196175).
(Portage version: 2.1.3.15)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/qsynth/ChangeLog7
-rw-r--r--media-sound/qsynth/files/digest-qsynth-0.3.13
-rw-r--r--media-sound/qsynth/qsynth-0.3.1.ebuild41
3 files changed, 50 insertions, 1 deletions
diff --git a/media-sound/qsynth/ChangeLog b/media-sound/qsynth/ChangeLog
index 1c49189f6eae..43c869f78b50 100644
--- a/media-sound/qsynth/ChangeLog
+++ b/media-sound/qsynth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/qsynth
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qsynth/ChangeLog,v 1.22 2007/06/20 14:39:34 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qsynth/ChangeLog,v 1.23 2007/10/19 20:48:42 flameeyes Exp $
+
+*qsynth-0.3.1 (19 Oct 2007)
+
+ 19 Oct 2007; Diego Pettenò <flameeyes@gentoo.org> +qsynth-0.3.1.ebuild:
+ Version bump (Bug #196175).
*qsynth-0.2.6 (20 Jun 2007)
diff --git a/media-sound/qsynth/files/digest-qsynth-0.3.1 b/media-sound/qsynth/files/digest-qsynth-0.3.1
new file mode 100644
index 000000000000..c1c841b623dc
--- /dev/null
+++ b/media-sound/qsynth/files/digest-qsynth-0.3.1
@@ -0,0 +1,3 @@
+MD5 41de4b244cd896a1150101855bafbbb8 qsynth-0.3.1.tar.gz 137632
+RMD160 276937ef5d118bd651556332290780cc9a48ecdc qsynth-0.3.1.tar.gz 137632
+SHA256 56d0c14f85a9469df97df2d813860a471a71e2206e7e11365e37a3be028a2aa6 qsynth-0.3.1.tar.gz 137632
diff --git a/media-sound/qsynth/qsynth-0.3.1.ebuild b/media-sound/qsynth/qsynth-0.3.1.ebuild
new file mode 100644
index 000000000000..2b071ff35f37
--- /dev/null
+++ b/media-sound/qsynth/qsynth-0.3.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qsynth/qsynth-0.3.1.ebuild,v 1.1 2007/10/19 20:48:42 flameeyes Exp $
+
+inherit qt4 eutils flag-o-matic
+
+DESCRIPTION="A Qt application to control FluidSynth"
+HOMEPAGE="http://qsynth.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qsynth/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+IUSE="debug"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="$(qt4_min_version 4.2)
+ media-sound/fluidsynth"
+
+src_compile() {
+ # Stupidly, qsynth's configure does *not* use pkg-config to
+ # discover the presence of Qt4, but uses fixed paths; as they
+ # don't really work that well for our case, let's just use this
+ # nasty hack and be done with it. *NOTE*: this hinders
+ # cross-compile.
+ append-flags -I/usr/include/qt4
+ append-ldflags -L/usr/$(get_libdir)/qt4
+
+ econf \
+ $(use_enable debug) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog README TODO
+
+ # The desktop file is invalid
+ rm -rf "${D}/usr/share/applications/qsynth.desktop"
+ make_desktop_entry qsynth Qsynth qsynth
+}