summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriele Giorgetti <stroke@gentoo.org>2002-06-05 00:06:26 +0000
committerGabriele Giorgetti <stroke@gentoo.org>2002-06-05 00:06:26 +0000
commit92f6ca11e41554d45fc43c6e1d217482dc80d3d6 (patch)
tree11d28f1a32fb124a9662185e0f2019a4fc76e385 /media-sound
parentcleanup (diff)
downloadgentoo-2-92f6ca11e41554d45fc43c6e1d217482dc80d3d6.tar.gz
gentoo-2-92f6ca11e41554d45fc43c6e1d217482dc80d3d6.tar.bz2
gentoo-2-92f6ca11e41554d45fc43c6e1d217482dc80d3d6.zip
Initial version of normalize added. (New package)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/normalize/ChangeLog12
-rw-r--r--media-sound/normalize/files/digest-normalize-0.7.41
-rw-r--r--media-sound/normalize/normalize-0.7.4.ebuild39
3 files changed, 52 insertions, 0 deletions
diff --git a/media-sound/normalize/ChangeLog b/media-sound/normalize/ChangeLog
new file mode 100644
index 000000000000..096cb11adf7a
--- /dev/null
+++ b/media-sound/normalize/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for media-sound/normalize
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/normalize/ChangeLog,v 1.1 2002/06/05 00:06:26 stroke Exp $
+
+*normalize-0.7.4 (5 May 2002)
+ 5 May 2002; Bardur Arantsson <bardur-gta@odense.kollegienet.dk> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository. \ No newline at end of file
diff --git a/media-sound/normalize/files/digest-normalize-0.7.4 b/media-sound/normalize/files/digest-normalize-0.7.4
new file mode 100644
index 000000000000..69cbb529b079
--- /dev/null
+++ b/media-sound/normalize/files/digest-normalize-0.7.4
@@ -0,0 +1 @@
+MD5 d3655fa5d58f07d3ed92234c7ed75c87 normalize-0.7.4.tar.bz2 286784
diff --git a/media-sound/normalize/normalize-0.7.4.ebuild b/media-sound/normalize/normalize-0.7.4.ebuild
new file mode 100644
index 000000000000..cd3f3bc91832
--- /dev/null
+++ b/media-sound/normalize/normalize-0.7.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/normalize/normalize-0.7.4.ebuild,v 1.1 2002/06/05 00:06:26 stroke Exp $
+
+DESCRIPTION="Audio file volume normalizer"
+HOMEPAGE="http://www.cs.columbia.edu/~cvaill/normalize"
+SRC_URI="http://www.cs.columbia.edu/~cvaill/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="xmms? ( >= xmms-1.2.7r6 )
+ >=media-libs/audiofile-0.2.3-r1
+ >=media-sound/mad-0.14.2b-r1"
+
+DEPEND="${RDEPEND}"
+
+# NOTE: the "audiofile" and "mad" dependencies are NOT
+# actually *required*, they are optional, but there are no
+# appropriate USE variables.
+#
+# The libraries are quite small, so it does not seem to be that
+# big a deal to force installation of them.
+#
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --with-audiofile \
+ --with-mad
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+}