summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn J. Ellis <jje@gentoo.org>2003-08-10 04:24:05 +0000
committerJohn J. Ellis <jje@gentoo.org>2003-08-10 04:24:05 +0000
commit8f4f2bc6ccb4dc47f416637f5085125fd329532f (patch)
tree8f07c2921f3f2e6c4607f5f4c7dd177c6998aa3e /media-sound
parentNew package, ~x86 masked. Closes #22901. (diff)
downloadgentoo-2-8f4f2bc6ccb4dc47f416637f5085125fd329532f.tar.gz
gentoo-2-8f4f2bc6ccb4dc47f416637f5085125fd329532f.tar.bz2
gentoo-2-8f4f2bc6ccb4dc47f416637f5085125fd329532f.zip
New package, ~x86 masked. Closes #22901.
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/fobbit/ChangeLog11
-rw-r--r--media-sound/fobbit/Manifest3
-rw-r--r--media-sound/fobbit/files/digest-fobbit-0.561
-rw-r--r--media-sound/fobbit/fobbit-0.56.ebuild87
4 files changed, 101 insertions, 1 deletions
diff --git a/media-sound/fobbit/ChangeLog b/media-sound/fobbit/ChangeLog
new file mode 100644
index 000000000000..52955fe478bc
--- /dev/null
+++ b/media-sound/fobbit/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for media-sound/fobbit
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fobbit/ChangeLog,v 1.1 2003/08/10 04:23:57 jje Exp $
+
+*fobbit-0.56 (10 Aug 2003)
+
+ 10 Aug 2003; jje <jje@gentoo.org> fobbit-0.56.ebuild:
+ Initial revision.
+
+ Submitted by: mike wakerly <mikew@wakerly.com>
+
diff --git a/media-sound/fobbit/Manifest b/media-sound/fobbit/Manifest
index 033d90fc45df..a7387506d995 100644
--- a/media-sound/fobbit/Manifest
+++ b/media-sound/fobbit/Manifest
@@ -1,2 +1,3 @@
-MD5 66e9afaa57ed92c3c15b4a5f57c50d21 fobbit-0.56.ebuild 2401
+MD5 409f84b1442cef6bfcba677fae5dd49a fobbit-0.56.ebuild 2498
+MD5 782f0cca159f99a8e7aebcc0561e538c ChangeLog 372
MD5 983c4f24367fac5d8213c436907d699b files/digest-fobbit-0.56 66
diff --git a/media-sound/fobbit/files/digest-fobbit-0.56 b/media-sound/fobbit/files/digest-fobbit-0.56
new file mode 100644
index 000000000000..13802af8b8b5
--- /dev/null
+++ b/media-sound/fobbit/files/digest-fobbit-0.56
@@ -0,0 +1 @@
+MD5 d28ebc75db0364fefc34f5627c84f0b9 fobbit-0.60rc1.tar.gz 126905
diff --git a/media-sound/fobbit/fobbit-0.56.ebuild b/media-sound/fobbit/fobbit-0.56.ebuild
new file mode 100644
index 000000000000..01ab138dc59a
--- /dev/null
+++ b/media-sound/fobbit/fobbit-0.56.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fobbit/fobbit-0.56.ebuild,v 1.1 2003/08/10 04:23:57 jje Exp $
+
+MY_P="${PN}-0.60rc1"
+S="${WORKDIR}/${MY_P}/src"
+DESCRIPTION="Software to use the Creative VoiceBlaster USB VoIP phone device"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+HOMEPAGE="http://www.fobbit.org/ http://www.sourceforge.net/projects/fobbit/"
+
+DEPEND="virtual/glibc"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86"
+
+src_compile() {
+ check_KV
+ einfo "Building vb client"
+ cd ${S}
+ sh TOUNIX
+ make
+ einfo "Building kernel module"
+
+ cd ${S}/linux_drv/
+
+ # the linux driver for kernel series 2.4.20 is different than for
+ # earlier kernels, so we have to detect the kernel version and
+ # manually select the source file.
+
+ # snippet courtesy of media-video/nvidia-kernel
+ # Get the kernel version of sources in /usr/src/linux ...
+ local KV_full="$(awk '/UTS_RELEASE/ { gsub("\"", "", $3); print $3 }' \
+ "${ROOT}/usr/src/linux/include/linux/version.h")"
+ local KV_major="$(echo "${KV_full}" | cut -d. -f1)"
+ local KV_minor="$(echo "${KV_full}" | cut -d. -f2)"
+ local KV_micro="$(echo "${KV_full}" | cut -d. -f3 | sed -e 's:[^0-9].*::')"
+ einfo "Linux kernel ${KV_major}.${KV_minor}.${KV_micro}"
+
+ if [ "${KV_major}" -eq 2 -a "${KV_minor}" -eq 4 ] && \
+ [ "${KV_micro}" -ge 20 ]
+ then
+ einfo "Using 2.4.20 usbvb source file"
+ mv usbvb.c usbvb_old.c
+ mv usbvb-2.4.20.c usbvb.c
+ fi
+
+ make
+}
+
+src_install() {
+ cd ${S}
+ # make the /usr/bin/vb binary
+ newbin vb vb
+ # place the kernel module somewhere nice
+ dodir /lib/modules/${KV}/misc
+ insinto /lib/modules/${KV}/misc
+ doins linux_drv/usbvb.o
+}
+
+pkg_config() {
+ # make devs is a seperate step, because it needn't be repeated for
+ # re-installs, etc..
+ mknod /dev/usb/vbc0 c 180 200
+ mknod /dev/usb/vbc1 c 180 201
+ mknod /dev/usb/vbc2 c 180 202
+ mknod /dev/usb/vbc3 c 180 203
+ mknod /dev/usb/vbv0 c 180 204
+ mknod /dev/usb/vbv1 c 180 205
+ mknod /dev/usb/vbv2 c 180 206
+ mknod /dev/usb/vbv3 c 180 207
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "Execute:"
+ einfo ""
+ einfo " \"ebuild /var/db/pkg/media-sound/${P}/${P}.ebuild config\""
+ einfo ""
+ einfo "to create the USB VB devices in /dev/vbc[0-3] and /dev/vbv[0-3]."
+ einfo ""
+ einfo "To load the usbvb module, you may type \"insmod usbvb\". To have"
+ einfo "the module load automatically at boot time, add the line \"usbvb\""
+ einfo "to /etc/modules.autoload"
+ einfo ""
+}
+