summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-06-20 20:37:18 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-06-20 20:37:18 +0000
commit7f6465890a4c3045ceabd60fe9ef2de26eb583b6 (patch)
treed213043cce336239dc3fc7521a06e26be12e660d /media-sound
parentgnome2 fixes (diff)
downloadgentoo-2-7f6465890a4c3045ceabd60fe9ef2de26eb583b6.tar.gz
gentoo-2-7f6465890a4c3045ceabd60fe9ef2de26eb583b6.tar.bz2
gentoo-2-7f6465890a4c3045ceabd60fe9ef2de26eb583b6.zip
Update to rc2.
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/alsa-driver/ChangeLog9
-rw-r--r--media-sound/alsa-driver/alsa-driver-0.9.0_rc2.ebuild84
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-0.9.0_rc21
-rw-r--r--media-sound/alsa-utils/ChangeLog9
-rw-r--r--media-sound/alsa-utils/alsa-utils-0.9.0_rc2.ebuild33
-rw-r--r--media-sound/alsa-utils/files/digest-alsa-utils-0.9.0_rc21
6 files changed, 135 insertions, 2 deletions
diff --git a/media-sound/alsa-driver/ChangeLog b/media-sound/alsa-driver/ChangeLog
index 15e5f6c79040..6baed810be02 100644
--- a/media-sound/alsa-driver/ChangeLog
+++ b/media-sound/alsa-driver/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/alsa-driver
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.12 2002/06/06 07:54:49 doctomoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.13 2002/06/20 20:36:26 agenkin Exp $
+
+*alsa-driver-0.9.0_rc2 (20 Jun 2002)
+
+ 20 Jun 2002; Arcady Genkin <agenkin@thpoon.com>
+ alsa-driver-0.9.0_rc2.ebuild :
+
+ Quick update to version 0.9.0rc2.
*alsa-driver-0.9.0_rc1 (27 Apr 2002)
diff --git a/media-sound/alsa-driver/alsa-driver-0.9.0_rc2.ebuild b/media-sound/alsa-driver/alsa-driver-0.9.0_rc2.ebuild
new file mode 100644
index 000000000000..26de01e47417
--- /dev/null
+++ b/media-sound/alsa-driver/alsa-driver-0.9.0_rc2.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-0.9.0_rc2.ebuild,v 1.1 2002/06/20 20:36:26 agenkin Exp $
+
+DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
+HOMEPAGE="http://www.alsa-project.org/"
+
+# By default, drivers for all supported cards will be compiled.
+# If you want to only compile for specific card(s), set ALSA_CARDS
+# environment variable accordingly
+[ x${ALSA_CARDS} = x ] && ALSA_CARDS=all
+
+SRC_URI="ftp://ftp.alsa-project.org/pub/driver/${P/_rc/rc}.tar.bz2"
+S=${WORKDIR}/${P/_rc/rc}
+
+# Need the baselayout 1.7.9 or newer for the init script to work correctly.
+DEPEND="sys-devel/autoconf
+ virtual/glibc
+ >=sys-apps/portage-1.9.10
+ >=sys-apps/baselayout-1.7.9"
+RDEPEND="${DEPEND}"
+PROVIDE="virtual/alsa"
+
+src_unpack() {
+ # Some *broken* Gentoo packages install stuff in /etc/rc.d/init.d
+ # instead of /etc/init.d. However, this causes alsa's installer
+ # to do the same foolish thing. This *hack* inibits the problem.
+ # I filed a bug report about this with the ALSA people:
+ # http://sourceforge.net/tracker/?func=detail&aid=551668&group_id=27464&atid=390601
+ unpack ${A}
+ cd ${S}
+ sed -e 's:/etc/rc.d/init.d:/etc/init.d:' < Makefile > Makefile.hacked
+ mv Makefile.hacked Makefile
+ if [ ${ARCH} = "ppc" ]
+ then patch -p1 < ${FILESDIR}/alsa-driver-0.9.0rc1-ppc.patch || die
+ fi
+}
+
+
+src_compile() {
+ # Portage should determine the version of the kernel sources
+ check_KV
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --with-kernel="${ROOT}usr/src/linux" \
+ --with-isapnp=yes \
+ --with-sequencer=yes \
+ --with-oss=yes \
+ --with-cards=${ALSA_CARDS} \
+ || die "./configure failed"
+
+ emake || die "Parallel Make Failed"
+}
+
+
+src_install () {
+ dodir /usr/include/sound
+ dodir /etc/init.d
+ make DESTDIR=${D} install || die
+
+ dodoc CARDS-STATUS COPYING FAQ INSTALL README WARNING TODO doc/*
+
+ insinto /etc/modules.d
+ newins ${FILESDIR}/alsa-modules.conf alsa
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/alsasound
+}
+
+pkg_postinst () {
+ if [ "${ROOT}" = / ]
+ then
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+ fi
+
+ einfo
+ einfo "You might want to edit file /etc/modules.d/alsa according to your"
+ einfo "hardware configuration."
+ einfo
+ einfo "If you are going to be using the 'alsasound' init script, make sure"
+ einfo "that you add it to the 'boot' runlevel (not 'default')."
+ einfo
+}
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-0.9.0_rc2 b/media-sound/alsa-driver/files/digest-alsa-driver-0.9.0_rc2
new file mode 100644
index 000000000000..8b9f0e3579dc
--- /dev/null
+++ b/media-sound/alsa-driver/files/digest-alsa-driver-0.9.0_rc2
@@ -0,0 +1 @@
+MD5 8ef5fd805ecd92a392ae536d7eacfcd2 alsa-driver-0.9.0rc2.tar.bz2 1289274
diff --git a/media-sound/alsa-utils/ChangeLog b/media-sound/alsa-utils/ChangeLog
index a004635f4277..43075adcfc9f 100644
--- a/media-sound/alsa-utils/ChangeLog
+++ b/media-sound/alsa-utils/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/alsa-utils
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.4 2002/04/28 21:03:09 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.5 2002/06/20 20:37:18 agenkin Exp $
+
+*alsa-utils-0.9.0_rc2 (20 Jun 2002)
+
+ 20 Jun 2002; Arcady Genkin <agenkin@thpoon.com>
+ alsa-utils-0.9.0_rc2.ebuild :
+
+ Quick update to version 0.9.0rc2.
*alsa-utils-0.5.10-r8 (28 Apr 2002)
diff --git a/media-sound/alsa-utils/alsa-utils-0.9.0_rc2.ebuild b/media-sound/alsa-utils/alsa-utils-0.9.0_rc2.ebuild
new file mode 100644
index 000000000000..a701756cf3a6
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-0.9.0_rc2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-0.9.0_rc2.ebuild,v 1.1 2002/06/20 20:37:18 agenkin Exp $
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils"
+HOMEPAGE="http://www.alsa-project.org/"
+
+SRC_URI="ftp://ftp.alsa-project.org/pub/utils/${P/_rc/rc}.tar.bz2"
+S=${WORKDIR}/${P/_rc/rc}
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ ~media-libs/alsa-lib-0.9.0_rc2"
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ || die "./configure failed"
+ emake || die "Parallel Make Failed"
+}
+
+src_install() {
+ local ALSA_UTILS_DOCS="COPYING ChangeLog README TODO
+ seq/aconnect/README.aconnect
+ seq/aseqnet/README.aseqnet"
+
+ make DESTDIR=${D} install || die "Installation Failed"
+
+ dodoc ${ALSA_UTILS_DOCS}
+ newdoc alsamixer/README README.alsamixer
+}
diff --git a/media-sound/alsa-utils/files/digest-alsa-utils-0.9.0_rc2 b/media-sound/alsa-utils/files/digest-alsa-utils-0.9.0_rc2
new file mode 100644
index 000000000000..dbaf5ff6a29e
--- /dev/null
+++ b/media-sound/alsa-utils/files/digest-alsa-utils-0.9.0_rc2
@@ -0,0 +1 @@
+MD5 996c230c198fe80c7146155e4b312413 alsa-utils-0.9.0rc2.tar.bz2 86782