summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-08-02 12:46:41 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-08-02 12:46:41 +0000
commit7c5ba5e08170a7ad81aeee9bb9e54e40372bc450 (patch)
tree19f811259afff0989ba301affdbf12985465b798 /media-sound
parentversion bump (diff)
downloadgentoo-2-7c5ba5e08170a7ad81aeee9bb9e54e40372bc450.tar.gz
gentoo-2-7c5ba5e08170a7ad81aeee9bb9e54e40372bc450.tar.bz2
gentoo-2-7c5ba5e08170a7ad81aeee9bb9e54e40372bc450.zip
version bump
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/vmpk/ChangeLog7
-rw-r--r--media-sound/vmpk/vmpk-0.5.0.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/media-sound/vmpk/ChangeLog b/media-sound/vmpk/ChangeLog
index 6fe489167930..b9e27448fe40 100644
--- a/media-sound/vmpk/ChangeLog
+++ b/media-sound/vmpk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/vmpk
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/vmpk/ChangeLog,v 1.13 2012/07/31 16:17:30 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/vmpk/ChangeLog,v 1.14 2012/08/02 12:46:41 aballier Exp $
+
+*vmpk-0.5.0 (02 Aug 2012)
+
+ 02 Aug 2012; Alexis Ballier <aballier@gentoo.org> +vmpk-0.5.0.ebuild:
+ version bump
31 Jul 2012; Michael Palimaka <kensington@gentoo.org> vmpk-0.3.1.ebuild,
vmpk-0.3.2.ebuild, vmpk-0.3.3.ebuild, vmpk-0.4.0.ebuild:
diff --git a/media-sound/vmpk/vmpk-0.5.0.ebuild b/media-sound/vmpk/vmpk-0.5.0.ebuild
new file mode 100644
index 000000000000..e3dd5055a82a
--- /dev/null
+++ b/media-sound/vmpk/vmpk-0.5.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/vmpk/vmpk-0.5.0.ebuild,v 1.1 2012/08/02 12:46:41 aballier Exp $
+
+EAPI=4
+
+inherit cmake-utils eutils
+
+DESCRIPTION="Virtual MIDI Piano Keyboard"
+HOMEPAGE="http://vmpk.sourceforge.net/"
+SRC_URI="mirror://sourceforge/vmpk/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa dbus jack"
+
+RDEPEND=">=x11-libs/qt-core-4.8:4
+ >=x11-libs/qt-gui-4.8:4
+ >=x11-libs/qt-svg-4.8:4
+ alsa? ( media-libs/alsa-lib )
+ dbus? ( >=x11-libs/qt-dbus-4.8:4 )
+ jack? ( media-sound/jack-audio-connection-kit )"
+DEPEND="${RDEPEND}
+ app-text/docbook-xsl-stylesheets
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_configure() {
+ local mycmakeargs=(
+ "$(cmake-utils_use_enable alsa ALSA)"
+ "$(cmake-utils_use_enable dbus DBUS)"
+ "$(cmake-utils_use_enable jack JACK)"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ rm -rf "${D}/usr/share/doc/packages"
+}