summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-01-29 20:19:40 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-01-29 20:19:40 +0000
commit793c548a268a3b505ae2cf8cbd0693447d72c860 (patch)
treea75f4d1884914f39e5b5068a7fec4f257bdb7891 /media-sound
parentAttempt to fix parallel issues once and for all, wrt #296174 c#14 (diff)
downloadgentoo-2-793c548a268a3b505ae2cf8cbd0693447d72c860.tar.gz
gentoo-2-793c548a268a3b505ae2cf8cbd0693447d72c860.tar.bz2
gentoo-2-793c548a268a3b505ae2cf8cbd0693447d72c860.zip
Fix building with x11-libs/libnotify >= 0.7.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/lxmusic/ChangeLog8
-rw-r--r--media-sound/lxmusic/files/lxmusic-0.4.4-libnotify-0.7.patch32
-rw-r--r--media-sound/lxmusic/lxmusic-0.4.4.ebuild13
3 files changed, 47 insertions, 6 deletions
diff --git a/media-sound/lxmusic/ChangeLog b/media-sound/lxmusic/ChangeLog
index 747d48de7801..45b7eefc95a8 100644
--- a/media-sound/lxmusic/ChangeLog
+++ b/media-sound/lxmusic/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/lxmusic
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lxmusic/ChangeLog,v 1.2 2010/08/07 17:30:24 vostorga Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lxmusic/ChangeLog,v 1.3 2011/01/29 20:19:40 ssuominen Exp $
+
+ 29 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> lxmusic-0.4.4.ebuild,
+ +files/lxmusic-0.4.4-libnotify-0.7.patch:
+ Fix building with x11-libs/libnotify >= 0.7.
07 Aug 2010; Víctor Ostorga <vostorga@gentoo.org> lxmusic-0.4.4.ebuild:
Adding x11-libs/libnotify as RDEPEND and fixing typo
diff --git a/media-sound/lxmusic/files/lxmusic-0.4.4-libnotify-0.7.patch b/media-sound/lxmusic/files/lxmusic-0.4.4-libnotify-0.7.patch
new file mode 100644
index 000000000000..62868c909856
--- /dev/null
+++ b/media-sound/lxmusic/files/lxmusic-0.4.4-libnotify-0.7.patch
@@ -0,0 +1,32 @@
+--- src/lxmusic-notify.c
++++ src/lxmusic-notify.c
+@@ -56,12 +56,26 @@
+ g_return_if_fail (message != NULL);
+
+ lxmusic_clear_notify (n);
+-
+- notify = notify_notification_new (summary, message,
+- "lxmusic", NULL);
++#ifdef NOTIFY_CHECK_VERSION
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ notify = notify_notification_new (summary, message, "lxmusic");
++#else
++ notify = notify_notification_new (summary, message, "lxmusic", NULL);
++#endif
++#else
++ notify = notify_notification_new (summary, message, "lxmusic", NULL);
++#endif
+ n->notification = notify;
+
++#ifdef NOTIFY_CHECK_VERSION
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++/* lazy */
++#else
++/* lazy */
++#endif
++#else
+ notify_notification_attach_to_status_icon (notify, n->status_icon);
++#endif
+ notify_notification_set_urgency (notify, NOTIFY_URGENCY_NORMAL);
+ notify_notification_set_timeout (notify, NOTIFY_EXPIRES_DEFAULT);
+
diff --git a/media-sound/lxmusic/lxmusic-0.4.4.ebuild b/media-sound/lxmusic/lxmusic-0.4.4.ebuild
index ac129bab1881..06bf1bd3e509 100644
--- a/media-sound/lxmusic/lxmusic-0.4.4.ebuild
+++ b/media-sound/lxmusic/lxmusic-0.4.4.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lxmusic/lxmusic-0.4.4.ebuild,v 1.2 2010/08/07 17:30:24 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lxmusic/lxmusic-0.4.4.ebuild,v 1.3 2011/01/29 20:19:40 ssuominen Exp $
EAPI=2
+inherit eutils
DESCRIPTION="A simple GUI XMMS2 client with minimal functionality"
HOMEPAGE="http://lxde.sourceforge.net/"
@@ -19,7 +20,11 @@ RDEPEND="x11-libs/gtk+:2
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
+}
+
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS README || die "dodoc failed"
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS README
}