summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2013-04-27 03:56:05 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2013-04-27 03:56:05 +0000
commit77c747661e616568192278199ebcea25d8f095ff (patch)
tree30630f9b1567c7de5dad67bf1ffd5b0600dec407 /media-sound
parentBeta channel bump. (diff)
downloadgentoo-2-77c747661e616568192278199ebcea25d8f095ff.tar.gz
gentoo-2-77c747661e616568192278199ebcea25d8f095ff.tar.bz2
gentoo-2-77c747661e616568192278199ebcea25d8f095ff.zip
Fix compilation with json-c 0.11 (bug #467280).
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 29C3E2EC)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/pulseaudio/ChangeLog8
-rw-r--r--media-sound/pulseaudio/files/pulseaudio-3.0-json-c-fix.patch28
-rw-r--r--media-sound/pulseaudio/pulseaudio-3.0-r1.ebuild236
3 files changed, 271 insertions, 1 deletions
diff --git a/media-sound/pulseaudio/ChangeLog b/media-sound/pulseaudio/ChangeLog
index 4f5d9a9b4489..b04ef5404b71 100644
--- a/media-sound/pulseaudio/ChangeLog
+++ b/media-sound/pulseaudio/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/pulseaudio
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/ChangeLog,v 1.300 2013/04/10 20:43:51 vincent Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/ChangeLog,v 1.301 2013/04/27 03:56:05 ford_prefect Exp $
+
+*pulseaudio-3.0-r1 (27 Apr 2013)
+
+ 27 Apr 2013; Arun Raghavan <ford_prefect@gentoo.org>
+ +pulseaudio-3.0-r1.ebuild, +files/pulseaudio-3.0-json-c-fix.patch:
+ Fix compilation with json-c 0.11 (bug #467280).
10 Apr 2013; Vicente Olivert Riera <vincent@gentoo.org>
pulseaudio-1.1-r1.ebuild, pulseaudio-2.1-r1.ebuild, pulseaudio-3.0.ebuild,
diff --git a/media-sound/pulseaudio/files/pulseaudio-3.0-json-c-fix.patch b/media-sound/pulseaudio/files/pulseaudio-3.0-json-c-fix.patch
new file mode 100644
index 000000000000..e0b027b20df5
--- /dev/null
+++ b/media-sound/pulseaudio/files/pulseaudio-3.0-json-c-fix.patch
@@ -0,0 +1,28 @@
+From 759c0bc6f990240287a14fa6dec029ecea581463 Mon Sep 17 00:00:00 2001
+From: Arun Raghavan <arun.raghavan@collabora.co.uk>
+Date: Sat, 27 Apr 2013 08:57:05 +0530
+Subject: [PATCH] build-sys: json-c changed everything :(
+
+json-c 0.11 ships a pkg-config file with a different name, and changes
+the name of its library as well.
+---
+ configure.ac | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index c8161a4..b1bd21a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -624,7 +624,8 @@ AM_CONDITIONAL([HAVE_TESTS], [test "x$HAVE_LIBCHECK" = x1])
+
+ #### json parsing ####
+
+-PKG_CHECK_MODULES(LIBJSON, [ json >= 0.9 ])
++PKG_CHECK_MODULES(LIBJSON, [ json-c >= 0.11 ], [],
++ [PKG_CHECK_MODULES(LIBJSON, [ json >= 0.9 ])])
+ AC_SUBST(LIBJSON_CFLAGS)
+ AC_SUBST(LIBJSON_LIBS)
+
+--
+1.8.1.2
+
diff --git a/media-sound/pulseaudio/pulseaudio-3.0-r1.ebuild b/media-sound/pulseaudio/pulseaudio-3.0-r1.ebuild
new file mode 100644
index 000000000000..4541c080b04c
--- /dev/null
+++ b/media-sound/pulseaudio/pulseaudio-3.0-r1.ebuild
@@ -0,0 +1,236 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-3.0-r1.ebuild,v 1.1 2013/04/27 03:56:05 ford_prefect Exp $
+
+EAPI="5"
+
+inherit autotools eutils flag-o-matic user versionator toolchain-funcs udev
+
+DESCRIPTION="A networked sound server with an advanced plugin system"
+HOMEPAGE="http://www.pulseaudio.org/"
+
+SRC_URI="http://freedesktop.org/software/pulseaudio/releases/${P}.tar.xz"
+
+# libpulse-simple and libpulse link to libpulse-core; this is daemon's
+# library and can link to gdbm and other GPL-only libraries. In this
+# cases, we have a fully GPL-2 package. Leaving the rest of the
+# GPL-forcing USE flags for those who use them.
+LICENSE="!gdbm? ( LGPL-2.1 ) gdbm? ( GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+alsa +asyncns avahi bluetooth +caps dbus doc equalizer +gdbm +glib gnome
+gtk ipv6 jack libsamplerate lirc neon +orc oss qt4 realtime ssl systemd
+system-wide tcpd test +udev +webrtc-aec +X xen"
+
+RDEPEND=">=media-libs/libsndfile-1.0.20
+ X? (
+ >=x11-libs/libX11-1.4.0
+ >=x11-libs/libxcb-1.6
+ >=x11-libs/xcb-util-0.3.1
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libXtst
+ )
+ caps? ( sys-libs/libcap )
+ libsamplerate? ( >=media-libs/libsamplerate-0.1.1-r1 )
+ alsa? ( >=media-libs/alsa-lib-1.0.19 )
+ glib? ( >=dev-libs/glib-2.4.0 )
+ avahi? ( >=net-dns/avahi-0.6.12[dbus] )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.117 )
+ tcpd? ( sys-apps/tcp-wrappers )
+ lirc? ( app-misc/lirc )
+ dbus? ( >=sys-apps/dbus-1.0.0 )
+ gtk? ( x11-libs/gtk+:2 )
+ gnome? ( >=gnome-base/gconf-2.4.0 )
+ bluetooth? (
+ >=net-wireless/bluez-4.99
+ >=sys-apps/dbus-1.0.0
+ media-libs/sbc
+ )
+ asyncns? ( net-libs/libasyncns )
+ udev? ( >=virtual/udev-143[hwdb] )
+ realtime? ( sys-auth/rtkit )
+ equalizer? ( sci-libs/fftw:3.0 )
+ orc? ( >=dev-lang/orc-0.4.9 )
+ ssl? ( dev-libs/openssl )
+ >=media-libs/speex-1.2_rc1
+ gdbm? ( sys-libs/gdbm )
+ webrtc-aec? ( media-libs/webrtc-audio-processing )
+ xen? ( app-emulation/xen )
+ systemd? ( >=sys-apps/systemd-39 )
+ dev-libs/json-c
+ >=sys-devel/libtool-2.2.4" # it's a valid RDEPEND, libltdl.so is used
+
+DEPEND="${RDEPEND}
+ sys-devel/m4
+ doc? ( app-doc/doxygen )
+ test? ( dev-libs/check )
+ X? (
+ x11-proto/xproto
+ >=x11-libs/libXtst-1.0.99.2
+ )
+ dev-libs/libatomic_ops
+ virtual/pkgconfig
+ system-wide? ( || ( dev-util/unifdef sys-freebsd/freebsd-ubin ) )
+ dev-util/intltool"
+# This is a PDEPEND to avoid a circular dep
+PDEPEND="alsa? ( media-plugins/alsa-plugins[pulseaudio] )"
+
+# alsa-utils dep is for the alsasound init.d script (see bug #155707)
+# bluez dep is for the bluetooth init.d script
+# PyQt4 dep is for the qpaeq script
+RDEPEND="${RDEPEND}
+ equalizer? ( qt4? ( dev-python/PyQt4[dbus] ) )
+ X? ( gnome-extra/gnome-audio )
+ system-wide? (
+ sys-apps/openrc
+ alsa? ( media-sound/alsa-utils )
+ bluetooth? ( >=net-wireless/bluez-4 )
+ )"
+
+# See "*** BLUEZ support not found (requires D-Bus)" in configure.ac
+REQUIRED_USE="bluetooth? ( dbus )"
+
+pkg_setup() {
+ enewgroup audio 18 # Just make sure it exists
+
+ if use system-wide; then
+ enewgroup pulse-access
+ enewgroup pulse
+ enewuser pulse -1 -1 /var/run/pulse pulse,audio
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-json-c-fix.patch"
+ eautoreconf
+}
+
+src_configure() {
+ if use gdbm; then
+ myconf+=" --with-database=gdbm"
+ #elif use tdb; then
+ # myconf+=" --with-database=tdb"
+ else
+ myconf+=" --with-database=simple"
+ fi
+
+ econf \
+ --enable-largefile \
+ $(use_enable glib glib2) \
+ --disable-solaris \
+ $(use_enable asyncns) \
+ $(use_enable oss oss-output) \
+ $(use_enable alsa) \
+ $(use_enable lirc) \
+ $(use_enable neon neon-opt) \
+ $(use_enable tcpd tcpwrap) \
+ $(use_enable jack) \
+ $(use_enable avahi) \
+ $(use_enable dbus) \
+ $(use_enable gnome gconf) \
+ $(use_enable gtk gtk2) \
+ $(use_enable libsamplerate samplerate) \
+ $(use_enable bluetooth bluez) \
+ $(use_enable X x11) \
+ $(use_enable test default-build-tests) \
+ $(use_enable udev) \
+ $(use_enable systemd) \
+ $(use_enable ipv6) \
+ $(use_enable ssl openssl) \
+ $(use_enable webrtc-aec) \
+ $(use_enable xen) \
+ $(use_with caps) \
+ $(use_with equalizer fftw) \
+ --disable-adrian-aec \
+ --disable-esound \
+ --localstatedir="${EPREFIX}"/var \
+ --with-udev-rules-dir="${EPREFIX}/$(udev_get_udevdir)"/rules.d \
+ ${myconf}
+
+ if use doc; then
+ pushd doxygen
+ doxygen doxygen.conf
+ popd
+ fi
+}
+
+src_test() {
+ # We avoid running the toplevel check target because that will run
+ # po/'s tests too, and they are broken. Officially, it should work
+ # with intltool 0.41, but that doesn't look like a stable release.
+ emake -C src check
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+
+ # Drop the script entirely if X is disabled
+ use X || rm "${ED}"/usr/bin/start-pulseaudio-x11
+
+ if use system-wide; then
+ newconfd "${FILESDIR}/pulseaudio.conf.d" pulseaudio
+
+ use_define() {
+ local define=${2:-$(echo $1 | tr '[:lower:]' '[:upper:]')}
+
+ use "$1" && echo "-D$define" || echo "-U$define"
+ }
+
+ unifdef $(use_define avahi) \
+ $(use_define alsa) \
+ $(use_define bluetooth) \
+ $(use_define udev) \
+ "${FILESDIR}/pulseaudio.init.d-5" \
+ > "${T}/pulseaudio"
+
+ doinitd "${T}/pulseaudio"
+ fi
+
+ use avahi && sed -i -e '/module-zeroconf-publish/s:^#::' "${ED}/etc/pulse/default.pa"
+
+ dodoc README todo
+
+ if use doc; then
+ pushd doxygen/html
+ dohtml *
+ popd
+ fi
+
+ # Create the state directory
+ use prefix || diropts -o pulse -g pulse -m0755
+
+ find "${D}" -name '*.la' -delete
+}
+
+pkg_postinst() {
+ if use system-wide; then
+ elog "PulseAudio in Gentoo can use a system-wide pulseaudio daemon."
+ elog "This support is enabled by starting the pulseaudio init.d ."
+ elog "To be able to access that you need to be in the group pulse-access."
+ elog "If you choose to use this feature, please make sure that you"
+ elog "really want to run PulseAudio this way:"
+ elog " http://pulseaudio.org/wiki/WhatIsWrongWithSystemMode"
+ elog "For more information about system-wide support, please refer to:"
+ elog " http://pulseaudio.org/wiki/SystemWideInstance"
+ if use gnome ; then
+ elog
+ elog "By enabling gnome USE flag, you enabled gconf support. Please note"
+ elog "that you might need to remove the gnome USE flag or disable the"
+ elog "gconf module on /etc/pulse/system.pa to be able to use PulseAudio"
+ elog "with a system-wide instance."
+ fi
+ fi
+ if use bluetooth; then
+ elog
+ elog "The Bluetooth proximity module is not enabled in the default"
+ elog "configuration file. If you do enable it, you'll have to have"
+ elog "your Bluetooth controller enabled and inserted at bootup or"
+ elog "PulseAudio will refuse to start."
+ fi
+ if use equalizer && ! use qt4; then
+ elog "You've enabled the 'equalizer' USE-flag but not the 'qt4' USE-flag."
+ elog "This will build the equalizer module, but the 'qpaeq' tool"
+ elog "which is required to set equalizer levels will not work."
+ fi
+}