summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-05-06 19:18:02 +0000
committerSamuli Suominen <drac@gentoo.org>2008-05-06 19:18:02 +0000
commit778aa3d37ae37250e4f8eab011f97074b03e4615 (patch)
treed494ee0b7b82c68a9011bf4ffa856a3ee372d327 /media-sound
parentBump to new upstream stable release 20080504, resolves #220605 (diff)
downloadgentoo-2-778aa3d37ae37250e4f8eab011f97074b03e4615.tar.gz
gentoo-2-778aa3d37ae37250e4f8eab011f97074b03e4615.tar.bz2
gentoo-2-778aa3d37ae37250e4f8eab011f97074b03e4615.zip
Version bump for bug 220429 with GCC 4.3 patch by Peter Alfredsen.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/ecasound/ChangeLog8
-rw-r--r--media-sound/ecasound/ecasound-2.4.6.1.ebuild98
-rw-r--r--media-sound/ecasound/files/ecasound-2.4.6.1-gcc43.patch33
3 files changed, 138 insertions, 1 deletions
diff --git a/media-sound/ecasound/ChangeLog b/media-sound/ecasound/ChangeLog
index 96ef8f421b04..a1593b95fc5a 100644
--- a/media-sound/ecasound/ChangeLog
+++ b/media-sound/ecasound/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/ecasound
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ChangeLog,v 1.43 2008/01/16 18:22:20 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ChangeLog,v 1.44 2008/05/06 19:18:01 drac Exp $
+
+*ecasound-2.4.6.1 (06 May 2008)
+
+ 06 May 2008; Samuli Suominen <drac@gentoo.org>
+ +files/ecasound-2.4.6.1-gcc43.patch, +ecasound-2.4.6.1.ebuild:
+ Version bump for bug 220429 with GCC 4.3 patch by Peter Alfredsen.
16 Jan 2008; Fabian Groffen <grobian@gentoo.org> ecasound-2.4.3.ebuild,
ecasound-2.4.4.ebuild, ecasound-2.4.5.ebuild:
diff --git a/media-sound/ecasound/ecasound-2.4.6.1.ebuild b/media-sound/ecasound/ecasound-2.4.6.1.ebuild
new file mode 100644
index 000000000000..aa5dac494f17
--- /dev/null
+++ b/media-sound/ecasound/ecasound-2.4.6.1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ecasound-2.4.6.1.ebuild,v 1.1 2008/05/06 19:18:01 drac Exp $
+
+inherit eutils multilib python
+
+DESCRIPTION="a package for multitrack audio processing"
+HOMEPAGE="http://ecasound.seul.org/ecasound"
+SRC_URI="http://${PN}.seul.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="alsa arts audiofile debug doc jack libsamplerate mikmod ncurses vorbis oss python ruby sndfile"
+
+DEPEND="python? ( dev-lang/python )
+ jack? ( media-sound/jack-audio-connection-kit )
+ media-libs/ladspa-sdk
+ audiofile? ( media-libs/audiofile )
+ alsa? ( media-libs/alsa-lib )
+ vorbis? ( media-libs/libvorbis )
+ arts? ( kde-base/arts )
+ libsamplerate? ( media-libs/libsamplerate )
+ mikmod? ( media-libs/libmikmod )
+ ruby? ( dev-lang/ruby )
+ python? ( dev-lang/python )
+ ncurses? ( sys-libs/ncurses )
+ sndfile? ( media-libs/libsndfile )
+ sys-libs/readline"
+
+pkg_setup() {
+ if use alsa && ! built_with_use --missing true media-libs/alsa-lib midi; then
+ die "Re-emerge media-libs/alsa-lib with USE midi."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+}
+
+src_compile() {
+ local PYConf
+
+ if use python; then
+ python_version
+ PYConf="--enable-pyecasound=c
+ --with-python-includes=/usr/include/python${PYVER}
+ --with-python-modules=/usr/$(get_libdir)/python${PYVER}"
+ else
+ PYConf="$myconf --disable-pyecasound"
+ fi
+
+ econf $(use_enable alsa) \
+ $(use_enable arts) \
+ $(use_enable audiofile) \
+ $(use_enable debug) \
+ $(use_enable jack) \
+ $(use_enable libsamplerate) \
+ $(use_enable ncurses) \
+ $(use_enable oss) \
+ $(use_enable ruby rubyecasound) \
+ $(use_enable sndfile) \
+ --enable-shared \
+ --with-largefile \
+ --enable-sys-readline \
+ ${PYConf} || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc BUGS NEWS README TODO Documentation/*.txt
+ use doc && dohtml Documentation/*.html
+}
+
+pkg_postinst() {
+ if use python; then
+ ebegin "Byte-compiling ${CATEGORY}/${PF} python modules"
+ python_version
+ local PYMODULE
+ for PYMODULE in ecacontrol.py pyeca.py eci.py; do
+ python_mod_compile "${ROOT}"usr/$(get_libdir)/python${PYVER}/site-packages/${PYMODULE}
+ done
+ eend $?
+ fi
+ if use arts; then
+ ewarn "WARNING: You have requested ecasound ARTS support,"
+ ewarn "this is no longer supported and will go away in"
+ ewarn "future releases."
+ fi
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}
diff --git a/media-sound/ecasound/files/ecasound-2.4.6.1-gcc43.patch b/media-sound/ecasound/files/ecasound-2.4.6.1-gcc43.patch
new file mode 100644
index 000000000000..f912744b9c6a
--- /dev/null
+++ b/media-sound/ecasound/files/ecasound-2.4.6.1-gcc43.patch
@@ -0,0 +1,33 @@
+diff -urNad ecasound~/ecatools/ecasignalview.cpp ecasound/ecatools/ecasignalview.cpp
+--- ecasound~/ecatools/ecasignalview.cpp 2007-08-20 22:03:30.000000000 +0900
++++ ecasound/ecatools/ecasignalview.cpp 2007-12-13 23:26:40.905257369 +0900
+@@ -31,6 +31,7 @@
+ #include <cassert>
+ #include <cmath>
+ #include <cstdio>
++#include <cstring>
+
+ #include <signal.h>
+ #include <unistd.h>
+diff -urNad ecasound~/kvutils/kvu_procedure_timer.cpp ecasound/kvutils/kvu_procedure_timer.cpp
+--- ecasound~/kvutils/kvu_procedure_timer.cpp 2007-08-20 22:03:30.000000000 +0900
++++ ecasound/kvutils/kvu_procedure_timer.cpp 2007-12-13 23:26:40.905257369 +0900
+@@ -19,6 +19,7 @@
+ // ------------------------------------------------------------------------
+
+ #include <cmath>
++#include <cstring>
+ #include <math.h> /* floor() */
+ #include "kvu_numtostr.h"
+ #include "kvu_procedure_timer.h"
+diff -urNad ecasound~/libecasound/plugins/audioio_jack_manager.cpp ecasound/libecasound/plugins/audioio_jack_manager.cpp
+--- ecasound~/libecasound/plugins/audioio_jack_manager.cpp 2007-08-20 22:03:30.000000000 +0900
++++ ecasound/libecasound/plugins/audioio_jack_manager.cpp 2007-12-13 23:26:40.906256145 +0900
+@@ -31,6 +31,7 @@
+ #include <iostream>
+ #include <string>
+
++#include <cstring>
+ #include <sys/time.h> /* gettimeofday() */
+ #include <errno.h> /* ETIMEDOUT */
+ #include <jack/jack.h>