summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2012-07-23 11:26:07 +0000
committerChristoph Mende <angelos@gentoo.org>2012-07-23 11:26:07 +0000
commit6a758f366326b0c3155b505f67ae435053c3f65b (patch)
tree095824047c275c604a14cdebd6a5db041e7aebd4 /media-sound
parentBump to latest release and use upstream versioning. (diff)
downloadgentoo-2-6a758f366326b0c3155b505f67ae435053c3f65b.tar.gz
gentoo-2-6a758f366326b0c3155b505f67ae435053c3f65b.tar.bz2
gentoo-2-6a758f366326b0c3155b505f67ae435053c3f65b.zip
Backport upstream patch to fix noise when using software mixer (bug #424043)
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/mpd/ChangeLog8
-rw-r--r--media-sound/mpd/files/mpd-0.17-noise.patch42
-rw-r--r--media-sound/mpd/mpd-0.17-r1.ebuild189
3 files changed, 238 insertions, 1 deletions
diff --git a/media-sound/mpd/ChangeLog b/media-sound/mpd/ChangeLog
index 9cee42c9fba0..05edec688fce 100644
--- a/media-sound/mpd/ChangeLog
+++ b/media-sound/mpd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/mpd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/ChangeLog,v 1.291 2012/07/19 18:17:54 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/ChangeLog,v 1.292 2012/07/23 11:26:07 angelos Exp $
+
+*mpd-0.17-r1 (23 Jul 2012)
+
+ 23 Jul 2012; Christoph Mende <angelos@gentoo.org> +files/mpd-0.17-noise.patch,
+ +mpd-0.17-r1.ebuild:
+ Backport upstream patch to fix noise when using software mixer (bug #424043)
19 Jul 2012; Markos Chandras <hwoarang@gentoo.org> mpd-0.16.8.ebuild:
Stable on amd64 wrt bug #426834
diff --git a/media-sound/mpd/files/mpd-0.17-noise.patch b/media-sound/mpd/files/mpd-0.17-noise.patch
new file mode 100644
index 000000000000..ee19109d85de
--- /dev/null
+++ b/media-sound/mpd/files/mpd-0.17-noise.patch
@@ -0,0 +1,42 @@
+From dbee2f199640ec296b049801fe79e35c4b3424f6 Mon Sep 17 00:00:00 2001
+From: Max Kellermann <max@duempel.org>
+Date: Mon, 09 Jul 2012 23:14:43 +0000
+Subject: output_init: put the "convert" filter at the end of the list
+
+No, really! This fixes a regression of commit 74617389, which
+changed the order of filter plugins.
+---
+diff --git a/src/output_init.c b/src/output_init.c
+index d2c86bf..c3b808e 100644
+--- a/src/output_init.c
++++ b/src/output_init.c
+@@ -213,13 +213,6 @@ ao_base_init(struct audio_output *ao,
+ ao->replay_gain_filter = NULL;
+ ao->other_replay_gain_filter = NULL;
+
+- /* the "convert" filter must be the last one in the chain */
+-
+- ao->convert_filter = filter_new(&convert_filter_plugin, NULL, NULL);
+- assert(ao->convert_filter != NULL);
+-
+- filter_chain_append(ao->filter, ao->convert_filter);
+-
+ /* done */
+
+ return true;
+@@ -280,6 +273,13 @@ audio_output_setup(struct audio_output *ao, const struct config_param *param,
+ return false;
+ }
+
++ /* the "convert" filter must be the last one in the chain */
++
++ ao->convert_filter = filter_new(&convert_filter_plugin, NULL, NULL);
++ assert(ao->convert_filter != NULL);
++
++ filter_chain_append(ao->filter, ao->convert_filter);
++
+ return true;
+ }
+
+--
+cgit v0.9.0.3-66-g3205
diff --git a/media-sound/mpd/mpd-0.17-r1.ebuild b/media-sound/mpd/mpd-0.17-r1.ebuild
new file mode 100644
index 000000000000..89e4d33255d3
--- /dev/null
+++ b/media-sound/mpd/mpd-0.17-r1.ebuild
@@ -0,0 +1,189 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/mpd-0.17-r1.ebuild,v 1.1 2012/07/23 11:26:07 angelos Exp $
+
+EAPI=4
+inherit eutils flag-o-matic linux-info multilib systemd user
+
+DESCRIPTION="The Music Player Daemon (mpd)"
+HOMEPAGE="http://www.musicpd.org"
+SRC_URI="mirror://sourceforge/musicpd/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sh ~x86 ~x86-fbsd ~x64-macos"
+IUSE="aac +alsa ao audiofile bzip2 cdio +curl debug +fifo +ffmpeg flac
+fluidsynth +id3tag inotify ipv6 jack lame lastfmradio mms libsamplerate +mad
+mikmod modplug mpg123 musepack +network ogg openal oss pipe pulseaudio recorder
+sid sndfile soundcloud soup sqlite systemd tcpd twolame unicode vorbis wavpack
+wildmidi zeroconf zip"
+
+OUTPUT_PLUGINS="alsa ao fifo jack network openal oss pipe pulseaudio recorder"
+INPUT_PLUGINS="aac audiofile ffmpeg flac fluidsynth mad mikmod modplug mpg123
+ musepack ogg flac sid vorbis wavpack wildmidi"
+ENCODER_PLUGINS="audiofile flac lame twolame vorbis"
+
+REQUIRED_USE="|| ( ${OUTPUT_PLUGINS} )
+ || ( ${INPUT_PLUGINS} )
+ network? ( || ( ${ENCODER_PLUGINS} ) )
+ recorder? ( || ( ${ENCODER_PLUGINS} ) )
+ lastfmradio? ( curl )"
+
+RDEPEND="!<sys-cluster/mpich2-1.4_rc2
+ dev-libs/glib:2
+ aac? ( media-libs/faad2 )
+ alsa? ( media-sound/alsa-utils
+ media-libs/alsa-lib )
+ ao? ( media-libs/libao[alsa?,pulseaudio?] )
+ audiofile? ( media-libs/audiofile )
+ bzip2? ( app-arch/bzip2 )
+ cdio? ( dev-libs/libcdio[-minimal] )
+ curl? ( net-misc/curl )
+ ffmpeg? ( virtual/ffmpeg )
+ flac? ( media-libs/flac[ogg?] )
+ fluidsynth? ( media-sound/fluidsynth )
+ id3tag? ( media-libs/libid3tag )
+ jack? ( media-sound/jack-audio-connection-kit )
+ lame? ( network? ( media-sound/lame ) )
+ libsamplerate? ( media-libs/libsamplerate )
+ mad? ( media-libs/libmad )
+ mikmod? ( media-libs/libmikmod:0 )
+ mms? ( media-libs/libmms )
+ modplug? ( media-libs/libmodplug )
+ mpg123? ( >=media-sound/mpg123-1.12.2 )
+ musepack? ( media-sound/musepack-tools )
+ network? ( >=media-libs/libshout-2
+ !lame? ( !vorbis? ( media-libs/libvorbis ) ) )
+ ogg? ( media-libs/libogg )
+ openal? ( media-libs/openal )
+ pulseaudio? ( media-sound/pulseaudio )
+ sid? ( media-libs/libsidplay:2 )
+ sndfile? ( media-libs/libsndfile )
+ soundcloud? ( >=dev-libs/yajl-2 )
+ soup? ( net-libs/libsoup:2.4 )
+ sqlite? ( dev-db/sqlite:3 )
+ systemd? ( sys-apps/systemd )
+ tcpd? ( sys-apps/tcp-wrappers )
+ twolame? ( media-sound/twolame )
+ vorbis? ( media-libs/libvorbis )
+ wavpack? ( media-sound/wavpack )
+ wildmidi? ( media-sound/wildmidi )
+ zeroconf? ( net-dns/avahi[dbus] )
+ zip? ( dev-libs/zziplib )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ use network || ewarn "Icecast and Shoutcast streaming needs networking."
+ use fluidsynth && ewarn "Using fluidsynth is discouraged by upstream."
+
+ enewuser mpd "" "" "/var/lib/mpd" audio
+
+ if use inotify; then
+ CONFIG_CHECK="~INOTIFY_USER"
+ ERROR_INOTIFY_USER="${P} requires inotify in-kernel support."
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ cp -f doc/mpdconf.example doc/mpdconf.dist || die "cp failed"
+ epatch "${FILESDIR}"/${PN}-0.16.conf.patch \
+ "${FILESDIR}"/${P}-noise.patch
+}
+
+src_configure() {
+ local mpdconf="--disable-despotify --disable-documentation --disable-ffado
+ --disable-gme --disable-mvp --disable-roar --enable-largefile
+ --enable-tcp --enable-un --docdir=${EPREFIX}/usr/share/doc/${PF}"
+
+ if use network; then
+ mpdconf+=" --enable-shout $(use_enable vorbis vorbis-encoder)
+ --enable-httpd-output $(use_enable lame lame-encoder)
+ $(use_enable twolame twolame-encoder)
+ $(use_enable audiofile wave-encoder)"
+ else
+ mpdconf+=" --disable-shout --disable-vorbis-encoder
+ --disable-httpd-output --disable-lame-encoder
+ --disable-twolame-encoder --disable-wave-encoder"
+ fi
+
+ append-lfs-flags
+ append-ldflags "-L/usr/$(get_libdir)/sidplay/builders"
+
+ econf \
+ $(use_enable aac) \
+ $(use_enable alsa) \
+ $(use_enable ao) \
+ $(use_enable audiofile) \
+ $(use_enable bzip2) \
+ $(use_enable cdio cdio-paranoia) \
+ $(use_enable cdio iso9660) \
+ $(use_enable curl) \
+ $(use_enable debug) \
+ $(use_enable ffmpeg) \
+ $(use_enable fifo) \
+ $(use_enable flac) \
+ $(use_enable fluidsynth) \
+ $(use_enable id3tag id3) \
+ $(use_enable inotify) \
+ $(use_enable ipv6) \
+ $(use_enable jack) \
+ $(use_enable lastfmradio lastfm) \
+ $(use_enable libsamplerate lsr) \
+ $(use_enable mad) \
+ $(use_enable mikmod) \
+ $(use_enable mms) \
+ $(use_enable modplug) \
+ $(use_enable mpg123) \
+ $(use_enable musepack mpc) \
+ $(use_enable openal) \
+ $(use_enable oss) \
+ $(use_enable pipe pipe-output) \
+ $(use_enable pulseaudio pulse) \
+ $(use_enable recorder recorder-output) \
+ $(use_enable sid sidplay) \
+ $(use_enable sndfile sndfile) \
+ $(use_enable soundcloud) \
+ $(use_enable soup) \
+ $(use_enable sqlite) \
+ $(use_enable systemd systemd-daemon) \
+ $(use_enable tcpd libwrap) \
+ $(use_enable vorbis) \
+ $(use_enable wavpack) \
+ $(use_enable wildmidi) \
+ $(use_enable zip zzip) \
+ $(use_with zeroconf zeroconf avahi) \
+ "$(systemd_with_unitdir)" \
+ ${mpdconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ insinto /etc
+ newins doc/mpdconf.dist mpd.conf
+
+ newinitd "${FILESDIR}"/mpd.init mpd
+
+ if use unicode; then
+ sed -i -e 's:^#filesystem_charset.*$:filesystem_charset "UTF-8":' \
+ "${ED}"/etc/mpd.conf || die "sed failed"
+ fi
+
+ use prefix || diropts -m0755 -o mpd -g audio
+ dodir /var/lib/mpd
+ keepdir /var/lib/mpd
+ dodir /var/lib/mpd/music
+ keepdir /var/lib/mpd/music
+ dodir /var/lib/mpd/playlists
+ keepdir /var/lib/mpd/playlists
+}
+
+pkg_postinst() {
+ elog "If you will be starting mpd via /etc/init.d/mpd, please make"
+ elog "sure that MPD's pid_file is unset."
+
+ # also change the homedir if the user has existed before
+ usermod -d "/var/lib/mpd" mpd
+}