summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-04-14 19:59:01 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-04-14 19:59:01 +0000
commit605f6941714cad266d84db5aae5cad0c016cbc99 (patch)
tree4158f596bbd8f5b7ee45059df695e26847e98e2e /media-sound
parentAdd USE_RUBY (diff)
downloadgentoo-2-605f6941714cad266d84db5aae5cad0c016cbc99.tar.gz
gentoo-2-605f6941714cad266d84db5aae5cad0c016cbc99.tar.bz2
gentoo-2-605f6941714cad266d84db5aae5cad0c016cbc99.zip
version bump
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/fluidsynth/ChangeLog10
-rw-r--r--media-sound/fluidsynth/files/fluidsynth-1.0.9-pkg.patch12
-rw-r--r--media-sound/fluidsynth/fluidsynth-1.0.9.ebuild72
3 files changed, 92 insertions, 2 deletions
diff --git a/media-sound/fluidsynth/ChangeLog b/media-sound/fluidsynth/ChangeLog
index 5bf2b217fa79..6c1e3765bff6 100644
--- a/media-sound/fluidsynth/ChangeLog
+++ b/media-sound/fluidsynth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/fluidsynth
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/ChangeLog,v 1.45 2008/11/09 14:50:09 klausman Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/ChangeLog,v 1.46 2009/04/14 19:59:01 aballier Exp $
+
+*fluidsynth-1.0.9 (14 Apr 2009)
+
+ 14 Apr 2009; Alexis Ballier <aballier@gentoo.org>
+ +files/fluidsynth-1.0.9-pkg.patch, +fluidsynth-1.0.9.ebuild:
+ version bump
09 Nov 2008; Tobias Klausmann <klausman@gentoo.org>
fluidsynth-1.0.8-r1.ebuild:
diff --git a/media-sound/fluidsynth/files/fluidsynth-1.0.9-pkg.patch b/media-sound/fluidsynth/files/fluidsynth-1.0.9-pkg.patch
new file mode 100644
index 000000000000..b937d334574f
--- /dev/null
+++ b/media-sound/fluidsynth/files/fluidsynth-1.0.9-pkg.patch
@@ -0,0 +1,12 @@
+Index: fluidsynth-1.0.9/configure.ac
+===================================================================
+--- fluidsynth-1.0.9.orig/configure.ac
++++ fluidsynth-1.0.9/configure.ac
+@@ -150,6 +150,7 @@ dnl
+ dnl Check support for all the drivers
+ dnl
+
++PKG_PROG_PKG_CONFIG
+
+ dnl - Sound file support check
+ dnl AUFILE_SUPPORT=0
diff --git a/media-sound/fluidsynth/fluidsynth-1.0.9.ebuild b/media-sound/fluidsynth/fluidsynth-1.0.9.ebuild
new file mode 100644
index 000000000000..df715e5f4445
--- /dev/null
+++ b/media-sound/fluidsynth/fluidsynth-1.0.9.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/fluidsynth-1.0.9.ebuild,v 1.1 2009/04/14 19:59:01 aballier Exp $
+
+EAPI=2
+
+inherit flag-o-matic eutils libtool autotools
+
+IUSE="alsa debug jack ladspa lash oss portaudio pulseaudio readline"
+
+DESCRIPTION="Fluidsynth is a software real-time synthesizer based on the Soundfont 2 specifications."
+HOMEPAGE="http://www.fluidsynth.org/"
+SRC_URI="http://savannah.nongnu.org/download/fluid/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+DEPEND="jack? ( media-sound/jack-audio-connection-kit )
+ ladspa? ( >=media-libs/ladspa-sdk-1.12
+ >=media-libs/ladspa-cmt-1.15 )
+ alsa? ( media-libs/alsa-lib[midi]
+ lash? ( >=media-sound/lash-0.5 ) )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.8 )
+ portaudio? ( >=media-libs/portaudio-19_pre )
+ readline? ( sys-libs/readline )"
+
+S="${WORKDIR}/${P/7a/7}"
+
+# Alsa is required for lash support in this package.
+pkg_setup() {
+ if use lash && ! use alsa; then
+ ewarn "ALSA support is required for lash support to be enabled."
+ ewarn "Continuing with lash support disabled."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-pkg.patch"
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ if use alsa; then
+ myconf="${myconf} $(use_enable lash)"
+ else
+ myconf="--disable-lash"
+ fi
+
+ elibtoolize
+ # ladcca support is deprecated in place of lash
+ econf \
+ --disable-ladcca \
+ --disable-dependency-tracking \
+ $(use_enable ladspa) \
+ $(use_enable jack jack-support) \
+ $(use_enable oss oss-support) \
+ $(use_enable alsa alsa-support) \
+ $(use_enable pulseaudio pulse-support) \
+ $(use_enable portaudio portaudio-support) \
+ $(use_enable lash) \
+ $(use_enable debug) \
+ $(use_with readline) \
+ ${myconf} || die "./configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS NEWS README THANKS TODO
+}