summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2013-02-15 08:51:56 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2013-02-15 08:51:56 +0000
commit49743ef4bffbaae6e8a82e19102ee612b8c0048f (patch)
tree407c3190172ee153d50d911e5d9d0314b9284fd3 /media-sound
parentVersion bump. (diff)
downloadgentoo-2-49743ef4bffbaae6e8a82e19102ee612b8c0048f.tar.gz
gentoo-2-49743ef4bffbaae6e8a82e19102ee612b8c0048f.tar.bz2
gentoo-2-49743ef4bffbaae6e8a82e19102ee612b8c0048f.zip
Add USE=qt to pull in qt deps for equalizer
(Portage version: 2.2.0_alpha162/cvs/Linux x86_64, signed Manifest commit with key 560FDD64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/pulseaudio/ChangeLog6
-rw-r--r--media-sound/pulseaudio/metadata.xml3
-rw-r--r--media-sound/pulseaudio/pulseaudio-3.0.ebuild22
-rw-r--r--media-sound/pulseaudio/pulseaudio-9999.ebuild22
4 files changed, 36 insertions, 17 deletions
diff --git a/media-sound/pulseaudio/ChangeLog b/media-sound/pulseaudio/ChangeLog
index b197b7d580f0..66c0f07213ce 100644
--- a/media-sound/pulseaudio/ChangeLog
+++ b/media-sound/pulseaudio/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/pulseaudio
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/ChangeLog,v 1.296 2013/01/01 18:46:40 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/ChangeLog,v 1.297 2013/02/15 08:51:56 nirbheek Exp $
+
+ 15 Feb 2013; Nirbheek Chauhan <nirbheek@gentoo.org> metadata.xml,
+ pulseaudio-3.0.ebuild, pulseaudio-9999.ebuild:
+ Add USE=qt to pull in qt deps for equalizer
01 Jan 2013; Raúl Porcel <armin76@gentoo.org> pulseaudio-2.1-r1.ebuild:
sh stable wrt #435074
diff --git a/media-sound/pulseaudio/metadata.xml b/media-sound/pulseaudio/metadata.xml
index af8e8805f59e..748e8cf3e94d 100644
--- a/media-sound/pulseaudio/metadata.xml
+++ b/media-sound/pulseaudio/metadata.xml
@@ -41,6 +41,9 @@
Makes PulseAudio use RealtimeKit (<pkg>sys-auth/rtkit</pkg>) to get
real-time priority while running.
</flag>
+ <flag name="qt">
+ Pull in deps for the equalizer GUI qpaeq (requires <pkg>dev-python/PyQt4</pkg>).
+ </flag>
<flag name="equalizer">
Enable the equalizer module (requires <pkg>sci-libs/fftw</pkg>).
</flag>
diff --git a/media-sound/pulseaudio/pulseaudio-3.0.ebuild b/media-sound/pulseaudio/pulseaudio-3.0.ebuild
index 5259c6d06da5..9df96e955049 100644
--- a/media-sound/pulseaudio/pulseaudio-3.0.ebuild
+++ b/media-sound/pulseaudio/pulseaudio-3.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-3.0.ebuild,v 1.2 2012/12/21 16:55:32 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-3.0.ebuild,v 1.3 2013/02/15 08:51:56 nirbheek Exp $
-EAPI=4
+EAPI="4"
inherit eutils flag-o-matic user versionator toolchain-funcs udev
@@ -18,7 +18,9 @@ SRC_URI="http://freedesktop.org/software/pulseaudio/releases/${P}.tar.xz"
LICENSE="!gdbm? ( LGPL-2.1 ) gdbm? ( GPL-2 )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="+alsa avahi +caps equalizer jack lirc neon oss tcpd +X dbus libsamplerate gnome bluetooth +asyncns +glib gtk test doc +udev ipv6 system-wide realtime +orc ssl +gdbm +webrtc-aec xen systemd"
+IUSE="+alsa +asyncns avahi bluetooth +caps dbus doc equalizer +gdbm +glib gnome
+gtk ipv6 jack libsamplerate lirc neon +orc oss qt realtime ssl systemd
+system-wide tcpd test +udev +webrtc-aec +X xen"
RDEPEND=">=media-libs/libsndfile-1.0.20
X? (
@@ -48,10 +50,7 @@ RDEPEND=">=media-libs/libsndfile-1.0.20
asyncns? ( net-libs/libasyncns )
udev? ( >=virtual/udev-143[hwdb] )
realtime? ( sys-auth/rtkit )
- equalizer? (
- sci-libs/fftw:3.0
- dev-python/PyQt4[dbus]
- )
+ equalizer? ( sci-libs/fftw:3.0 )
orc? ( >=dev-lang/orc-0.4.9 )
ssl? ( dev-libs/openssl )
>=media-libs/speex-1.2_rc1
@@ -79,7 +78,9 @@ PDEPEND="alsa? ( media-plugins/alsa-plugins[pulseaudio] )"
# alsa-utils dep is for the alsasound init.d script (see bug #155707)
# bluez dep is for the bluetooth init.d script
+# PyQt4 dep is for the qpaeq script
RDEPEND="${RDEPEND}
+ equalizer? ( qt? ( dev-python/PyQt4[dbus] ) )
X? ( gnome-extra/gnome-audio )
system-wide? (
sys-apps/openrc
@@ -222,4 +223,9 @@ pkg_postinst() {
elog "your Bluetooth controller enabled and inserted at bootup or"
elog "PulseAudio will refuse to start."
fi
+ if use equalizer && ! use qt; then
+ elog "You've enabled the 'equalizer' USE-flag but not the 'qt' USE-flag."
+ elog "This will build the equalizer module, but the 'qpaeq' tool"
+ elog "which is required to set equalizer levels will not work."
+ fi
}
diff --git a/media-sound/pulseaudio/pulseaudio-9999.ebuild b/media-sound/pulseaudio/pulseaudio-9999.ebuild
index 2c3e18097b23..8db05fffb67a 100644
--- a/media-sound/pulseaudio/pulseaudio-9999.ebuild
+++ b/media-sound/pulseaudio/pulseaudio-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-9999.ebuild,v 1.32 2012/12/26 02:44:01 ford_prefect Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-9999.ebuild,v 1.33 2013/02/15 08:51:56 nirbheek Exp $
-EAPI=4
+EAPI="4"
inherit autotools eutils flag-o-matic user versionator git-2 udev
@@ -18,7 +18,9 @@ EGIT_REPO_URI="git://anongit.freedesktop.org/pulseaudio/pulseaudio.git"
LICENSE="!gdbm? ( LGPL-2.1 ) gdbm? ( GPL-2 )"
SLOT="0"
KEYWORDS=""
-IUSE="+alsa avahi +caps equalizer jack lirc oss tcpd +X dbus libsamplerate gnome bluetooth +asyncns +glib gtk test doc +udev ipv6 system-wide realtime +orc ssl +gdbm +webrtc-aec xen systemd"
+IUSE="+alsa +asyncns avahi bluetooth +caps dbus doc equalizer +gdbm +glib gnome
+gtk ipv6 jack libsamplerate lirc neon +orc oss qt realtime ssl systemd
+system-wide tcpd test +udev +webrtc-aec +X xen"
RDEPEND=">=media-libs/libsndfile-1.0.20
X? (
@@ -48,10 +50,7 @@ RDEPEND=">=media-libs/libsndfile-1.0.20
asyncns? ( net-libs/libasyncns )
udev? ( >=virtual/udev-143[hwdb] )
realtime? ( sys-auth/rtkit )
- equalizer? (
- sci-libs/fftw:3.0
- dev-python/PyQt4[dbus]
- )
+ equalizer? ( sci-libs/fftw:3.0 )
orc? ( >=dev-lang/orc-0.4.9 )
ssl? ( dev-libs/openssl )
>=media-libs/speex-1.2_rc1
@@ -79,7 +78,9 @@ PDEPEND="alsa? ( media-plugins/alsa-plugins[pulseaudio] )"
# alsa-utils dep is for the alsasound init.d script (see bug #155707)
# bluez dep is for the bluetooth init.d script
+# PyQt4 dep is for the qpaeq script
RDEPEND="${RDEPEND}
+ equalizer? ( qt? ( dev-python/PyQt4[dbus] ) )
X? ( gnome-extra/gnome-audio )
system-wide? (
sys-apps/openrc
@@ -224,4 +225,9 @@ pkg_postinst() {
elog "your Bluetooth controller enabled and inserted at bootup or"
elog "PulseAudio will refuse to start."
fi
+ if use equalizer && ! use qt; then
+ elog "You've enabled the 'equalizer' USE-flag but not the 'qt' USE-flag."
+ elog "This will build the equalizer module, but the 'qpaeq' tool"
+ elog "which is required to set equalizer levels will not work."
+ fi
}