summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2012-04-13 16:46:55 +0000
committerThomas Kahle <tomka@gentoo.org>2012-04-13 16:46:55 +0000
commit48420e220eca7de02afa867d3b94657cb5345b30 (patch)
treeb5d998f780cdd4951e0a7c386e8685447e8f9a51 /media-sound
parentfix ebuild to be RDEPEND, not DEPEND on perl and Config-Simple (diff)
downloadgentoo-2-48420e220eca7de02afa867d3b94657cb5345b30.tar.gz
gentoo-2-48420e220eca7de02afa867d3b94657cb5345b30.tar.bz2
gentoo-2-48420e220eca7de02afa867d3b94657cb5345b30.zip
bump to 1.3.1
(Portage version: 2.1.10.56/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/gmtp/ChangeLog10
-rw-r--r--media-sound/gmtp/files/gmtp-1.3.1-makefile-gentoo.patch70
-rw-r--r--media-sound/gmtp/gmtp-1.3.1.ebuild46
3 files changed, 124 insertions, 2 deletions
diff --git a/media-sound/gmtp/ChangeLog b/media-sound/gmtp/ChangeLog
index c4aef1a33fa3..6ec9d2469b00 100644
--- a/media-sound/gmtp/ChangeLog
+++ b/media-sound/gmtp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/gmtp
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gmtp/ChangeLog,v 1.5 2011/12/24 10:32:11 tomka Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gmtp/ChangeLog,v 1.6 2012/04/13 16:46:55 tomka Exp $
+
+*gmtp-1.3.1 (13 Apr 2012)
+
+ 13 Apr 2012; Thomas Kahle <tomka@gentoo.org>
+ +files/gmtp-1.3.1-makefile-gentoo.patch, +gmtp-1.3.1.ebuild:
+ bump to 1.3.1
*gmtp-1.3.0 (24 Dec 2011)
diff --git a/media-sound/gmtp/files/gmtp-1.3.1-makefile-gentoo.patch b/media-sound/gmtp/files/gmtp-1.3.1-makefile-gentoo.patch
new file mode 100644
index 000000000000..00f1e90d17ca
--- /dev/null
+++ b/media-sound/gmtp/files/gmtp-1.3.1-makefile-gentoo.patch
@@ -0,0 +1,70 @@
+diff -U 3 -dHrN gMTP/Makefile gMTP.new/Makefile
+--- gMTP/Makefile 2011-12-15 05:57:19.000000000 +0100
++++ gMTP.new/Makefile 2011-12-24 11:16:52.211115913 +0100
+@@ -1,7 +1,7 @@
+ # gMTP Sync tool
+
+ PKG_NAME = gmtp
+-PREFIX ?= /usr/local
++PREFIX ?= /usr
+ VER = 1.3.1
+ # Note: If you update above, please update the config.h and pkginfo file as well.
+
+@@ -36,7 +36,7 @@
+ GCONFTOOL = gconftool-2
+ TAR = tar
+
+-CFLAGS += -c -g #-O
++CFLAGS += -c
+ LDFLAGS +=
+ LIBS +=
+
+@@ -123,7 +123,7 @@
+ $(INSTALL) -d $(DESTDIR)$(PREFIX)/share/applications
+ $(INSTALL) -d $(DESTDIR)$(PREFIX)/share/pixmaps
+ $(INSTALL) -d $(DESTDIR)$(PREFIX)/share/gconf
+- $(INSTALL) -d $(DESTDIR)$(PREFIX)/share/gconf/schemas
++ $(INSTALL) -d $(DESTDIR)/etc/gconf/schemas
+ $(INSTALL) -d $(DESTDIR)$(PREFIX)/share/locale
+ $(INSTALL) -d $(DESTDIR)$(PREFIX)/share/locale/es
+ $(INSTALL) -d $(DESTDIR)$(PREFIX)/share/locale/it
+@@ -151,17 +151,17 @@
+ $(INSTALL) -m 644 images/view-refresh.png $(DESTDIR)$(PREFIX)/share/$(PKG_NAME)
+ $(INSTALL) -m 644 misc/gMTP.desktop $(DESTDIR)$(PREFIX)/share/applications
+ $(INSTALL) -m 644 images/icon.png $(DESTDIR)$(PREFIX)/share/pixmaps
+- $(INSTALL) -m 644 misc/gMTP.schemas $(DESTDIR)$(PREFIX)/share/gconf/schemas
++ $(INSTALL) -m 644 misc/gMTP.schemas $(DESTDIR)/etc/gconf/schemas
+ mv $(DESTDIR)$(PREFIX)/share/pixmaps/icon.png $(DESTDIR)$(PREFIX)/share/pixmaps/gMTPicon.png
+ cp po/es.mo $(DESTDIR)$(PREFIX)/share/locale/es/LC_MESSAGES/gmtp.mo
+ cp po/fr.mo $(DESTDIR)$(PREFIX)/share/locale/fr/LC_MESSAGES/gmtp.mo
+ cp po/it.mo $(DESTDIR)$(PREFIX)/share/locale/it/LC_MESSAGES/gmtp.mo
+ cp po/da.mo $(DESTDIR)$(PREFIX)/share/locale/da/LC_MESSAGES/gmtp.mo
+ cp po/de.mo $(DESTDIR)$(PREFIX)/share/locale/de/LC_MESSAGES/gmtp.mo
+- mv $(DESTDIR)$(PREFIX)/share/gconf/schemas/gMTP.schemas $(DESTDIR)$(PREFIX)/share/gconf/schemas/gmtp.schemas
++ mv $(DESTDIR)/etc/gconf/schemas/gMTP.schemas $(DESTDIR)/etc/gconf/schemas/gmtp.schemas
+
+ register-gconf-schemas: install
+- GCONF_CONFIG_SOURCE=`$(GCONFTOOL) --get-default-source` $(GCONFTOOL) --makefile-install-rule $(DESTDIR)$(PREFIX)/share/gconf/schemas/gmtp.schemas
++ GCONF_CONFIG_SOURCE=`$(GCONFTOOL) --get-default-source` $(GCONFTOOL) --makefile-install-rule $(DESTDIR)/etc/gconf/schemas/gmtp.schemas
+
+ install-gtk3: gmtp $(catalogues)
+ $(INSTALL) -d $(DESTDIR)$(PREFIX)
+@@ -223,7 +223,7 @@
+ rm -f $(DESTDIR)$(PREFIX)/share/$(PKG_NAME)/*
+ rm -f $(DESTDIR)$(PREFIX)/share/applications/gMTP.desktop
+ rm -f $(DESTDIR)$(PREFIX)/share/pixmaps/gMTPicon.png
+- rm -f $(DESTDIR)$(PREFIX)/share/gconf/schemas/gmtp.schemas
++ rm -f $(DESTDIR)/etc/gconf/schemas/gmtp.schemas
+ rm -f $(DESTDIR)$(PREFIX)/share/glib-2.0/schemas/org.gnome.gMTP.gschema.xml
+ rm -f $(DESTDIR)$(PREFIX)/share/locale/es/LC_MESSAGES/gmtp.mo
+ rm -f $(DESTDIR)$(PREFIX)/share/locale/fr/LC_MESSAGES/gmtp.mo
+diff -U 3 -dHrN gMTP/pkginfo gMTP.new/pkginfo
+--- gMTP/pkginfo 2011-11-29 14:18:41.000000000 +0100
++++ gMTP.new/pkginfo 2011-12-24 11:16:57.790091128 +0100
+@@ -1,5 +1,5 @@
+ CLASSES=none
+-BASEDIR=/usr/local
++BASEDIR=/usr
+ TZ=PST
+ PATH=/sbin:/usr/sbin:/usr/bin:/usr/sadm/install/bin
+ PKG=gmtp
diff --git a/media-sound/gmtp/gmtp-1.3.1.ebuild b/media-sound/gmtp/gmtp-1.3.1.ebuild
new file mode 100644
index 000000000000..cd86ca08a040
--- /dev/null
+++ b/media-sound/gmtp/gmtp-1.3.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gmtp/gmtp-1.3.1.ebuild,v 1.1 2012/04/13 16:46:55 tomka Exp $
+
+EAPI=4
+
+inherit eutils gnome2-utils
+
+DESCRIPTION="simple MP3 player client for MTP based devices"
+HOMEPAGE="http://gmtp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PF}-i386.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/gtk+
+gnome-base/gconf
+media-libs/libmtp
+media-libs/libid3tag
+dev-libs/libusb
+media-libs/flac
+media-libs/libvorbis"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/gMTP"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PF}-makefile-gentoo.patch"
+}
+
+pkg_preinst() {
+ gnome2_gconf_savelist
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_gconf_uninstall
+ gnome2_icon_cache_update
+}