summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-05-11 03:45:38 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-05-11 03:45:38 +0000
commit45363e8a2ae7553ca61882e1ab51d37e2c7b4f12 (patch)
tree7dc7f2d440aa3a3eb0f5be75c0ee40ab2b640c3a /media-sound
parentCommiting new ebuild to fix bug #48030. This uses the kmod.eclass to use the ... (diff)
downloadgentoo-2-45363e8a2ae7553ca61882e1ab51d37e2c7b4f12.tar.gz
gentoo-2-45363e8a2ae7553ca61882e1ab51d37e2c7b4f12.tar.bz2
gentoo-2-45363e8a2ae7553ca61882e1ab51d37e2c7b4f12.zip
Version bump.
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/audacity/ChangeLog8
-rw-r--r--media-sound/audacity/Manifest2
-rw-r--r--media-sound/audacity/audacity-1.2.1.ebuild91
-rw-r--r--media-sound/audacity/files/digest-audacity-1.2.11
4 files changed, 101 insertions, 1 deletions
diff --git a/media-sound/audacity/ChangeLog b/media-sound/audacity/ChangeLog
index d48d7a4abe22..860869ef8a0c 100644
--- a/media-sound/audacity/ChangeLog
+++ b/media-sound/audacity/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/audacity
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/ChangeLog,v 1.23 2004/05/06 17:34:18 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/ChangeLog,v 1.24 2004/05/11 03:45:38 eradicator Exp $
+
+*audacity-1.2.1 (10 May 2004)
+
+ 10 May 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ audacity-1.2.1.ebuild:
+ Version bump.
06 May 2004; Jeremy Huddleston <eradicator@gentoo.org>
audacity-1.2.0-r1.ebuild:
diff --git a/media-sound/audacity/Manifest b/media-sound/audacity/Manifest
index 6563a93d612d..1ac6dea5f3b9 100644
--- a/media-sound/audacity/Manifest
+++ b/media-sound/audacity/Manifest
@@ -1,8 +1,10 @@
MD5 a3623bd9211a3bb07f20ac7bc9d74769 audacity-1.1.3.ebuild 2080
+MD5 a97d0ce292e6de4e437c8b2e00d3b819 audacity-1.2.1.ebuild 2321
MD5 3f0ebf085802276d8bb9ab4cb6d2fc04 audacity-1.2.0-r1.ebuild 2320
MD5 d731cd3b5fb77998d7d8c2e1f5ecbbc7 ChangeLog 5046
MD5 a1eaeb2ae801daeb712c90c060e922dc metadata.xml 158
MD5 3997cded5596ed884d44484d5a650a5b files/digest-audacity-1.2.0-r1 71
MD5 cb2f75d37538e9688fe397cf178f57ad files/digest-audacity-1.1.3 68
+MD5 8f1e5073472cee2da1987db62e7db3a9 files/digest-audacity-1.2.1 72
MD5 e2ae7b2007d03d608173fd4faecc1a06 files/audacity-1.2.0-STTypes.patch 499
MD5 8332a9c72a43ed19ab1904a935a25e03 files/audacity.desktop 155
diff --git a/media-sound/audacity/audacity-1.2.1.ebuild b/media-sound/audacity/audacity-1.2.1.ebuild
new file mode 100644
index 000000000000..7ff1a5cefd51
--- /dev/null
+++ b/media-sound/audacity/audacity-1.2.1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.2.1.ebuild,v 1.1 2004/05/11 03:45:38 eradicator Exp $
+
+MY_PV="${PV/_/-}"
+MY_P="${PN}-src-${MY_PV}"
+
+DESCRIPTION="A free, crossplatform audio editor."
+HOMEPAGE="http://audacity.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+IUSE="encode flac mad oggvorbis"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc"
+
+DEPEND=">=x11-libs/wxGTK-2.2.9
+ >=app-arch/zip-2.3
+ >=media-libs/id3lib-3.8.0
+ media-libs/libid3tag
+ >=media-libs/libsndfile-1.0.0
+ >=media-libs/libsamplerate-0.0.14
+ >=media-libs/ladspa-sdk-1.12
+ flac? ( media-libs/flac )
+ oggvorbis? ( >=media-libs/libvorbis-1.0 )
+ mad? ( >=media-sound/madplay-0.14 )
+ encode? ( >=media-sound/lame-3.92 )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOC="LICENSE.txt README.txt audacity-1.2-help.htb"
+
+pkg_setup() {
+ if wx-config --cppflags | grep gtk2u >& /dev/null; then
+ einfo "Audacity will not build if wxGTK was compiled"
+ einfo "with unicode support. If you are using a version of"
+ einfo "wxGTK <= 2.4.2, you must set USE=-gtk2. In newer versions,"
+ einfo "you must set USE=-unicode."
+ die "wxGTK must be re-emerged without unicode suport"
+ fi
+}
+
+src_compile() {
+ local myconf;
+
+ myconf="--with-libsndfile=system --with-id3tag=system"
+
+ # MAD support
+ if use mad; then
+ myconf="${myconf} --with-libmad=system"
+ else
+ myconf="${myconf} --with-libmad=none"
+ fi
+
+ # FLAC support
+ if use flac; then
+ myconf="${myconf} --with-libflac=system"
+ else
+ myconf="${myconf} --with-libflac=none"
+ fi
+
+ # Ogg Vorbis support
+ if use oggvorbis; then
+ myconf="${myconf} --with-vorbis=system"
+ else
+ myconf="${myconf} --with-vorbis=none"
+ fi
+
+ econf ${myconf} || die
+
+ # parallel borks
+ emake -j1 || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ # Install our docs
+ dodoc ${DOC}
+
+ # Remove bad doc install
+ rm -rf ${D}/share/doc
+
+ insinto /usr/share/gnome/apps/Multimedia
+ doins ${FILESDIR}/audacity.desktop
+ insinto /usr/share/applnk/Multimedia
+ doins ${FILESDIR}/audacity.desktop
+ insinto /usr/share/applications
+ doins ${FILESDIR}/audacity.desktop
+}
diff --git a/media-sound/audacity/files/digest-audacity-1.2.1 b/media-sound/audacity/files/digest-audacity-1.2.1
new file mode 100644
index 000000000000..582b8ec83095
--- /dev/null
+++ b/media-sound/audacity/files/digest-audacity-1.2.1
@@ -0,0 +1 @@
+MD5 8914538a3edb6f88e2f70fb2fec3790f audacity-src-1.2.1.tar.bz2 2742327