summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2006-09-18 21:16:19 +0000
committerTony Vroon <chainsaw@gentoo.org>2006-09-18 21:16:19 +0000
commit35926231862103e1ea071b44fd33c70193ea8509 (patch)
treefe149633c6ca52fee227d2216e64da19066647dd /media-sound
parentfixed CFLAGS issue (see bug #147250), removed old versions. (diff)
downloadgentoo-2-35926231862103e1ea071b44fd33c70193ea8509.tar.gz
gentoo-2-35926231862103e1ea071b44fd33c70193ea8509.tar.bz2
gentoo-2-35926231862103e1ea071b44fd33c70193ea8509.zip
Version bump to the first 1.2.0 release candidate, with separately packaged plugins.
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/audacious/ChangeLog8
-rw-r--r--media-sound/audacious/audacious-1.2.0_rc1.ebuild54
-rw-r--r--media-sound/audacious/files/digest-audacious-1.2.0_rc16
3 files changed, 67 insertions, 1 deletions
diff --git a/media-sound/audacious/ChangeLog b/media-sound/audacious/ChangeLog
index e75a15795acd..eaff5c9d21d1 100644
--- a/media-sound/audacious/ChangeLog
+++ b/media-sound/audacious/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/audacious
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.75 2006/09/16 14:35:50 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.76 2006/09/18 21:16:19 chainsaw Exp $
+
+*audacious-1.2.0_rc1 (18 Sep 2006)
+
+ 18 Sep 2006; Tony Vroon <chainsaw@gentoo.org> +audacious-1.2.0_rc1.ebuild:
+ Version bump to the first 1.2.0 release candidate, with separately packaged
+ plugins.
16 Sep 2006; Markus Rothe <corsair@gentoo.org> audacious-1.1.2.ebuild:
Stable on ppc64
diff --git a/media-sound/audacious/audacious-1.2.0_rc1.ebuild b/media-sound/audacious/audacious-1.2.0_rc1.ebuild
new file mode 100644
index 000000000000..160284c00a16
--- /dev/null
+++ b/media-sound/audacious/audacious-1.2.0_rc1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-1.2.0_rc1.ebuild,v 1.1 2006/09/18 21:16:19 chainsaw Exp $
+
+inherit flag-o-matic
+
+MY_P=${P/_/-}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://audacious-media-player.org/release/${MY_P}.tgz
+ mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="chardet nls gnome"
+
+RDEPEND=">=x11-libs/gtk+-2.6
+ >=gnome-base/libglade-2.3.1
+ dev-libs/libxml2
+ gnome? ( >=gnome-base/gconf-2.6.0 )"
+
+DEPEND="${RDEPEND}
+ nls? ( dev-util/intltool )
+ >=dev-util/pkgconfig-0.9.0"
+
+PDEPEND="media-plugins/audacious-plugins"
+
+src_compile() {
+ # Bug #42893
+ replace-flags "-Os" "-O2"
+ # Bug #86689
+ is-flag "-O*" || append-flags -O
+
+ econf \
+ $(use_enable chardet) \
+ $(use_enable nls) \
+ $(use_enable gnome gconf) \
+ || die
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README
+
+ # Gentoo_ice skin installation; bug #109772
+ insinto /usr/share/audacious/Skins/gentoo_ice
+ doins "${WORKDIR}"/gentoo_ice/*
+ docinto gentoo_ice
+ dodoc "${WORKDIR}"/README
+}
diff --git a/media-sound/audacious/files/digest-audacious-1.2.0_rc1 b/media-sound/audacious/files/digest-audacious-1.2.0_rc1
new file mode 100644
index 000000000000..450cf6a9402f
--- /dev/null
+++ b/media-sound/audacious/files/digest-audacious-1.2.0_rc1
@@ -0,0 +1,6 @@
+MD5 2329efc80cbafd836f40a0838fe753aa audacious-1.2.0-rc1.tgz 1772794
+RMD160 949cd0737830bd8929086dc9900c185998d7fbb2 audacious-1.2.0-rc1.tgz 1772794
+SHA256 29706fbf51794a492077d94379c2a764918331b3442f144186f427f5bbbf3b5a audacious-1.2.0-rc1.tgz 1772794
+MD5 41eababfa8bad11e9e34e467cdfb86be gentoo_ice-xmms-0.2.tar.bz2 51839
+RMD160 11439cbebf8c6dc5745c8593a79e88303d094544 gentoo_ice-xmms-0.2.tar.bz2 51839
+SHA256 d1be63368b76f4a8b1d5b0e955cd7a77177f56a7f0b828c6603d8fd2836422b1 gentoo_ice-xmms-0.2.tar.bz2 51839