summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-05-29 12:34:07 +0000
committerTim Harder <radhermit@gentoo.org>2012-05-29 12:34:07 +0000
commit2759da4dd7c1b9e7db6cef01e58d64c33e482fc1 (patch)
treee2ecdd87210752159edc20d44837b2df48578da4 /media-sound
parentRemove old. (diff)
downloadgentoo-2-2759da4dd7c1b9e7db6cef01e58d64c33e482fc1.tar.gz
gentoo-2-2759da4dd7c1b9e7db6cef01e58d64c33e482fc1.tar.bz2
gentoo-2-2759da4dd7c1b9e7db6cef01e58d64c33e482fc1.zip
Version bump.
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/abcmidi/ChangeLog7
-rw-r--r--media-sound/abcmidi/abcmidi-2012.05.29.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/media-sound/abcmidi/ChangeLog b/media-sound/abcmidi/ChangeLog
index 4fe3e1bc646e..2d3156de2a2a 100644
--- a/media-sound/abcmidi/ChangeLog
+++ b/media-sound/abcmidi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/abcmidi
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/abcmidi/ChangeLog,v 1.17 2012/04/22 00:02:16 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/abcmidi/ChangeLog,v 1.18 2012/05/29 12:34:07 radhermit Exp $
+
+*abcmidi-2012.05.29 (29 May 2012)
+
+ 29 May 2012; Tim Harder <radhermit@gentoo.org> +abcmidi-2012.05.29.ebuild:
+ Version bump.
*abcmidi-2012.04.15 (22 Apr 2012)
diff --git a/media-sound/abcmidi/abcmidi-2012.05.29.ebuild b/media-sound/abcmidi/abcmidi-2012.05.29.ebuild
new file mode 100644
index 000000000000..16e4484e2977
--- /dev/null
+++ b/media-sound/abcmidi/abcmidi-2012.05.29.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/abcmidi/abcmidi-2012.05.29.ebuild,v 1.1 2012/05/29 12:34:07 radhermit Exp $
+
+EAPI="4"
+
+inherit eutils versionator autotools
+
+MY_P="abcMIDI-$(replace_all_version_separators '-')"
+DESCRIPTION="Programs for processing ABC music notation files"
+HOMEPAGE="http://abc.sourceforge.net/abcMIDI/"
+SRC_URI="http://ifdo.pugmarks.com/~seymour/runabc/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2011.10.19-install.patch
+ rm configure makefile || die
+ sed -i -e "s:-O2::" configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc doc/{AUTHORS,CHANGES,abcguide.txt,abcmatch.txt,history.txt,readme.txt,yapshelp.txt}
+
+ if use examples ; then
+ docinto examples
+ dodoc samples/*.abc
+ fi
+}