summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-03-06 20:39:06 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-03-06 20:39:06 +0000
commit21e64bc608790760317d38f7eddcfeed4a1709fc (patch)
treef359b9dd976f708d84a1df0c949b9c5a32ba51a0 /media-sound
parentadd have_NPTL (diff)
downloadgentoo-2-21e64bc608790760317d38f7eddcfeed4a1709fc.tar.gz
gentoo-2-21e64bc608790760317d38f7eddcfeed4a1709fc.tar.bz2
gentoo-2-21e64bc608790760317d38f7eddcfeed4a1709fc.zip
fix compiling under NPTL ...
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/grip/ChangeLog7
-rw-r--r--media-sound/grip/files/grip-3.0.6-NPTL-compat.patch11
-rw-r--r--media-sound/grip/grip-3.0.6.ebuild21
3 files changed, 36 insertions, 3 deletions
diff --git a/media-sound/grip/ChangeLog b/media-sound/grip/ChangeLog
index 75a7662a0ed8..df9e00d4032a 100644
--- a/media-sound/grip/ChangeLog
+++ b/media-sound/grip/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for media-sound/grip
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/grip/ChangeLog,v 1.12 2003/02/17 00:19:42 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/grip/ChangeLog,v 1.13 2003/03/06 20:39:06 azarah Exp $
*grip-3.0.6 (16 Feb 2003)
+ 06 March 2003; Martin Schlemmer <azarah@gentoo.org> grip-3.0.6.ebuild :
+ The NPTL pthreads implementation do not support the
+ pthread_kill_other_threads_np function, as its a true posix threading
+ library .. patch grip thus to use pthread_kill if we are using NPTL.
+
16 Feb 2003; Arcady Genkin <agenkin@gentoo.org> :
Version bump.
diff --git a/media-sound/grip/files/grip-3.0.6-NPTL-compat.patch b/media-sound/grip/files/grip-3.0.6-NPTL-compat.patch
new file mode 100644
index 000000000000..fba9bb32e621
--- /dev/null
+++ b/media-sound/grip/files/grip-3.0.6-NPTL-compat.patch
@@ -0,0 +1,11 @@
+--- grip-3.0.6/src/cdplay.c.orig 2003-03-06 22:01:14.000000000 +0200
++++ grip-3.0.6/src/cdplay.c 2003-03-06 22:01:58.000000000 +0200
+@@ -90,7 +90,7 @@
+ #elif defined(__FreeBSD__)
+ pthread_kill(ginfo->discdb_thread,0);
+ #else
+- pthread_kill_other_threads_np();
++ pthread_kill(ginfo->discdb_thread,0);
+ #endif
+ Debug(_("Aborted\n"));
+
diff --git a/media-sound/grip/grip-3.0.6.ebuild b/media-sound/grip/grip-3.0.6.ebuild
index 39b31a0f6e52..b0f14e6e28e5 100644
--- a/media-sound/grip/grip-3.0.6.ebuild
+++ b/media-sound/grip/grip-3.0.6.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/grip/grip-3.0.6.ebuild,v 1.1 2003/02/17 00:19:42 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/grip/grip-3.0.6.ebuild,v 1.2 2003/03/06 20:39:06 azarah Exp $
+
+inherit eutils
DESCRIPTION="GTK+ based Audio CD Player/Ripper."
HOMEPAGE="http://www.nostatic.org/grip"
@@ -24,8 +26,23 @@ KEYWORDS="~x86 ~ppc"
SRC_URI="http://www.nostatic.org/grip/${P}.tar.gz"
S=${WORKDIR}/${P}
+src_unpack() {
+ unpack ${A}
+
+ # The NPTL pthreads implementation do not support the
+ # pthread_kill_other_threads_np function, as its a true
+ # posix threading library .. patch grip thus to use
+ # pthread_kill if we are using NPTL.
+ #
+ # <azarah@gentoo.org> (06 March 2003)
+ if have_NPTL
+ then
+ cd ${S}; epatch ${FILESDIR}/${P}-NPTL-compat.patch
+ fi
+}
+
src_compile() {
- local myconf
+ local myconf=
use nls || myconf="--disable-nls"
econf ${myconf} || die