summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-04-16 04:09:13 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-04-16 04:09:13 +0000
commit1e8baaf7642251d5eac7ab79cefb51fc362daef9 (patch)
treed31825e4fba6dd8639ee17bd4d076d0c3b2291e3 /media-sound
parentBump, GnuTLS support per bug #421463. Tested with USE="berkdb crypt cxx exper... (diff)
downloadgentoo-2-1e8baaf7642251d5eac7ab79cefb51fc362daef9.tar.gz
gentoo-2-1e8baaf7642251d5eac7ab79cefb51fc362daef9.tar.bz2
gentoo-2-1e8baaf7642251d5eac7ab79cefb51fc362daef9.zip
Synchronize the ebuild for 1.* with 9999 using if and else.
(Portage version: 2.2.0_alpha172/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/alsa-headers/ChangeLog8
-rw-r--r--media-sound/alsa-headers/alsa-headers-1.0.25-r1.ebuild50
-rw-r--r--media-sound/alsa-headers/alsa-headers-9999.ebuild43
3 files changed, 82 insertions, 19 deletions
diff --git a/media-sound/alsa-headers/ChangeLog b/media-sound/alsa-headers/ChangeLog
index 0d0e8ed46db0..d56f5ca79d0e 100644
--- a/media-sound/alsa-headers/ChangeLog
+++ b/media-sound/alsa-headers/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/alsa-headers
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-headers/ChangeLog,v 1.220 2013/03/13 10:57:18 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-headers/ChangeLog,v 1.221 2013/04/16 04:09:12 ssuominen Exp $
+
+*alsa-headers-1.0.25-r1 (16 Apr 2013)
+
+ 16 Apr 2013; Samuli Suominen <ssuominen@gentoo.org>
+ +alsa-headers-1.0.25-r1.ebuild, alsa-headers-9999.ebuild:
+ Synchronize the ebuild for 1.* with 9999 using if and else.
13 Mar 2013; Agostino Sarubbo <ago@gentoo.org> alsa-headers-1.0.25.ebuild:
Stable for ppc, wrt bug #406101
diff --git a/media-sound/alsa-headers/alsa-headers-1.0.25-r1.ebuild b/media-sound/alsa-headers/alsa-headers-1.0.25-r1.ebuild
new file mode 100644
index 000000000000..eaeb056ce884
--- /dev/null
+++ b/media-sound/alsa-headers/alsa-headers-1.0.25-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-headers/alsa-headers-1.0.25-r1.ebuild,v 1.1 2013/04/16 04:09:12 ssuominen Exp $
+
+EAPI=5
+
+if [[ ${PV} = 9999* ]]; then
+ inherit git-2
+else
+ MY_P=${P/headers/driver}
+ SRC_URI="mirror://alsaproject/driver/${MY_P}.tar.bz2"
+ S=${WORKDIR}/${MY_P}
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+fi
+
+inherit eutils
+
+DESCRIPTION="Header files for Advanced Linux Sound Architecture kernel modules"
+HOMEPAGE="http://www.alsa-project.org/"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+RESTRICT="binchecks strip"
+
+EGIT_REPO_URI="git://git.alsa-project.org/alsa-kmirror.git
+ http://git.alsa-project.org/http/alsa-kmirror.git"
+
+pkg_setup() {
+ local obsolete_symlink="${ROOT}"/usr/include/sound
+ if [[ -L ${obsolete_symlink} ]]; then
+ ebegin "Removing obsolete symlink ${obsolete_symlink}"
+ rm "${obsolete_symlink}"
+ eend $?
+ fi
+}
+
+src_prepare() {
+ [[ ${PV} = 9999* ]] || epatch "${FILESDIR}"/${PN}-1.0.6a-user.patch
+}
+
+src_configure() { :; }
+src_compile() { :; }
+
+src_install() {
+ [[ ${PV} = 9999* ]] || cd alsa-kernel
+ insinto /usr/include/sound
+ doins include/*.h
+}
diff --git a/media-sound/alsa-headers/alsa-headers-9999.ebuild b/media-sound/alsa-headers/alsa-headers-9999.ebuild
index 0629806ec15d..6e1256a8181f 100644
--- a/media-sound/alsa-headers/alsa-headers-9999.ebuild
+++ b/media-sound/alsa-headers/alsa-headers-9999.ebuild
@@ -1,43 +1,50 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-headers/alsa-headers-9999.ebuild,v 1.8 2011/09/21 08:11:50 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-headers/alsa-headers-9999.ebuild,v 1.9 2013/04/16 04:09:13 ssuominen Exp $
-inherit eutils git-2
+EAPI=5
+
+if [[ ${PV} = 9999* ]]; then
+ inherit git-2
+else
+ MY_P=${P/headers/driver}
+ SRC_URI="mirror://alsaproject/driver/${MY_P}.tar.bz2"
+ S=${WORKDIR}/${MY_P}
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+fi
+
+inherit eutils
DESCRIPTION="Header files for Advanced Linux Sound Architecture kernel modules"
HOMEPAGE="http://www.alsa-project.org/"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
-KEYWORDS=""
IUSE=""
-DEPEND=""
-RDEPEND=""
-
RESTRICT="binchecks strip"
EGIT_REPO_URI="git://git.alsa-project.org/alsa-kmirror.git
http://git.alsa-project.org/http/alsa-kmirror.git"
-# Remove the sound symlink workaround...
pkg_setup() {
- if [[ -L "${ROOT}/usr/include/sound" ]]; then
- rm "${ROOT}/usr/include/sound"
+ local obsolete_symlink="${ROOT}"/usr/include/sound
+ if [[ -L ${obsolete_symlink} ]]; then
+ ebegin "Removing obsolete symlink ${obsolete_symlink}"
+ rm "${obsolete_symlink}"
+ eend $?
fi
}
-src_unpack() {
- git-2_src_unpack
-
- cd "${S}"
- epatch "${FILESDIR}/${PN}-1.0.6a-user.patch"
+src_prepare() {
+ [[ ${PV} = 9999* ]] || epatch "${FILESDIR}"/${PN}-1.0.6a-user.patch
}
-src_compile() { : ; }
+src_configure() { :; }
+src_compile() { :; }
src_install() {
- cd "${S}/include"
+ [[ ${PV} = 9999* ]] || cd alsa-kernel
insinto /usr/include/sound
- doins *.h || die "include failed"
+ doins include/*.h
}