summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2011-07-25 12:52:28 +0000
committerTony Vroon <chainsaw@gentoo.org>2011-07-25 12:52:28 +0000
commit0c1dfd40db1ededd537b6bdd28d4bade940d8609 (patch)
tree8e034a75af512e9d681eb56b71d90ee53b69eb50 /media-sound
parentVersion bump. Dropped old. (diff)
downloadgentoo-2-0c1dfd40db1ededd537b6bdd28d4bade940d8609.tar.gz
gentoo-2-0c1dfd40db1ededd537b6bdd28d4bade940d8609.tar.bz2
gentoo-2-0c1dfd40db1ededd537b6bdd28d4bade940d8609.zip
First ebuild on the 3.x branch.
(Portage version: 2.1.10.7/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/audacious/ChangeLog7
-rw-r--r--media-sound/audacious/audacious-3.0.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/media-sound/audacious/ChangeLog b/media-sound/audacious/ChangeLog
index 74bc563f150e..c33cc1391bdf 100644
--- a/media-sound/audacious/ChangeLog
+++ b/media-sound/audacious/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/audacious
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.234 2011/07/15 13:29:00 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.235 2011/07/25 12:52:28 chainsaw Exp $
+
+*audacious-3.0 (25 Jul 2011)
+
+ 25 Jul 2011; Tony Vroon <chainsaw@gentoo.org> +audacious-3.0.ebuild:
+ First ebuild on the 3.x branch.
*audacious-2.5.4 (15 Jul 2011)
diff --git a/media-sound/audacious/audacious-3.0.ebuild b/media-sound/audacious/audacious-3.0.ebuild
new file mode 100644
index 000000000000..4f56b8637522
--- /dev/null
+++ b/media-sound/audacious/audacious-3.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-3.0.ebuild,v 1.1 2011/07/25 12:52:28 chainsaw Exp $
+
+EAPI=4
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://distfiles.atheme.org/${MY_P}.tar.bz2
+ mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="altivec chardet nls session sse2"
+
+RDEPEND=">=dev-libs/dbus-glib-0.60
+ >=dev-libs/glib-2.16
+ >=dev-libs/libmcs-0.7.1-r2
+ >=dev-libs/libmowgli-0.9.50
+ dev-libs/libxml2
+ >=x11-libs/cairo-1.2.6
+ >=x11-libs/gtk+-2.14:2
+ >=x11-libs/pango-1.8.0
+ session? ( x11-libs/libSM )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9.0
+ chardet? ( app-i18n/libguess )
+ nls? ( dev-util/intltool )"
+
+PDEPEND=">=media-plugins/audacious-plugins-3.0"
+
+src_configure() {
+ # D-Bus is a mandatory dependency, remote control,
+ # session management and some plugins depend on this.
+ # Building without D-Bus is *unsupported* and a USE-flag
+ # will not be added due to the bug reports that will result.
+ # Bugs #197894, #199069, #207330, #208606
+ econf \
+ --enable-dbus \
+ $(use_enable altivec) \
+ $(use_enable chardet) \
+ $(use_enable nls) \
+ $(use_enable session sm) \
+ $(use_enable sse2)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README
+
+ # Gentoo_ice skin installation; bug #109772
+ insinto /usr/share/audacious/Skins/gentoo_ice
+ doins "${WORKDIR}"/gentoo_ice/*
+ docinto gentoo_ice
+ dodoc "${WORKDIR}"/README
+}