summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-10-01 02:40:50 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-10-01 02:40:50 +0000
commit0bc123df0b869891a70e24839970e968c29e5ad7 (patch)
tree0ad8c3ac93d3fe4d9a952db83db3d7596645bf9c /media-sound
parentstable on amd64 (Manifest recommit) (diff)
downloadgentoo-2-0bc123df0b869891a70e24839970e968c29e5ad7.tar.gz
gentoo-2-0bc123df0b869891a70e24839970e968c29e5ad7.tar.bz2
gentoo-2-0bc123df0b869891a70e24839970e968c29e5ad7.zip
Added flac USE flag support.
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/xmms/xmms-1.2.10-r6.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/media-sound/xmms/xmms-1.2.10-r6.ebuild b/media-sound/xmms/xmms-1.2.10-r6.ebuild
index 6535e0d33739..5a446862b92d 100644
--- a/media-sound/xmms/xmms-1.2.10-r6.ebuild
+++ b/media-sound/xmms/xmms-1.2.10-r6.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms/xmms-1.2.10-r6.ebuild,v 1.2 2004/09/30 23:29:48 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms/xmms-1.2.10-r6.ebuild,v 1.3 2004/10/01 02:40:50 eradicator Exp $
-IUSE="xml nls esd opengl mmx oggvorbis 3dnow mikmod directfb ipv6 cjk alsa oss arts jack sndfile lirc"
+IUSE="xml nls esd opengl mmx oggvorbis 3dnow mikmod directfb ipv6 cjk alsa oss arts jack sndfile lirc flac"
inherit flag-o-matic eutils libtool gnuconfig
@@ -34,10 +34,12 @@ RDEPEND="${DEPEND}
sys-devel/gettext
app-arch/unzip"
+# USE flags pull in xmms plugins
PDEPEND="!alpha? ( !hppa? ( !ia64? ( !mips? ( !ppc64? ( jack? ( media-plugins/xmms-jack ) ) ) ) ) )
!alpha? ( !ia64? ( !ppc64? ( lirc? ( media-plugins/xmms-lirc ) ) ) )
!ia64? ( !ppc64? ( arts? ( media-plugins/xmms-arts ) ) )
- !alpha? ( !hppa? ( !ia64? ( !mips? ( !ppc64? ( sndfile? ( media-plugins/xmms-sndfile ) ) ) ) ) )"
+ !alpha? ( !hppa? ( !ia64? ( !mips? ( !ppc64? ( sndfile? ( media-plugins/xmms-sndfile ) ) ) ) ) )
+ flac? ( media-libs/flac )"
#We want these things in DEPEND only
DEPEND="${DEPEND}