summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2007-03-02 16:43:47 +0000
committerTony Vroon <chainsaw@gentoo.org>2007-03-02 16:43:47 +0000
commit056c6d04562f077ba71333e50dfe884945a3669b (patch)
tree298770db26146b5c3355b2e4481653d99fa0bde3 /media-sound
parentNew upstream release. Added libsamplerate dependency closes bug #168734. This... (diff)
downloadgentoo-2-056c6d04562f077ba71333e50dfe884945a3669b.tar.gz
gentoo-2-056c6d04562f077ba71333e50dfe884945a3669b.tar.bz2
gentoo-2-056c6d04562f077ba71333e50dfe884945a3669b.zip
New upstream release.
(Portage version: 2.1.2-r13)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/audacious/ChangeLog7
-rw-r--r--media-sound/audacious/audacious-1.3.0.ebuild60
-rw-r--r--media-sound/audacious/files/digest-audacious-1.3.06
3 files changed, 72 insertions, 1 deletions
diff --git a/media-sound/audacious/ChangeLog b/media-sound/audacious/ChangeLog
index 005f3aeaf385..030799c50134 100644
--- a/media-sound/audacious/ChangeLog
+++ b/media-sound/audacious/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/audacious
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.107 2007/02/27 15:31:41 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.108 2007/03/02 16:43:47 chainsaw Exp $
+
+*audacious-1.3.0 (02 Mar 2007)
+
+ 02 Mar 2007; Tony Vroon <chainsaw@gentoo.org> +audacious-1.3.0.ebuild:
+ New upstream release.
*audacious-1.3.0_rc2 (27 Feb 2007)
diff --git a/media-sound/audacious/audacious-1.3.0.ebuild b/media-sound/audacious/audacious-1.3.0.ebuild
new file mode 100644
index 000000000000..f28c43e53e27
--- /dev/null
+++ b/media-sound/audacious/audacious-1.3.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-1.3.0.ebuild,v 1.1 2007/03/02 16:43:47 chainsaw Exp $
+
+inherit flag-o-matic
+
+MY_P=${P/_/-}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://static.audacious-media-player.org/release/${MY_P}.tgz
+ mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="chardet nls"
+
+RDEPEND=">=x11-libs/gtk+-2.6
+ >=gnome-base/libglade-2.3.1
+ >=dev-libs/libmcs-0.4.1
+ dev-libs/libxml2"
+
+DEPEND="${RDEPEND}
+ nls? ( dev-util/intltool )
+ >=dev-util/pkgconfig-0.9.0"
+
+PDEPEND=">=media-plugins/audacious-plugins-1.3.0"
+
+src_compile() {
+ # Bug #42893
+ replace-flags "-Os" "-O2"
+ # Bug #86689
+ is-flag "-O*" || append-flags -O
+
+ econf \
+ --enable-mcs \
+ $(use_enable chardet) \
+ $(use_enable nls) \
+ || die
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README
+
+ # Gentoo_ice skin installation; bug #109772
+ insinto /usr/share/audacious/Skins/gentoo_ice
+ doins "${WORKDIR}"/gentoo_ice/*
+ docinto gentoo_ice
+ dodoc "${WORKDIR}"/README
+}
+
+pkg_postinst() {
+ elog "Note that you need to recompile *all* third-party plugins to use Audacious 1.3"
+ elog "Failure to do so may cause the player to crash. If you note any instability "
+ elog "you should unmerge all plugins (except for audacious-plugins) before you file a bug."
+}
diff --git a/media-sound/audacious/files/digest-audacious-1.3.0 b/media-sound/audacious/files/digest-audacious-1.3.0
new file mode 100644
index 000000000000..a53d03e152d1
--- /dev/null
+++ b/media-sound/audacious/files/digest-audacious-1.3.0
@@ -0,0 +1,6 @@
+MD5 8f0245cdf12258c0ff3ac63503473241 audacious-1.3.0.tgz 1745980
+RMD160 1bc57dacf7cf7908768247271b8b712597e69109 audacious-1.3.0.tgz 1745980
+SHA256 64cb7cd74224b34ccd0acffe20236ef4df970f3b8c8fe788e5ea8811cc197979 audacious-1.3.0.tgz 1745980
+MD5 41eababfa8bad11e9e34e467cdfb86be gentoo_ice-xmms-0.2.tar.bz2 51839
+RMD160 11439cbebf8c6dc5745c8593a79e88303d094544 gentoo_ice-xmms-0.2.tar.bz2 51839
+SHA256 d1be63368b76f4a8b1d5b0e955cd7a77177f56a7f0b828c6603d8fd2836422b1 gentoo_ice-xmms-0.2.tar.bz2 51839