summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-03-07 10:06:10 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-03-07 10:06:10 +0000
commit842d1dea00b0c8873071499bf655b05dae5204c8 (patch)
tree50b55a4de17f727ccb551fe57d39dc2836a7368a /media-sound/zynaddsubfx
parentversion bump (diff)
downloadgentoo-2-842d1dea00b0c8873071499bf655b05dae5204c8.tar.gz
gentoo-2-842d1dea00b0c8873071499bf655b05dae5204c8.tar.bz2
gentoo-2-842d1dea00b0c8873071499bf655b05dae5204c8.zip
version bump
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/zynaddsubfx')
-rw-r--r--media-sound/zynaddsubfx/ChangeLog7
-rw-r--r--media-sound/zynaddsubfx/zynaddsubfx-2.4.2.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/media-sound/zynaddsubfx/ChangeLog b/media-sound/zynaddsubfx/ChangeLog
index 95b14d07d8e0..b3cd86188ffa 100644
--- a/media-sound/zynaddsubfx/ChangeLog
+++ b/media-sound/zynaddsubfx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/zynaddsubfx
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/zynaddsubfx/ChangeLog,v 1.39 2012/01/05 17:34:26 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/zynaddsubfx/ChangeLog,v 1.40 2012/03/07 10:06:10 aballier Exp $
+
+*zynaddsubfx-2.4.2 (07 Mar 2012)
+
+ 07 Mar 2012; Alexis Ballier <aballier@gentoo.org> +zynaddsubfx-2.4.2.ebuild:
+ version bump
05 Jan 2012; Samuli Suominen <ssuominen@gentoo.org>
-zynaddsubfx-2.2.1-r2.ebuild, -zynaddsubfx-2.2.1-r4.ebuild,
diff --git a/media-sound/zynaddsubfx/zynaddsubfx-2.4.2.ebuild b/media-sound/zynaddsubfx/zynaddsubfx-2.4.2.ebuild
new file mode 100644
index 000000000000..ab926982fdca
--- /dev/null
+++ b/media-sound/zynaddsubfx/zynaddsubfx-2.4.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/zynaddsubfx/zynaddsubfx-2.4.2.ebuild,v 1.1 2012/03/07 10:06:10 aballier Exp $
+
+EAPI=4
+inherit eutils cmake-utils
+
+MY_P=ZynAddSubFX-${PV}
+
+DESCRIPTION="ZynAddSubFX is an opensource software synthesizer."
+HOMEPAGE="http://zynaddsubfx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/zynaddsubfx/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa +fltk jack lash"
+
+RDEPEND=">=dev-libs/mini-xml-2.2.1
+ sci-libs/fftw:3.0
+ alsa? ( media-libs/alsa-lib )
+ fltk? ( >=x11-libs/fltk-1.3:1 )
+ jack? ( media-sound/jack-audio-connection-kit )
+ lash? ( media-sound/lash )"
+# portaudio? ( media-libs/portaudio )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+# Upstream uses the following preferences: alsa > jack > portaudio
+# At least one of them must be enabled
+# We do not support portaudio, so if alsa is disabled force jack.
+REQUIRED_USE="!alsa? ( jack )"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.4.1-docs.patch
+)
+
+DOCS="ChangeLog FAQ.txt HISTORY.txt README.txt ZynAddSubFX.lsm bugs.txt"
+
+src_configure() {
+ use lash || sed -i -e 's/lash-1.0/lash_disabled/' "${S}"/src/CMakeLists.txt
+ mycmakeargs=(
+ `use fltk && echo "-DGuiModule=fltk" || echo "-DGuiModule=off"`
+ `use alsa && echo "-DOutputModule=alsa" || echo "-DOutputModule=jack"`
+ `use alsa && echo "-DAlsaMidiOutput=TRUE" || echo "-DAlsaMidiOutput=FALSE"`
+ `use jack && echo "-DJackOutput=TRUE" || echo "-DJackOutput=FALSE"`
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ insinto /usr/share/${PN}
+ doins -r "${S}"/banks "${S}"/examples
+}