summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-23 12:37:01 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-23 12:37:01 +0000
commit11dca813e25697e7c497c594a459a41b255b5ef8 (patch)
tree2582df8d228bb98a72371e2348de49787c0d39cb /media-sound/xmms
parentupdated avi4xmms (diff)
downloadgentoo-2-11dca813e25697e7c497c594a459a41b255b5ef8.tar.gz
gentoo-2-11dca813e25697e7c497c594a459a41b255b5ef8.tar.bz2
gentoo-2-11dca813e25697e7c497c594a459a41b255b5ef8.zip
non-avi'd
Diffstat (limited to 'media-sound/xmms')
-rw-r--r--media-sound/xmms/ChangeLog14
-rw-r--r--media-sound/xmms/files/digest-xmms-1.2.7-r132
-rw-r--r--media-sound/xmms/xmms-1.2.7-r11.ebuild20
-rw-r--r--media-sound/xmms/xmms-1.2.7-r13.ebuild154
4 files changed, 175 insertions, 15 deletions
diff --git a/media-sound/xmms/ChangeLog b/media-sound/xmms/ChangeLog
index ce367de6bf0c..7a58b8b39e09 100644
--- a/media-sound/xmms/ChangeLog
+++ b/media-sound/xmms/ChangeLog
@@ -1,8 +1,16 @@
# ChangeLog for media-sound/xmms
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms/ChangeLog,v 1.25 2002/07/31 16:43:34 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms/ChangeLog,v 1.26 2002/08/23 12:37:01 seemant Exp $
-xmms-1.2.7-r12 (18 Jul 2002)
+*xmms-1.2.7-r13 (23 Aug 2002)
+
+ 23 Aug 2002; Seemant Kulleen <seemant@gentoo.org> xmms-1.2.7-r13.ebuild
+ files/digest-xmms-1.2.7-r13 :
+
+ Removed all avi stuff from xmms ebuild, since the xmms folks have updated
+ the avi-xmms plugin to be statically compiled against avifile.
+
+*xmms-1.2.7-r12 (18 Jul 2002)
31 Jul 2002; Martin Schlemmer <azarah@gentoo.org> xmms-1.2.7-r12.ebuild :
Minor form fixes.
@@ -17,7 +25,7 @@ xmms-1.2.7-r12 (18 Jul 2002)
-xmms-1.2.7-r11 (30 Jun 2002)
+*xmms-1.2.7-r11 (30 Jun 2002)
30 Jun 2002; Martin Schlemmer <azarah@gentoo.org> :
This revision tries to fix all the automake/autoconf warning, etc.
diff --git a/media-sound/xmms/files/digest-xmms-1.2.7-r13 b/media-sound/xmms/files/digest-xmms-1.2.7-r13
new file mode 100644
index 000000000000..89cc7eba5fd4
--- /dev/null
+++ b/media-sound/xmms/files/digest-xmms-1.2.7-r13
@@ -0,0 +1,2 @@
+MD5 8aa14a305d1eeb1bb53dba2197ba695a xmms-1.2.7.tar.gz 2860908
+MD5 daea40648c3ae296597dcd3e78500279 xmms-1.2.7-mmx.patch.gz 14990
diff --git a/media-sound/xmms/xmms-1.2.7-r11.ebuild b/media-sound/xmms/xmms-1.2.7-r11.ebuild
index 388079ae3965..2ad630262bc1 100644
--- a/media-sound/xmms/xmms-1.2.7-r11.ebuild
+++ b/media-sound/xmms/xmms-1.2.7-r11.ebuild
@@ -44,7 +44,7 @@ src_unpack() {
# and libstdcxx.
#
# NOTE: because we change a Makefile.am here, we run auto* at the
- # bottom.
+ # bottom.
use avi && ( \
patch -p1 <${FILESDIR}/${P}-enable-avifile-plugins.patch || die
)
@@ -128,21 +128,17 @@ src_compile() {
use nls \
|| myopts="${myopts} --disable-nls"
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --mandir=/usr/share/man \
- ${myopts} || die
-
+ econf ${myopts} || die
emake || die
}
-src_install() {
+src_install() {
make prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- sysconfdir=${D}/etc \
- sysdir=${D}/usr/share/applets/Multimedia \
- GNOME_SYSCONFDIR=${D}/etc \
- install || die
+ mandir=${D}/usr/share/man \
+ sysconfdir=${D}/etc \
+ sysdir=${D}/usr/share/applets/Multimedia \
+ GNOME_SYSCONFDIR=${D}/etc \
+ install || die
dodoc AUTHORS ChangeLog COPYING FAQ NEWS README TODO
diff --git a/media-sound/xmms/xmms-1.2.7-r13.ebuild b/media-sound/xmms/xmms-1.2.7-r13.ebuild
new file mode 100644
index 000000000000..f3b94acaeaca
--- /dev/null
+++ b/media-sound/xmms/xmms-1.2.7-r13.ebuild
@@ -0,0 +1,154 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms/xmms-1.2.7-r13.ebuild,v 1.1 2002/08/23 12:37:01 seemant Exp $
+
+inherit libtool
+
+S=${WORKDIR}/${P}
+DESCRIPTION="X MultiMedia System"
+SRC_URI="http://www.xmms.org/files/1.2.x/${P}.tar.gz
+ mmx? ( http://members.jcom.home.ne.jp/jacobi/linux/etc/${P}-mmx.patch.gz )"
+HOMEPAGE="http://www.xmms.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc"
+
+RDEPEND="app-arch/unzip
+ =x11-libs/gtk+-1.2*
+ mikmod? ( >=media-libs/libmikmod-3.1.6 )
+ esd? ( >=media-sound/esound-0.2.22 )
+ xml? ( >=dev-libs/libxml-1.8.15 )
+ gnome? ( <gnome-base/gnome-panel-1.5.0 )
+ opengl? ( virtual/opengl )
+ oggvorbis? ( >=media-libs/libvorbis-1.0_beta4 )"
+
+
+DEPEND="${RDEPEND}
+ nls? ( dev-util/intltool )"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ cd ${S}
+
+ # The following optimisations are ONLY for x86 platform
+ use x86 && ( \
+ # For mmx/3dnow enabled CPUs, this patch adds mmx/3dnow optimisations
+ #
+ # ( use mmx || use 3dnow ) && \
+ # cat ${DISTDIR}/${P}-mmx.patch.gz | gunzip -c | patch -p1 || die
+ #
+ # For you guys who favour this kind of USE flag checking ... this
+ # is exactly why I do NOT like it, because the actual
+ # "cat ${DISTDIR}/${P}-mmx.patch.gz | gunzip -c | patch -p1 || die"
+ # was not in a subshell, it would ALWAYS fail to build if "mmx" or
+ # "3dnow" was not in USE, because of the || die at the end. So
+ # PLEASE, PLEASE test things with all possible USE flags if you use
+ # this style!!!! Then, if in a subshell, it do not detect if the
+ # command fails :/
+ #
+ # Azarah - 30 Jun 2002
+ #
+ if use mmx || use 3dnow
+ then
+ cat ${DISTDIR}/${P}-mmx.patch.gz | gunzip -c | patch -p1 || die
+ fi
+ )
+
+ [ ! -f ${S}/config.rpath ] && ( \
+ touch ${S}/config.rpath
+ chmod +x ${S}/config.rpath
+ )
+
+ # We run automake and autoconf here else we get a lot of warning/errors.
+ # I have tested this with gcc-2.95.3 and gcc-3.1.
+ elibtoolize
+ echo ">>> Reconfiguring..."
+ for x in ${S} ${S}/libxmms
+ do
+ cd ${x}
+ aclocal
+ export WANT_AUTOCONF_2_5=1
+ automake --gnu --include-deps Makefile || die
+ autoconf || die
+ done
+}
+
+src_compile() {
+ local myconf=""
+
+ use gnome \
+ && myconf="${myconf} --with-gnome" \
+ || myconf="${myconf} --without-gnome"
+
+ use 3dnow || use mmx \
+ && myconf="${myconf} --enable-simd" \
+ || myconf="${myconf} --disable-simd"
+
+ use esd \
+ && myconf="${myconf} --enable-esd --enable-esdtest" \
+ || myconf="${myconf} --disable-esd --disable-esdtest"
+
+ use mikmod \
+ && myconf="${myconf} --enable-mikmod --enable-mikmodtest \
+ --with-libmikmod" \
+ || myconf="${myconf} --disable-mikmod --disable-mikmodtest \
+ --without-libmikmod"
+
+ use opengl \
+ && myconf="${myconf} --enable-opengl" \
+ || myconf="${myconf} --disable-opengl"
+
+ use oggvorbis \
+ && myconf="${myconf} --enable-vorbis --enable-oggtest \
+ --enable-vorbistest --with-ogg" \
+ || myconf="${myconf} --disable-vorbis --disable-oggtest \
+ --disable-vorbistest --without-ogg"
+
+ use xml \
+ || myconf="${myconf} --disable-cdindex"
+
+ use nls \
+ || myconf="${myconf} --disable-nls"
+
+ econf ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+
+ einstall \
+ sysdir=${D}/usr/share/applets/Multimedia \
+ GNOME_SYSCONFDIR=${D}/etc || die
+
+ dodoc AUTHORS ChangeLog COPYING FAQ NEWS README TODO
+
+ dodir /usr/share/xmms/Skins
+ insinto /usr/share/pixmaps/
+ donewins gnomexmms/gnomexmms.xpm xmms.xpm
+ doins xmms/xmms_logo.xpm
+ insinto /usr/share/pixmaps/mini
+ doins xmms/xmms_mini.xpm
+
+ insinto /etc/X11/wmconfig
+ donewins xmms/xmms.wmconfig xmms
+
+ use gnome && ( \
+ insinto /usr/share/gnome/apps/Multimedia
+ doins xmms/xmms.desktop
+ dosed "s:xmms_mini.xpm:mini/xmms_mini.xpm:" \
+ /usr/share/gnome/apps/Multimedia/xmms.desktop
+ ) || ( \
+ rm ${D}/usr/share/man/man1/gnomexmms*
+ )
+}
+
+pkg_postrm() {
+
+ if [ -x ${ROOT}/usr/bin/xmms ] && [ ! -d ${ROOT}/usr/share/xmms/Skins ]
+ then
+ mkdir -p ${ROOT}/usr/share/xmms/Skins
+ fi
+}