summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2009-03-28 16:29:09 +0000
committerChristoph Mende <angelos@gentoo.org>2009-03-28 16:29:09 +0000
commiteee25748eac03fdf2b75a9dbe36e0c2f12b6254a (patch)
treeb69623a4957b1e0379a8d4d6a99a34e2c5ffe5c0 /media-sound/xfmpc
parentMask 2.6.29 for HPPA - all the rc's I tested were fine, but not the final. (diff)
downloadgentoo-2-eee25748eac03fdf2b75a9dbe36e0c2f12b6254a.tar.gz
gentoo-2-eee25748eac03fdf2b75a9dbe36e0c2f12b6254a.tar.bz2
gentoo-2-eee25748eac03fdf2b75a9dbe36e0c2f12b6254a.zip
Version bump
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/xfmpc')
-rw-r--r--media-sound/xfmpc/ChangeLog9
-rw-r--r--media-sound/xfmpc/xfmpc-0.1.0.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/media-sound/xfmpc/ChangeLog b/media-sound/xfmpc/ChangeLog
index b02b88459455..b7f3f15e2db3 100644
--- a/media-sound/xfmpc/ChangeLog
+++ b/media-sound/xfmpc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/xfmpc
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/xfmpc/ChangeLog,v 1.7 2008/11/14 19:48:22 armin76 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xfmpc/ChangeLog,v 1.8 2009/03/28 16:29:09 angelos Exp $
+
+*xfmpc-0.1.0 (28 Mar 2009)
+
+ 28 Mar 2009; Christoph Mende <angelos@gentoo.org> +xfmpc-0.1.0.ebuild:
+ Version bump
14 Nov 2008; Raúl Porcel <armin76@gentoo.org> xfmpc-0.0.7.ebuild:
sparc stable wrt #244795
diff --git a/media-sound/xfmpc/xfmpc-0.1.0.ebuild b/media-sound/xfmpc/xfmpc-0.1.0.ebuild
new file mode 100644
index 000000000000..c5b5dcd83e8a
--- /dev/null
+++ b/media-sound/xfmpc/xfmpc-0.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xfmpc/xfmpc-0.1.0.ebuild,v 1.1 2009/03/28 16:29:09 angelos Exp $
+
+inherit fdo-mime
+
+DESCRIPTION="a GTK+ based MPD client focusing on low footprint."
+HOMEPAGE="http://goodies.xfce.org/projects/applications/xfmpc"
+SRC_URI="http://goodies.xfce.org/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND=">=media-libs/libmpd-0.15
+ >=x11-libs/gtk+-2.12
+ x11-themes/hicolor-icon-theme
+ >=xfce-base/libxfcegui4-4.4
+ >=xfce-base/libxfce4util-4.4"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf --disable-dependency-tracking $(use_enable debug)
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog IDEAS NEWS README THANKS
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}