summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-06-19 10:50:46 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-06-19 10:50:46 +0000
commit2756669be92719399b73e89c756b5c92684eb3f7 (patch)
tree23dd2030545df2e377fc5bdb72d851df112fd883 /media-sound/wavegain
parentstable x86, bug 245345 (diff)
downloadgentoo-2-2756669be92719399b73e89c756b5c92684eb3f7.tar.gz
gentoo-2-2756669be92719399b73e89c756b5c92684eb3f7.tar.bz2
gentoo-2-2756669be92719399b73e89c756b5c92684eb3f7.zip
respect ldflags
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/wavegain')
-rw-r--r--media-sound/wavegain/wavegain-1.2.6.ebuild18
1 files changed, 12 insertions, 6 deletions
diff --git a/media-sound/wavegain/wavegain-1.2.6.ebuild b/media-sound/wavegain/wavegain-1.2.6.ebuild
index bf2d845cbf7c..5193d0af9f20 100644
--- a/media-sound/wavegain/wavegain-1.2.6.ebuild
+++ b/media-sound/wavegain/wavegain-1.2.6.ebuild
@@ -1,25 +1,31 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/wavegain/wavegain-1.2.6.ebuild,v 1.2 2009/05/14 19:33:17 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/wavegain/wavegain-1.2.6.ebuild,v 1.3 2009/06/19 10:50:46 ssuominen Exp $
inherit toolchain-funcs
+MY_P=${P/wavegain/WaveGain}
+
DESCRIPTION="ReplayGain for WAVE audio files"
HOMEPAGE="http://www.rarewares.org/files/others"
SRC_URI="http://www.rarewares.org/files/others/${P}srcs.zip"
-MY_P="${P/wavegain/WaveGain}"
-S="${WORKDIR}/${MY_P}"
+
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
+
RDEPEND="media-libs/libsndfile"
-DEPEND="app-arch/unzip"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}
src_compile(){
- $(tc-getCC) ${CFLAGS} *.c -o wavegain -DHAVE_CONFIG_H -lm -lsndfile
+ $(tc-getCC) ${LDFLAGS} ${CFLAGS} *.c -o ${PN} \
+ -DHAVE_CONFIG_H -lm -lsndfile || die "build failed"
}
src_install(){
- dobin wavegain
+ dobin ${PN} || die "dobin failed"
}