summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2008-12-07 05:43:49 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2008-12-07 05:43:49 +0000
commit37603819629a688c90bb63646d31e4ad9b1117a8 (patch)
treef125f4b393fc94a1242de26dc040d9bd4f8c6e27 /media-sound/tunapie
parenttake over maintaince of the package (diff)
downloadgentoo-2-37603819629a688c90bb63646d31e4ad9b1117a8.tar.gz
gentoo-2-37603819629a688c90bb63646d31e4ad9b1117a8.tar.bz2
gentoo-2-37603819629a688c90bb63646d31e4ad9b1117a8.zip
Version bump for bug 250108, thanks to Hans Meier.
(Portage version: 2.1.6_rc3/cvs/Linux 2.6.27.7 i686)
Diffstat (limited to 'media-sound/tunapie')
-rw-r--r--media-sound/tunapie/ChangeLog7
-rw-r--r--media-sound/tunapie/tunapie-2.1.13.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/media-sound/tunapie/ChangeLog b/media-sound/tunapie/ChangeLog
index 82a505dc0061..b533079de407 100644
--- a/media-sound/tunapie/ChangeLog
+++ b/media-sound/tunapie/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/tunapie
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/tunapie/ChangeLog,v 1.6 2008/11/24 16:13:22 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/tunapie/ChangeLog,v 1.7 2008/12/07 05:43:49 ssuominen Exp $
+
+*tunapie-2.1.13 (07 Dec 2008)
+
+ 07 Dec 2008; <ssuominen@gentoo.org> +tunapie-2.1.13.ebuild:
+ Version bump for bug 250108, thanks to Hans Meier.
24 Nov 2008; <ssuominen@gentoo.org> metadata.xml:
Re-assign to sound herd.
diff --git a/media-sound/tunapie/tunapie-2.1.13.ebuild b/media-sound/tunapie/tunapie-2.1.13.ebuild
new file mode 100644
index 000000000000..3d2b5efa7d88
--- /dev/null
+++ b/media-sound/tunapie/tunapie-2.1.13.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/tunapie/tunapie-2.1.13.ebuild,v 1.1 2008/12/07 05:43:49 ssuominen Exp $
+
+inherit eutils multilib python
+
+DESCRIPTION="Directory browser for Radio and TV streams"
+HOMEPAGE="http://tunapie.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="offensive"
+
+RDEPEND="=dev-python/wxpython-2.6*"
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s:/usr/local/share:/usr/$(get_libdir):" \
+ "${S}"/${PN} || die "sed failed."
+}
+
+src_install() {
+ dobin ${PN} || die "dobin failed."
+ doman ${PN}.1
+ dodoc CHANGELOG README
+
+ domenu ${PN}.desktop
+ doicon src/tplogo.xpm
+
+ insinto /usr/$(get_libdir)/${PN}
+ doins src/{*.py,*.png} || die "doins failed."
+
+ dodir /etc
+
+ if use offensive; then
+ echo 1 > "${D}"/etc/${PN}.config
+ else
+ echo 0 > "${D}"/etc/${PN}.config
+ fi
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/${PN}
+}