summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-07 16:05:23 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-07 16:05:23 +0000
commitedd73c4a80d62ef2b90b6c87d38610fcac3aab2d (patch)
tree87ec0f762a2d49d0e9428c3fda9b9895559a5b49 /media-sound/toolame/toolame-02l-r2.ebuild
parentAdd ~sparc keyword (Bug #122726). (diff)
downloadgentoo-2-edd73c4a80d62ef2b90b6c87d38610fcac3aab2d.tar.gz
gentoo-2-edd73c4a80d62ef2b90b6c87d38610fcac3aab2d.tar.bz2
gentoo-2-edd73c4a80d62ef2b90b6c87d38610fcac3aab2d.zip
Drop virtual/libc dependency. Respect LDFLAGS.
(Portage version: 2.1_pre5-r4)
Diffstat (limited to 'media-sound/toolame/toolame-02l-r2.ebuild')
-rw-r--r--media-sound/toolame/toolame-02l-r2.ebuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/media-sound/toolame/toolame-02l-r2.ebuild b/media-sound/toolame/toolame-02l-r2.ebuild
index 2d37a0f749f6..7415dbb3201c 100644
--- a/media-sound/toolame/toolame-02l-r2.ebuild
+++ b/media-sound/toolame/toolame-02l-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/toolame/toolame-02l-r2.ebuild,v 1.1 2005/08/25 12:21:58 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/toolame/toolame-02l-r2.ebuild,v 1.2 2006/03/07 16:05:23 flameeyes Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -14,21 +14,17 @@ SLOT="0"
LICENSE="LGPL-2.1"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-DEPEND="virtual/libc
- sys-devel/gcc"
-
src_unpack() {
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/${P}-gentoo.diff
- epatch ${FILESDIR}/${P}-uint.patch
+ epatch "${FILESDIR}/${P}-gentoo.diff"
+ epatch "${FILESDIR}/${P}-uint.patch"
}
src_compile() {
# Enable largefile support, as toolame doesn't use autoconf
- ( use elibc_glibc || use elibc_uclibc ) && \
- append-flags "-D_FILE_OFFSET_BITS=64"
+ append-lfs-flags
tc-export CC