summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-09-12 14:42:43 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-09-12 14:42:43 +0000
commit0909782a365b80966719a22cfddc529d51b8dbd5 (patch)
treee641fc6b5fc0b502711886f517c73957c2963388 /media-sound/tempest_for_eliza
parentMake this respect LDFLAGS, bug #334987 (by Flameeyes). (diff)
downloadgentoo-2-0909782a365b80966719a22cfddc529d51b8dbd5.tar.gz
gentoo-2-0909782a365b80966719a22cfddc529d51b8dbd5.tar.bz2
gentoo-2-0909782a365b80966719a22cfddc529d51b8dbd5.zip
Respect LDFLAGS. Bug #335533
(Portage version: 2.2_rc78/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/tempest_for_eliza')
-rw-r--r--media-sound/tempest_for_eliza/ChangeLog10
-rw-r--r--media-sound/tempest_for_eliza/tempest_for_eliza-1.0.5-r1.ebuild38
2 files changed, 46 insertions, 2 deletions
diff --git a/media-sound/tempest_for_eliza/ChangeLog b/media-sound/tempest_for_eliza/ChangeLog
index f04c4976c973..40dde2be36aa 100644
--- a/media-sound/tempest_for_eliza/ChangeLog
+++ b/media-sound/tempest_for_eliza/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/tempest_for_eliza
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/tempest_for_eliza/ChangeLog,v 1.9 2009/05/11 08:31:35 ssuominen Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/tempest_for_eliza/ChangeLog,v 1.10 2010/09/12 14:42:43 hwoarang Exp $
+
+*tempest_for_eliza-1.0.5-r1 (12 Sep 2010)
+
+ 12 Sep 2010; Markos Chandras <hwoarang@gentoo.org>
+ +tempest_for_eliza-1.0.5-r1.ebuild:
+ Respect LDFLAGS. Bug #335533
11 May 2009; Samuli Suominen <ssuominen@gentoo.org>
tempest_for_eliza-1.0.5.ebuild:
diff --git a/media-sound/tempest_for_eliza/tempest_for_eliza-1.0.5-r1.ebuild b/media-sound/tempest_for_eliza/tempest_for_eliza-1.0.5-r1.ebuild
new file mode 100644
index 000000000000..03682377763e
--- /dev/null
+++ b/media-sound/tempest_for_eliza/tempest_for_eliza-1.0.5-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/tempest_for_eliza/tempest_for_eliza-1.0.5-r1.ebuild,v 1.1 2010/09/12 14:42:43 hwoarang Exp $
+
+EAPI=2
+inherit toolchain-funcs
+
+DESCRIPTION="listen to music on the radio generated by images on your screen"
+HOMEPAGE="http://www.erikyyy.de/tempest/"
+SRC_URI="http://www.erikyyy.de/tempest/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ tc-export CXX
+ econf \
+ --enable-debug \
+ --enable-nowarnerror
+}
+
+src_compile() {
+ emake CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README
+
+ rm songs/Makefile*
+ insinto /usr/share/${PN}
+ doins songs/* || die "doins failed"
+}