summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-03-04 19:49:54 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-03-04 19:49:54 +0000
commitfaa855feb157a3015a3ab3e123ec6114b7b34824 (patch)
tree480e98446081051abb157e33dc1e0d5b1f33d714 /media-sound/teamspeak2-client-bin
parentgpl2, forget the later (diff)
downloadgentoo-2-faa855feb157a3015a3ab3e123ec6114b7b34824.tar.gz
gentoo-2-faa855feb157a3015a3ab3e123ec6114b7b34824.tar.bz2
gentoo-2-faa855feb157a3015a3ab3e123ec6114b7b34824.zip
ebuild cleanup
Diffstat (limited to 'media-sound/teamspeak2-client-bin')
-rw-r--r--media-sound/teamspeak2-client-bin/ChangeLog6
-rw-r--r--media-sound/teamspeak2-client-bin/teamspeak2-client-bin-2.0.32.60-r2.ebuild82
2 files changed, 57 insertions, 31 deletions
diff --git a/media-sound/teamspeak2-client-bin/ChangeLog b/media-sound/teamspeak2-client-bin/ChangeLog
index e1641e0bf7a1..81c023f0c839 100644
--- a/media-sound/teamspeak2-client-bin/ChangeLog
+++ b/media-sound/teamspeak2-client-bin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/teamspeak2-client-bin
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/teamspeak2-client-bin/ChangeLog,v 1.5 2004/03/04 00:34:55 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/teamspeak2-client-bin/ChangeLog,v 1.6 2004/03/04 19:49:54 eradicator Exp $
+
+ 04 Mar 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ teamspeak2-client-bin-2.0.32.60-r2.ebuild:
+ ebuild cleanup
*teamspeak2-client-bin-2.0.32.60-r2 (03 Mar 2004)
diff --git a/media-sound/teamspeak2-client-bin/teamspeak2-client-bin-2.0.32.60-r2.ebuild b/media-sound/teamspeak2-client-bin/teamspeak2-client-bin-2.0.32.60-r2.ebuild
index 6c4b5f1efb86..ffc58e40c85f 100644
--- a/media-sound/teamspeak2-client-bin/teamspeak2-client-bin-2.0.32.60-r2.ebuild
+++ b/media-sound/teamspeak2-client-bin/teamspeak2-client-bin-2.0.32.60-r2.ebuild
@@ -1,60 +1,80 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/teamspeak2-client-bin/teamspeak2-client-bin-2.0.32.60-r2.ebuild,v 1.3 2004/03/04 18:15:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/teamspeak2-client-bin/teamspeak2-client-bin-2.0.32.60-r2.ebuild,v 1.4 2004/03/04 19:49:54 eradicator Exp $
MY_PV=rc2_2032
-DESCRIPTION="The Teamspeak Voice Communication Tool"
-HOMEPAGE="http://www.teamspeak.org/"
+DESCRIPTION="The TeamSpeak voice communication tool"
+HOMEPAGE="http://www.teamspeak.org"
SRC_URI="ftp://teamspeak.krawall.de/releases/ts2_client_${MY_PV}.tar.bz2"
LICENSE="as-is"
SLOT="0"
KEYWORDS="~x86"
+
IUSE="kde"
-# Note: ts2 client comes with its own speex library, so no need to
-# depend on it
-DEPEND="virtual/x11
- virtual/glibc
- kde? ( >=kde-base/kdelibs-3.1.0 )"
+RDEPEND="virtual/x11"
+
+DEPEND="${DEPEND}
+ kde? ( >=kde-base/kdelibs-3.1.0 )
+ imagemagick? ( media-gfx/imagemagick )"
+
+S="${WORKDIR}/ts2_client_${MY_PV}/setup.data/image"
-S=${WORKDIR}/ts2_client_${MY_PV}/setup.data/image
+src_compile() {
+ if use imagemagick; then
+ convert icon.xpm teamspeak.png
+ fi
+}
src_install() {
local dir="/opt/teamspeak2-client"
- dodir ${dir}
- # Edit the Teamspeak startscript to match our install directory
- sed -i -e "s:%installdir%:${dir}:g" TeamSpeak
+ newdoc Readme.txt README
+ dodoc client_sdk/SDK_readme.txt
+ dohtml manual/*
- if use kde ; then
- # Install a teamspeak.protocol file for kde/konqueror to accept
- # teamspeak:// links
- insinto $(kde-config --prefix)/share/services/
- doins ${FILESDIR}/teamspeak.protocol
- fi
+ into /opt
+ dobin ${FILESDIR}/TeamSpeak
+ dosed "s:%installdir%:/opt/teamspeak2-client:g" /opt/bin/TeamSpeak
- # The next three are removed after the operation so that they are not
- # copied into the install directory
- dobin TeamSpeak && rm TeamSpeak
- newdoc Readme.txt README && rm Readme.txt
- dohtml -r manual/* && rm -rf manual
+ exeinto ${dir}
+ doexe TeamSpeak.bin *.so*
- # A symlink is created so that Help -> Read Manual still works
- dosym /usr/share/doc/${PF}/html ${dir}/manual
+ insinto ${dir}/sounds
+ doins sounds/*
- # All regular files except the executables are made non executable
- find -type f -not \( -name "TeamSpeak.bin" -or -name "*.so*" -or \
- -name "tsControl" \) -exec chmod -x {} \;
+ insinto ${dir}/client_sdk
+ exeinto ${dir}/client_sdk
+ doins client_sdk/*.pas client_sdk/*.dpr
+ doexe client_sdk/tsControl client_sdk/*.so*
#Install the teamspeak icon.
insinto /usr/share/pixmaps
- newins ${S}/icon.xpm ${S}/teamspeak.xpm
+ if use imagemagick; then
+ doins teamspeak.png
+ fi
+ newins icon.xpm teamspeak.xpm
- cp -r * ${D}/${dir} || die "cp failed"
+ if [ `use kde` ] ; then
+ # Install a teamspeak.protocol file for kde/konqueror to accept
+ # teamspeak:// links
+ insinto $(kde-config --prefix)/share/services/
+ doins ${FILESDIR}/teamspeak.protocol
+ fi
}
pkg_postinst() {
+
+ echo
+ einfo
+ einfo "Please Note: The new Teamspeak2 Release Candidate 2 Client"
+ einfo "will not be able to connect to any of the *old* rc1 servers."
+ einfo "if you get 'Bad response' from your server check if your"
+ einfo "server is running rc2, which is a version >= 2.0.19.16."
+ einfo "Also note this release supports the new speex codec, "
+ einfo "so if you got unsupported codec messages, you need this :D"
+ echo
einfo "Note: If you just upgraded from a version less than 2.0.32.60-r1,"
einfo "your users' config files will incorrectly point to non-existant"
einfo "soundfiles because they've been moved from their old location."
@@ -63,4 +83,6 @@ pkg_postinst() {
einfo "# ln -s ${dir}/sounds /usr/share/teamspeak2-client/sounds"
einfo "This way, each user won't have to modify their config files to"
einfo "reflect this move."
+ echo
}
+